<!DOCTYPE html>
			    	<html lang="en">

	<head>
										<meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
<meta http-equiv="X-UA-Compatible"  content="IE=edge" />
<meta name="viewport" content="width=100%,initial-scale=1.0,maximum-scale=2.0" />
   	 	 			<link rel="canonical" href="https://www.newsday.com/long-island/suffolk/100th-birthday-huntington-link-parade-1.50142835" />
					    	 	 	 <link rel="amphtml" href="https://www.newsday.com/amp/long-island/suffolk/100th-birthday-huntington-link-parade-1.50142835">
					 <meta name="apple-itunes-app" content="app-id=358571317, affiliate-data=, app-argument=https://itunes.apple.com/us/app/newsday/id358571317?mt=8">
											    <link rel="alternate" href="android-app://com.pagesuite.newsday/https://www.newsday.com/json/long-island/suffolk/100th-birthday-huntington-link-parade-1.50142835" />
    <link rel="alternate" href="ios-app://com.pagesuite.newsday/https://www.newsday.com/json/long-island/suffolk/100th-birthday-huntington-link-parade-1.50142835" />
<title>Twenty-car parade honors ex-teacher from Huntington on her 100th birthday | Newsday</title>
<meta name="description" content="In celebrating her 100th birthday Thursday, Alice Link announced some plans. &quot;I&rsquo;m aiming for 118,&quot; Link said outside her Huntington home just before a line of vehicles festooned with ribbons, balloons" />
<meta name="msvalidate.01" content="AC41EB10D1EC6B5358F0ECA0E861CCAA" />
<meta name="theme-color" content="#0077c8" />
<link rel="shortcut icon" href="/img/newsday/favicon.ico" type="image/x-icon" />
<link rel="apple-touch-icon" href="/img/newsday/apple-touch-icon.png" />
<link rel="apple-touch-icon" sizes="57x57" href="/img/newsday/apple-touch-icon-57x57.png" />
<link rel="apple-touch-icon" sizes="72x72" href="/img/newsday/apple-touch-icon-72x72.png" />
<link rel="apple-touch-icon" sizes="76x76" href="/img/newsday/apple-touch-icon-76x76.png" />
<link rel="apple-touch-icon" sizes="114x114" href="/img/newsday/apple-touch-icon-114x114.png" />
<link rel="apple-touch-icon" sizes="120x120" href="/img/newsday/apple-touch-icon-120x120.png" />
<link rel="apple-touch-icon" sizes="144x144" href="/img/newsday/apple-touch-icon-144x144.png" />
<link rel="apple-touch-icon" sizes="152x152" href="/img/newsday/apple-touch-icon-152x152.png" />
<link rel="apple-touch-icon" href="/img/newsday/apple-touch-icon-precomposed.png" />
<meta name="google-site-verification" content="WS-IPs_DqbPtrQ9XhKPi_32a-1spE4tjsjhWUqwVVns" />
<meta name="application-name" content="Newsday"/>
<meta name="msapplication-TileColor" content="#1B3664"/>
<meta name="msapplication-TileImage" content="/img/newsday/nd-win8-icon.png"/>
<link href="https://plus.google.com/111657400568598461034" rel="publisher" />
<meta name="p:domain_verify" content="b22f651177478af415d53d6eb00b8167"/>
<meta property="fb:pages" content="19175874448" />
 		        	<meta property="ia:markup_url" content="https://www.newsday.com/facebook/long-island/suffolk/100th-birthday-huntington-link-parade-1.50142835">
   	<meta property="article:content_tier" content="metered"/>
      <meta property="article:opinion" content="false"/>
          <link rel="image_src" href="https://www.newsday.com/img/blog-share-nd.jpg" />
<meta name="news_keywords" content="long island,local,newsday,source">
<meta property="og:title" content="Twenty-car parade honors ex-teacher on her 100th birthday"/>
<meta property="og:url" content="https://www.newsday.com/long-island/suffolk/100th-birthday-huntington-link-parade-1.50142835"/>
<meta property="og:image" content="https://www.newsday.com/img/blog-share-nd.jpg"/>
<meta property="og:site_name" content="Newsday"/>
<meta property="og:description" content="In celebrating her 100th birthday Thursday, Alice Link announced some plans. &quot;I&rsquo;m aiming for 118,&quot; Link said outside her Huntington home just before a line of vehicles festooned with ribbons, balloons"/>
   <meta property="og:type" content="article"/>
 <meta property="fb:app_id" content="147686468041"/>
<meta name="twitter:card" content="summary_large_image"/>
<meta name="twitter:site" content="@Newsday"/>
<meta name="twitter:title" content="Twenty-car parade honors ex-teacher on her 100th birthday"/>
<meta name="twitter:description" content="In celebrating her 100th birthday Thursday, Alice Link announced some plans. &quot;I&rsquo;m aiming for 118,&quot; Link said outside her Huntington home just before a line of vehicles festooned with ribbons, balloons"/>
<meta name="twitter:image" content="https://www.newsday.com/img/blog-share-nd.jpg"/>
            	    	      <meta name="twitter:creator" content="@dsvmorris"/>
<meta name="twitter:app:id:iphone" content="358571317"/>
<meta name="twitter:app:id:ipad" content="358571317"/>
<meta name="twitter:app:id:googleplay" content="com.pagesuite.newsday"/>
 <link rel="alternate" type="application/rss+xml" title="Newsday Top Stories" href="https://www.newsday.com/xml/1.1251995"/>
 <meta name="sailthru.date" content="Thu, 04 Feb 2021 16:20:12 -0500" />
 <meta name="sailthru.title" content="Twenty-car parade honors ex-teacher on her 100th birthday" />
 <meta name="sailthru.tags" content="long island,local,newsday,source" />
 <meta name="sailthru.author" content="Deborah S. Morris" />
<meta name="isDesktop" content="true">
				<script>
  //make nd_css available early, just like gAds
  window.nd_css = {queue: []};
</script>
<script src="https://cdn.p-n.io/pushly-sdk.min.js?domain_key=Cg42p96hLQLxIfwvT2auEs3ugoWYzaGqjUYN" async></script>
<script>
  var PushlySDK = window.PushlySDK || [];
  function pushly() { PushlySDK.push(arguments) }
  pushly('load', {
    domainKey: 'Cg42p96hLQLxIfwvT2auEs3ugoWYzaGqjUYN',
    sw: '/push-worker.js?v=n2101.1',
  });
</script>
<!-- preconnect to frequently used dependency domains -->
<link rel="preconnect" href="https://securepubads.g.doubleclick.net" />
<link rel="preconnect" href="https://c.amazon-adsystem.com" />
<link rel="preconnect" href="https://newsday.demdex.net" />
<link rel="preconnect" href="https://loader-cdn.azureedge.net" />
<link rel="preconnect" href="https://edge.api.brightcove.com" />
<link rel="preconnect" href="https://projects.newsday.com" />
<link rel="preconnect" href="https://cdn.cookielaw.org" />
<link rel="preconnect" href="https://cookie-cdn.cookiepro.com" />

<style>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</style>
					<link href="/shell/css/nd-article-secondary.min.css?v=n2101.1" rel="preload" type="text/css" as='style' onload='window.nd_css.queue.push(this);'/>
	
<noscript>
				<link href="/shell/css/nd-article-secondary.min.css?v=n2101.1" rel="stylesheet" type="text/css" />
	</noscript>
          <style>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</style>

<script>
var dnc_vid_id;
var dnc_player;

window.addEventListener("DOMContentLoaded", function(){ 
	console.log("Tweaking DOM");
	dnc_player = document.querySelector("[data-video-id='6181858609001']");
        if (!!dnc_player) {
 	  dnc_player.dataset.config = JSON.stringify({muted: true, autoplay: true, playsinline: true});

 	  dnc_video_override();
        }
});

var dnc_video_override = function(){
	if(typeof videojs !== "undefined"){
		dnc_player = document.querySelector("[data-video-id='6181858609001']");
		dnc_vid_id = dnc_player.id;
		
		var dnc_player_js = videojs.getPlayer(dnc_vid_id);

		if(!dnc_player_js){
			setTimeout(function(){
				dnc_video_override();
			}, 250);
		} else{
			console.log("Binding to play");
			dnc_player_js.on("play", function(e){
				console.log("Playback began. Disabling mouseover");
				$(dnc_player).off();
			});
		}
	} else{
		setTimeout(function(){
			dnc_video_override();
		}, 250);
	}
}


</script>
   							<script defer src="/shell/js/ads.min.js?v=n2101.1"></script>
			<script src="//www.newsday.com/js/launch-prod/launch-ENe1484b2b97da4cf1bd7f7a777f05562c.min.js?v=n2101.1" async></script>
			</head>
				
			<body id="long-island" class="newsday  ">
																																				<header id="masthead" role="banner" v="n2101.1">
					<div class="container">
						<div class="headL">
							<a href="#prefs" class="actToggle mBtn"><span></span><em>Menu</em></a>
							<a href="/eedition" class="actToggle sBtn ss"><em>Today's paper</em></a>
						</div>
						<a href="https://www.newsday.com" class="logo">
							<img alt="Newsday" src="https://www.newsday.com/img/newsday/newsdayLogo.svg" />
						</a>
						<div class="headR">
							<div class="logStatus">
								<a href="#" class="not-loggedin logInbtn MG2login" id="MG2login" data-mg2-action="activation"><strong><em>Log in</em></strong></a>
								<a href="#" class="loggedin MG2MyAccount"><span></span><em>ACCOUNT</em></a>
								<a href="/subscribe" class="tBtn subacct MG2Subscribe" id="MG2Subscribe" style="display: none;"><strong><em>Subscribe</em></strong></a>
							</div>
						</div>
					</div>
				</header>
												<div id="subNav">
					<div class="container">
						<div class="searchBox" data-step="9" data-intro="We've upgraded our search engine to help you find exactly what you are looking for.">
							<a href="/search">SEARCH <i class="mag-glass"></i></a>
													</div>
						<!-- html for top nav -->
												<div id="nav"><ul>
<li><a class="lisl" href="/long-island" title="Long Island">Long Island</a></li>
<li><a class="sports" href="/sports" title="Sports">Sports</a></li>
<li><a class="life" href="/lifestyle" title="Things to Do">Things to Do</a></li>
<li><a class="nation" href="/news/nation" title="News">News</a></li>
<li><a class="eatdrink" href="/lifestyle/restaurants" title="Feed Me">Feed Me</a></li>
<li><a class="opinion" href="/opinion" title="Opinion">Opinion</a></li>
<li><a class="biz" href="/business" title="Business">Business</a></li>
<li><a class="obit" href="https://www.legacy.com/obituaries/newsday/" title="Obituaries">Obituaries</a></li>
<li><a class="ndlive" href="https://www.newsday.com/newsday-live" title="Events">Events</a></li>
<!--<li id="all"><a class="all mBtn" href="#">All</a></li>-->
</ul>
</div>
												<!-- /html for top nav -->
					</div>
				</div>
				<div id="sections" class="pane">
					<button aria-label="Close" class="x"></button>
					<a class="todays btn gBtn" href="/eedition">TODAY'S PAPER</a>
					<!-- weather -->
						      <section class="weather">
       <a href="/weather">
         <span class="weatherIcon">
         <i class="wicon34"></i>
         <em>40&deg;</em>
         </span>
         <span class="weather-abso">
         <time datetime="2021-02-04">2/4/2021</time>
         <strong>Good Afternoon</strong>
         <b class="loggedin active"></b>
         </span>
       </a>
    </section>
					<!-- closings -->
																									<a href="https://projects.newsday.com/databases/long-island/school-closings/" class="clos">CLOSINGS<i class="fa fa-exclamation-circle"></i></a>
										<!-- /.closings -->
					<!-- search -->
					<div class="searchBox">
						<a href="/search">SEARCH <i class="mag-glass"></i></a>
					</div>
										<!-- /.search -->
					<!-- html for nav -->
										<nav id="navMenu">
<ul>
<li><span><a href="https://www.newsday.com" title="Home">Home</a></span></li>
<li>
<span><a href="https://www.newsday.com/long-island" title="Long Island">Long Island</a> <i class="plus"></i></span>
<div>
<a class="" href="https://www.newsday.com/long-island/nassau">Nassau</a>
<a class="" href="https://www.newsday.com/long-island/suffolk">Suffolk</a>
<a class="" href="https://www.newsday.com/long-island/education">Education</a>
<a class="" href="https://www.newsday.com/long-island/crime">Crime</a>
<a class="" href="https://www.newsday.com/long-island/politics">Politics</a>
<a class="" href="https://www.newsday.com/long-island/towns">Towns</a>
<a class="" href="https://www.newsday.com/long-island/investigations">Investigations</a>
<a class="" href="https://www.newsday.com/long-island/data">Data and maps</a>
<a class="" href="https://www.newsday.com/traffic">Commuting</a>
<a class="" href="https://www.newsday.com/long-island/long-island-life-1.27307843">LI Life</a>
<a class="" href="https://www.newsday.com/long-island/history">History</a>
<a class="" href="https://www.legacy.com/obituaries/newsday/">Obituaries</a>
</div>
</li>
<li>
<span><a href="https://www.newsday.com/sports" title="Sports">Sports</a><i class="plus"></i></span>
<div>
<a href="https://www.newsday.com/sports/baseball/yankees" class="icons"><span class="yankees"></span>Yankees</a>
<a href="https://www.newsday.com/sports/baseball/mets" class="icons"><span class="mets"></span>Mets</a>
<a href="https://www.newsday.com/sports/hockey/islanders" class="icons"><span class="islanders"></span>Islanders</a>
<a href="https://www.newsday.com/sports/hockey/rangers" class="icons"><span class="rangers"></span>Rangers</a>
<a href="https://www.newsday.com/sports/football/jets" class="icons"><span class="jets"></span>Jets</a>
<a href="https://www.newsday.com/sports/football/giants" class="icons"><span class="giants"></span>Giants</a>
<a href="https://www.newsday.com/sports/basketball/knicks" class="icons"><span class="knicks"></span>Knicks</a>
<a href="https://www.newsday.com/sports/basketball/nets" class="icons"><span class="nets"></span>Nets</a>
<a href="https://www.newsday.com/sports/high-school">High school</a>
<a href="https://www.newsday.com/sports/college">College</a>
<a href="https://www.newsday.com/sports/columnists">Columns</a>
<a href="https://www.newsday.com/sports/video">Videos</a>
<a href="https://newsday.sports.gracenote.com/gamematchups">Scores</a>
<a href="https://www.newsday.com/sports/baseball">Baseball</a>
<a href="https://www.newsday.com/sports/basketball">Basketball</a>
<a href="https://www.newsday.com/sports/boxing">Boxing</a>
<a href="https://www.newsday.com/sports/football">Football</a>
<a href="https://www.newsday.com/sports/golf">Golf</a>
<a href="https://www.newsday.com/sports/hockey">Hockey</a>
<a href="https://www.newsday.com/sports/horseracing">Horse Racing</a>
<a href="https://www.newsday.com/sports/media">Media</a>
<a href="https://www.newsday.com/sports/mixed-martial-arts">MMA</a>
<a href="https://www.newsday.com/sports/motor-racing">Motor Racing</a>
<a href="https://www.newsday.com/sports/olympics">Olympics</a>
<a href="https://www.newsday.com/sports/soccer">Soccer</a>
</div>
</li>
<li>
<span><a href="https://www.newsday.com/entertainment" title="Entertainment">Entertainment</a><i class="plus"></i></span>
<div>
<a class="" href="https://www.newsday.com/entertainment/movies">Movies</a>
<a class="" href="https://www.newsday.com/entertainment/tv">TV</a>
<a class="" href="https://www.newsday.com/entertainment/celebrities">Celebrities</a>
<a class="" href="https://www.newsday.com/entertainment/music">Music</a>
<a class="" href="https://www.newsday.com/entertainment/books">Books</a>
<a class="" href="https://www.newsday.com/entertainment/theater">Theater</a>
<a class="" href="https://www.newsday.com/entertainment/tv/reality-tv">Reality TV</a>
<a class="" href="https://www.newsday.com/entertainment/nassau-coliseum">Nassau Coliseum</a>
<a class="" href="https://www.newsday.com/crosswords">Crosswords</a>
</div>
</li>
<li><span><a href="https://www.newsday.com/lifestyle/restaurants">Feed Me</a></span></li>
<li>
<span><a href="https://www.newsday.com/lifestyle" title="Lifestyle">Things to Do</a><i class="plus"></i></span>
<div>
<a href="https://www.newsday.com/lifestyle/restaurants">Restaurants</a>
<a href="https://www.newsday.com/lifestyle/family">Family</a>
<a href="https://www.newsday.com/lifestyle/pets">Pets</a>
<a href="https://www.newsday.com/travel">Travel</a>
<a href="https://www.newsday.com/lifestyle/restaurants/food-and-drink">Food and Drink</a>
<a href="https://projects.newsday.com/feature-grid/lifestyle/restaurants/top-long-island-restaurants-2016-eat-now/">Top 100 Restaurants</a>
<a href="https://www.newsday.com/lifestyle/fashion-and-shopping">Fashion and Shopping</a>
<a href="https://www.newsday.com/lifestyle/home-and-garden">Home and Garden</a>
<a href="https://www.newsday.com/travel/long-island-getaways">LI Getaways</a>
<a href="https://www.newsday.com/lifestyle/recreation">Recreation</a>
<a href="https://www.newsday.com/lifestyle/retirement">Retirement</a>
<a href="https://www.newsday.com/lifestyle/advice/advice-1.2509012">Advice</a>
<a href="https://www.newsday.com/lifestyle/long-island-events">Events</a>
<a href="https://www.newsday.com/lifestyle/holidays/winter-holidays">Winter fun</a>
<a href="https://www.newsday.com/lifestyle/holidays/valentines-day">Valentine's Day</a>
</div>
</li>
<li><span><a href="https://www.newsday.com/news/nation" title="News">News</a><i class="plus"></i></span>
<div>
<a class="" href="https://www.newsday.com/news/nation">Nation and World</a>
<a class="" href="https://www.newsday.com/news/new-york">NYC</a>
<a class="" href="https://www.newsday.com/news/region-state">State and Region</a>
<a class="" href="https://www.newsday.com/news/health">Health</a>
<a class="" href="https://www.newsday.com/business/technology">Technology</a>
<a class="" href="https://www.newsday.com/news/lottery">Lottery</a>
</div>
</li>
<li>
<span><a href="https://www.newsday.com/opinion" title="Opinion">Opinion</a><i class="plus"></i></span>
<div>
<a class="" href="https://projects.newsday.com/cartoons/opinion/matt-davies-political-cartoons/">Matt Davies</a>
<a class="" href="https://www.newsday.com/podcasts/life-under-coronavirus">Podcast: Life Under Coronavirus</a>
<a class="" href="https://www.newsday.com/opinion/columnists">Columnists</a>
<a class="" href="https://www.newsday.com/opinion/letters/letters-to-the-editor-1.2516391">Letters to the editor</a>
<a class="" href="https://www.newsday.com/opinion/submit-your-letter-1.2516352">Submit your letter</a>
</div>
</li>
<li>
<span><a href="https://www.newsday.com/business" title="Business">Business</a><i class="plus"></i></span>
<div>
<a class="" href="https://www.newsday.com/classifieds/real-estate">Real Estate</a>
<a class="" href="https://www.newsday.com/business/technology">Technology</a>
<a class="" href="https://www.newsday.com/classifieds/cars">Cars</a>
<a class="" href="https://www.newsday.com/business/columnists">Columns</a>
<a class="" href="https://www.newsday.com/business/mutual-funds-1.5276471">Mutual funds</a>
<a class="" href="https://www.newsday.com/business/market-summary-1.5274800">Markets</a>
<a class="" href="https://www.newsday.com/business/stock-quotes-1.5276093">Stocks</a>
</div>
</li>
<li><span><a href="https://www.newsday.com/classifieds/real-estate">Real Estate<i class="angle-right"></i></a></span></li>
<li><span><a href="https://www.newsday.com/lifestyle/fashion-and-shopping/deals">Shopping Deals<i class="angle-right"></i></a></span></li>
<li><span><a href="https://www.legacy.com/obituaries/newsday/">Obituaries<i class="angle-right"></i></a></span></li>
<li><span><a href="https://www.newsday.com/newsday-live">Events<i class="angle-right"></i></a></span></li>
<li><span><a href="http://edition.pagesuite-professional.co.uk/Newsday/SpecialSections.aspx">Special Sections<i class="angle-right"></i></a></span></li>
<li><span><a href="https://www.newsday.com/classifieds">Classifieds<i class="angle-right"></i></a></span></li>
<li><span><a href="https://www.newsday.com/classifieds/cars">Cars<i class="angle-right"></i></a></span></li>	
<li><span><a href="https://www.newsday.com/classifieds/jobs">Jobs<i class="angle-right"></i></a></span></li>	
<li><span><a href="https://www.newsday.com/crosswords">Crosswords<i class="angle-right"></i></a></span></li>
<li><span><a href="https://www.newsday.com/weather">Weather<i class="angle-right"></i></a></span></li>
<li><span><a href="https://www.newsday.com/long-island/data">Data<i class="angle-right"></i></a></span></li>
<li><span><a href="https://www.newsday.com/entertainment/extras/horoscopes-1.1674854">Horoscopes<i class="angle-right"></i></a></span></li>
<li><span><a href="https://www.newsday.com/services/contact-newsday-1.1303755">Contact Newsday<i class="angle-right"></i></a></span></li>
</ul>
</nav>
										<!-- /html for nav -->
				</div><!-- /#sections -->
				<div id="picks" class="pane">
					<button aria-label="Close" class="x"></button>
						      <section class="weather">
       <a href="/weather">
         <span class="weatherIcon">
         <i class="wicon34"></i>
         <em>40&deg;</em>
         </span>
         <span class="weather-abso">
         <time datetime="2021-02-04">2/4/2021</time>
         <strong>Good Afternoon</strong>
         <b class="loggedin active"></b>
         </span>
       </a>
    </section>
					<aside id="account">
						<div class="not-loggedin" id="menu-not-logged-in">
							<a href="#" class="log not-loggedin logInbtn MG2login" id="MG2login" data-mg2-action="activation"><strong>LOG IN</strong></a>
							<section>
								<a href="/subscribe" class="btn drk tBtn subacct MG2Subscribe" id="MG2Subscribe"><strong>SUBSCRIBE</strong></a>
								<a class="btn gBtn gray" href="/newsletters">NEWSLETTERS</a>
							</section>
						</div>
						<div class="loggedin" id="menu-logged-in">
							<a class="log logout MG2logout" href="#" id="MG2logout"><strong>LOG OUT</strong></a>
							<section>
								<a href="/manageaccount" class="btn gBtn stk gray manage MMyAccount" style="display:none"><strong>MANAGE MY</strong> ACCOUNT</a>
								<form id="nwsltrForm" action="https://link.newsday.com/join/55i/newsdaysignup" method="post">
									<input type="hidden" name="email" value="" />
									<a href="/newsletters" class="btn gBtn gray newsletters stk"><strong>MANAGE</strong> NEWSLETTERS</a>
								</form>
								<a href="#" class="btn gBtn stk gray manage MG2activation" style="display:none" id="MG2activation" data-mg2-action="activation"><strong>ACTIVATE MY</strong> ACCOUNT</a>
							</section>
						</div>
					</aside>
				</div>
								  																		  						  										    	                                                                    																					<main class="container">
    <article>
      <div class="sticky">
    <div class="top fullBanner ad">
      <div class="adBanner"></div>
    </div>
    <header>
	  											<strong class="breadcrumb"><a href="/long-island">Long Island</a><a href="/long-island/suffolk">Suffolk</a></strong>
	 	    			      <h1>Twenty-car parade honors ex-teacher from Huntington on her 100th birthday</h1>
    </header>
  </div>
    <div class="gut">
    <section class="contentWell">
    				<div class="byline">
  <div>
                 <strong>By Deborah S. Morris</strong>
                 	<a href="mailto:deborah.morris@newsday.com?subject=newsday.com">deborah.morris@newsday.com</a>    
  			<a href="https://twitter.com/dsvmorris" target="blank"><i class="fa fa-twitter" aria-hidden="true"></i>
				   @dsvmorris 		 </a>
			   		   <time datetime="2021-02-04T16:20:12-05:00">February 4, 2021 4:20 PM</time>
		  </div>
</div>
		<div class="sshare">
	<a class="printBtn" onclick="window.print();"> Print</a>
	<input type="checkbox" id="checkbox_toggle">
	<label for="checkbox_toggle">
		<a class="tog">Share <i class="fa fa-share-alt"></i></a>
	</label>
	<div class="simpleShare" id="simpleShareTop">
		<a class="fb" rel="noopener" href=""><i class="fa fa-facebook" aria-hidden="true"></i><span class="font0">fb</span>Share</a>
		<a class="tw" rel="noopener" href="" data-mention="Newsday"><i class="fa fa-twitter" aria-hidden="true"></i> Tweet</a>
		<a class="env" href="" data-rel="external"><i class="fa fa-envelope" aria-hidden="true"></i> Email</a>
	</div>
</div>
	<div id="contentAccess">
							    		    		    					<p>In celebrating her 100th birthday Thursday, Alice Link announced some plans.</p>
																																					      				  <p>"I’m aiming for 118," Link said outside her Huntington home just before a line of vehicles festooned with ribbons, balloons and signs, some in English and Spanish, cruised past her home. "Because the oldest person who died in Japan was 117, so I figure I’ll aim for one more."</p>
						  																														      				  <p>The drive-by tribute was a community affair featuring members of the Huntington Historical Society, retired teachers from the South Huntington School District, friends, neighbors and of course cake.</p>
						  																														      				  <p>Town Supervisor Chad Lupinacci declared it was Alice Link Day in honor of the former foreign language teacher who worked in the South Huntington School District teaching Spanish and French for 20 years.</p>
						  																									    		<div id="rlm_1_image">
					<aside class="mediaCell">
				<figure>
					  				  			<picture class="lazy">
																						 <source srcset="https://cdn.newsday.com/polopoly_fs/1.22642050.1556723435!/httpImage/image.png_gen/derivatives/landscape_768/image.png" data-srcset="https://cdn.newsday.com/polopoly_fs/1.50142836.1612473613!/httpImage/image.jpg_gen/derivatives/landscape_768/image.jpg" media="(min-width: 455px)">
	 																								    		    	    <img src="https://cdn.newsday.com/polopoly_fs/1.22642050.1556723435!/httpImage/image.png_gen/derivatives/landscape_456/image.png" data-src="https://cdn.newsday.com/polopoly_fs/1.50142836.1612473613!/httpImage/image.jpg_gen/derivatives/landscape_456/image.jpg" alt="Alice Link waves to passing cars in a"  />
	  	</picture>
	<noscript><img src="https://cdn.newsday.com/polopoly_fs/1.50142836.1612473613!/httpImage/image.jpg_gen/derivatives/landscape_456/image.jpg" alt="Alice Link waves to passing cars in a"  /></noscript>
			<figcaption class="caption">Alice Link&nbsp;waves to passing cars in a parade going past her Huntington house Thursday to celebrate&nbsp;her 100th birthday. Credit: Newsday/Steve Pfost</figcaption>
				</figure>
		</aside>
	</div>
																																							      				  <p>"We're very happy to celebrate Alice today " Lupinacci said. "We want to thank her for her contributions to the community."</p>
						  																																  <p> Link was born in Boston in 1921, raised in France and returned to the U.S. with her parents due to the onset of World War II.</p>
						  				  	<aside>
					            	<div class="newsletterSignup signupDiv " data-confirm="">
          	  	    <label for="userContact">Sign up for The Classroom newsletter.</label>
	  	  <p>The pandemic has changed education on Long Island. Find out how.</p>	  <form id="subscribeForm" action="" method="POST">
		<div class="formBorder">
		  <input class="form-control" type="text" id="userContact" name="userContact" value="" placeholder="Email address" required="required">
		  <input type="hidden" name="sub" value="nd_edit_education" />
		  <input type="hidden" name="requestType" value="new_subscription" />
		  <input type="hidden" name="responseType" value="json" />
		  <input type="hidden" name="version" value="2" />
		  <input type="hidden" name="search_token" value="4130495ed93c0201d6a883c478efa852e913fbe0" />
		  <input type="hidden" name="confirmationEmail" value="" />
		  <input type="hidden" name="email" value="" />		  <input type="hidden" name="nsource" value="A">		</div>
		  <a class="btn disable" href="#">Sign up</a>
	  </form>
	  <div class="signupSuccess"></div>
	  <p class="disclaimer">By clicking Sign up, you agree to our <a href="/privacy" target="blank">privacy policy</a>.</p>
	  	</div>
					</aside>
							  		  																																			      				  <p>She moved to Huntington in 1946 where she and her husband had five children. The feisty centenarian attributes her longevity to an old adage.</p>
						  																														      				  <p>"The old Greek saying, moderation in all things," Link said. "I love my drink, but I’m not going to give a whole bottle at a time."</p>
						  																														      				  <p>Link studied interior design at the Parsons School of Interior Design in Manhattan but took a break to raise her family.</p>
						  																																					      				  <p>She returned to college when she was in her 40s, and received her bachelor’s degree, teaching certificate and Masters of Humanities degree from Hofstra University.</p>
						  																														      				  <p>Justine Hughes of Greenlawn described her grandmother as a strong, loyal and amazing woman who has lived by her own motto: "never say I can’t because you can."</p>
						  																														      				  <p>"She just keeps going and that’s her secret. She doesn’t want to stop," Hughes said.</p>
						  																														      				  <p> Link was adopted, Hughes said, and was an only child so she always made her children a priority, returning to school at night and working by day following her divorce.</p>
						  																														      				  <p>Gay Worthington, of Hampton Bays, Link's adopted child said: </p>
						  																																					      				  <p>"She took a lot of people in, not just me. She just likes having people and family around. She just has a good heart, a giving soul."</p>
						  																														      				  <p>After Link retired she tutored students in foreign languages, traveled extensively and volunteered as a docent for the Huntington Historical Society for over 30 years.</p>
						  																														      				  <p>"I’ve been very, very fortunate," she said. "I’ve never lost a child which most people have by my age, they’re still all alive, they’re all old, and but I’ve been very fortunate."</p>
						  																									                                                                      
				<div class="byline bot">
	  	  <div>
                       <strong>By Deborah S. Morris</strong>
              	    	    	<a href="mailto:deborah.morris@newsday.com?subject=newsday.com">deborah.morris@newsday.com</a>	    	  				<a href="https://twitter.com/dsvmorris" target="blank"><i class="fa fa-twitter" aria-hidden="true"></i>
						   @dsvmorris 			 </a>
			  </div>
	   <p>Deborah Morris is a native Long Islander and covers the town of Huntington.</p> 	</div>
			</div>
		<div class="sshare simpleShare big" id="simpleShareBig">
	<a class="fb" rel="noopener" href="/"><i class="fa fa-facebook" aria-hidden="true"></i> Share on Facebook</a>
	<a class="tw" rel="noopener" href="/" data-mention="@Newsday"><i class="fa fa-twitter" aria-hidden="true"></i> Share on Twitter</a>
</div>

        			    </section>
    <!-- side bar -->
                      <section class="side">
<div class="ad cubeAd">
    <div class="adBanner"></div>
    </div>
	  	     	    	    	  	        	      	<aside id="recommendedStories" class="headlines">
      		<h3>Most Popular</h3>
      		<p></p>
      		<ul>
	        																					<li>
																	<label class="sec">WATCH NOW</label>
										<a href="https://www.newsday.com/long-island/nassau/bethpage-letter-christmas-lights-covid-19-1.50141630">After cruel month, a letter to family made things worse</a>
						</li>					            	    	  	        																					<li>
																  							<a href="https://www.newsday.com/long-island/crime/abduction-lindenhurst-police-officer-impersonation-1.50142209">Police: Man arrested in abduction of teen girl</a>
						</li>					            	    	  	        																					<li>
																  							<a href="https://www.newsday.com/news/health/coronavirus/covid-19-virus-long-island-new-york-vaccines-1.50141236">State: More than 25,000 to get vaccine this week at pop-up sites</a>
						</li>					            	    	  	        																					<li>
																  							<a href="https://www.newsday.com/long-island/nassau/wantagh-house-saved-historic-1.50141571">Neighbors save 1920s house in Wantagh from demolition</a>
						</li>					            	    	  	        																					<li>
																			<label class="sec">WATCH NOW</label>
										<a href="https://www.newsday.com/news/health/coronavirus/covid-19-virus-long-island-new-york-vaccines-1.50142420">Nassau official to state: Set up mass vaccination site at the Coliseum</a>
						</li>					            	    	  	        					            	    	  	        					            	    	  	        					            	    	  	        					            	    	  	        					            	    	  	        					            	    	  	        					            	    	  	        					            	    	  	        					            	    	  	        					            	    	  	        					            	    	  	        					            	    	  	        					            	    	  	        					            	    	  	        					            	    	      	</ul>
  		</aside>
  			 <div class="ad cubeAd">
  <div class="adBanner"></div>
</div>
	  	     	              <aside class="tops" id="topStories-side">
    <h3></h3>
    <p></p>
    <ol>
              				      <li>
          <a class="imgLink" href="https://www.newsday.com/news/health/coronavirus/covid-19-virus-long-island-new-york-vaccines-1.50142420">
                        				  			<picture class="lazy">
																							    				    	    <img src="https://cdn.newsday.com/polopoly_fs/1.22642050.1556723435!/httpImage/image.png_gen/derivatives/preview_115/image.png" data-src="https://cdn.newsday.com/polopoly_fs/1.50142441.1612473943!/httpImage/image.jpg_gen/derivatives/preview_115/image.jpg" alt="The presiding officer of the Nassau County Legislature" width="115" height="86" />
	  	</picture>
	<noscript><img src="https://cdn.newsday.com/polopoly_fs/1.50142441.1612473943!/httpImage/image.jpg_gen/derivatives/preview_115/image.jpg" alt="The presiding officer of the Nassau County Legislature" width="115" height="86" /></noscript>
                                  								              <span class="watch-vid"><i class="fa fa-play"></i><time>1:45</time></span>
                    </a>
          										<label class="sec">WATCH NOW</label>
			          <a href="https://www.newsday.com/news/health/coronavirus/covid-19-virus-long-island-new-york-vaccines-1.50142420">
            <strong>Nassau official to state: Set up mass vaccination site at the Coliseum</strong>
          </a>
      </li>
                      				      <li>
          <a class="imgLink" href="https://www.newsday.com/news/health/coronavirus/covid-19-hauppauge-doug-jansson-1.50142050">
                        				  			<picture class="lazy">
																							    				    	    <img src="https://cdn.newsday.com/polopoly_fs/1.22642050.1556723435!/httpImage/image.png_gen/derivatives/preview_115/image.png" data-src="https://cdn.newsday.com/polopoly_fs/1.50142180.1612472293!/httpImage/image.jpg_gen/derivatives/preview_115/image.jpg" alt="Doug Jansson, leadpastor of Living Word Church in" width="115" height="86" />
	  	</picture>
	<noscript><img src="https://cdn.newsday.com/polopoly_fs/1.50142180.1612472293!/httpImage/image.jpg_gen/derivatives/preview_115/image.jpg" alt="Doug Jansson, leadpastor of Living Word Church in" width="115" height="86" /></noscript>
                                  								              <span class="watch-vid"><i class="fa fa-play"></i><time>1:02</time></span>
                    </a>
          												<label class="sec">WATCH NOW</label>
			          <a href="https://www.newsday.com/news/health/coronavirus/covid-19-hauppauge-doug-jansson-1.50142050">
            <strong>His family needed a miracle and a dying pastor got one</strong>
          </a>
      </li>
                      				      <li>
          <a class="imgLink" href="https://www.newsday.com/news/health/coronavirus/covid-19-pastor-stony-brook-1.50142198">
                        				  			<picture class="lazy">
																							    				    	    <img src="https://cdn.newsday.com/polopoly_fs/1.22642050.1556723435!/httpImage/image.png_gen/derivatives/preview_115/image.png" data-src="https://cdn.newsday.com/polopoly_fs/1.50142203.1612441375!/httpImage/image.jpg_gen/derivatives/preview_115/image.jpg" alt="Doug Jansson, pastor of Living Word Church, was" width="115" height="86" />
	  	</picture>
	<noscript><img src="https://cdn.newsday.com/polopoly_fs/1.50142203.1612441375!/httpImage/image.jpg_gen/derivatives/preview_115/image.jpg" alt="Doug Jansson, pastor of Living Word Church, was" width="115" height="86" /></noscript>
                                  								              <span class="watch-vid"><i class="fa fa-play"></i><time>1:02</time></span>
                    </a>
          												<label class="sec">WATCH NOW</label>
			          <a href="https://www.newsday.com/news/health/coronavirus/covid-19-pastor-stony-brook-1.50142198">
            <strong>Pastor discharged after two-month battle with COVID-19</strong>
          </a>
      </li>
                      				      <li>
          <a class="imgLink" href="https://www.newsday.com/long-island/suffolk/variance-requests-zba-apartments-parking-1.50142447">
                        				  			<picture class="lazy">
																							    				    	    <img src="https://cdn.newsday.com/polopoly_fs/1.22642050.1556723435!/httpImage/image.png_gen/derivatives/preview_115/image.png" data-src="https://cdn.newsday.com/polopoly_fs/1.50142448.1612458102!/httpImage/image.jpg_gen/derivatives/preview_115/image.jpg" alt="Developer Mitchell Giannini was seeking variance relief to" width="115" height="86" />
	  	</picture>
	<noscript><img src="https://cdn.newsday.com/polopoly_fs/1.50142448.1612458102!/httpImage/image.jpg_gen/derivatives/preview_115/image.jpg" alt="Developer Mitchell Giannini was seeking variance relief to" width="115" height="86" /></noscript>
                              </a>
          									            <a href="https://www.newsday.com/long-island/suffolk/variance-requests-zba-apartments-parking-1.50142447">
            <strong>Babylon ZBA says no to turning house into parking lot</strong>
          </a>
      </li>
                      				      <li>
          <a class="imgLink" href="https://www.newsday.com/long-island/education/st-james-smithtown-schools-hybrid-covid-1.50140957">
                        				  			<picture class="lazy">
																							    				    	    <img src="https://cdn.newsday.com/polopoly_fs/1.22642050.1556723435!/httpImage/image.png_gen/derivatives/preview_115/image.png" data-src="https://cdn.newsday.com/polopoly_fs/1.50141753.1612439147!/httpImage/image.jpg_gen/derivatives/preview_115/image.jpg" alt="Two parents of Smithtown schoolchildren, Karen Wontrobski-Ricciardi and" width="115" height="86" />
	  	</picture>
	<noscript><img src="https://cdn.newsday.com/polopoly_fs/1.50141753.1612439147!/httpImage/image.jpg_gen/derivatives/preview_115/image.jpg" alt="Two parents of Smithtown schoolchildren, Karen Wontrobski-Ricciardi and" width="115" height="86" /></noscript>
                                  								              <span class="watch-vid"><i class="fa fa-play"></i><time>1:56</time></span>
                    </a>
          												<label class="sec">WATCH NOW</label>
			          <a href="https://www.newsday.com/long-island/education/st-james-smithtown-schools-hybrid-covid-1.50140957">
            <strong>Smithtown parents plan rally over hybrid school schedule</strong>
          </a>
      </li>
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  </ol>
</aside>
	 <div class="ad cubeAd">
  <div class="adBanner"></div>
</div>
</section>
		  </div><!-- /.gut -->
</article>
		  	     	                  <section class="storyGallery" id="bottomTopStories">
      <h3>Latest Long Island News</h3>
               				       <div class="tout">
          <a class="imgLink" href="https://www.newsday.com/long-island/obituaries/obituary-joe-viverito-ad-executive-distance-runner-marathoner-1.50142738">
                        				  			<picture class="lazy">
																						 <source srcset="https://cdn.newsday.com/polopoly_fs/1.22642050.1556723435!/httpImage/image.png_gen/derivatives/landscape_384/image.png" data-srcset="https://cdn.newsday.com/polopoly_fs/1.50142741.1612473233!/httpImage/image.jpg_gen/derivatives/landscape_384/image.jpg" media="(min-width: 374px)">
	 																								    		    	    <img src="https://cdn.newsday.com/polopoly_fs/1.22642050.1556723435!/httpImage/image.png_gen/derivatives/landscape_375/image.png" data-src="https://cdn.newsday.com/polopoly_fs/1.50142741.1612473233!/httpImage/image.jpg_gen/derivatives/landscape_375/image.jpg" alt="Joe Viverito Jr. died Dec. 25 in his"  />
	  	</picture>
	<noscript><img src="https://cdn.newsday.com/polopoly_fs/1.50142741.1612473233!/httpImage/image.jpg_gen/derivatives/landscape_375/image.jpg" alt="Joe Viverito Jr. died Dec. 25 in his"  /></noscript>
                              </a>
          							            <a href="https://www.newsday.com/long-island/obituaries/obituary-joe-viverito-ad-executive-distance-runner-marathoner-1.50142738"><strong>Joe Viverito Jr., 87, distance runner and ad exec, dies</strong></a>
       </div>
                        				       <div class="tout">
          <a class="imgLink" href="https://www.newsday.com/news/health/coronavirus/covid-19-virus-long-island-new-york-vaccines-1.50142420">
                        				  			<picture class="lazy">
																						 <source srcset="https://cdn.newsday.com/polopoly_fs/1.22642050.1556723435!/httpImage/image.png_gen/derivatives/landscape_384/image.png" data-srcset="https://cdn.newsday.com/polopoly_fs/1.50142441.1612473943!/httpImage/image.jpg_gen/derivatives/landscape_384/image.jpg" media="(min-width: 374px)">
	 																								    		    	    <img src="https://cdn.newsday.com/polopoly_fs/1.22642050.1556723435!/httpImage/image.png_gen/derivatives/landscape_375/image.png" data-src="https://cdn.newsday.com/polopoly_fs/1.50142441.1612473943!/httpImage/image.jpg_gen/derivatives/landscape_375/image.jpg" alt="The presiding officer of the Nassau County Legislature"  />
	  	</picture>
	<noscript><img src="https://cdn.newsday.com/polopoly_fs/1.50142441.1612473943!/httpImage/image.jpg_gen/derivatives/landscape_375/image.jpg" alt="The presiding officer of the Nassau County Legislature"  /></noscript>
                                  								              <span class="watch-vid"><i class="fa fa-play"></i><time>1:45</time></span>
                    </a>
          												<label class="sec">WATCH NOW</label>
			          <a href="https://www.newsday.com/news/health/coronavirus/covid-19-virus-long-island-new-york-vaccines-1.50142420"><strong>Nassau official to state: Set up mass vaccination site at the Coliseum</strong></a>
       </div>
                        				       <div class="tout">
          <a class="imgLink" href="https://www.newsday.com/long-island/nassau/wantagh-house-saved-historic-1.50141571">
                        				  			<picture class="lazy">
																						 <source srcset="https://cdn.newsday.com/polopoly_fs/1.22642050.1556723435!/httpImage/image.png_gen/derivatives/landscape_384/image.png" data-srcset="https://cdn.newsday.com/polopoly_fs/1.50141572.1612472343!/httpImage/image.jpg_gen/derivatives/landscape_384/image.jpg" media="(min-width: 374px)">
	 																								    		    	    <img src="https://cdn.newsday.com/polopoly_fs/1.22642050.1556723435!/httpImage/image.png_gen/derivatives/landscape_375/image.png" data-src="https://cdn.newsday.com/polopoly_fs/1.50141572.1612472343!/httpImage/image.jpg_gen/derivatives/landscape_375/image.jpg" alt="The Colonial Revival-style house on Elm Place in"  />
	  	</picture>
	<noscript><img src="https://cdn.newsday.com/polopoly_fs/1.50141572.1612472343!/httpImage/image.jpg_gen/derivatives/landscape_375/image.jpg" alt="The Colonial Revival-style house on Elm Place in"  /></noscript>
                              </a>
          									            <a href="https://www.newsday.com/long-island/nassau/wantagh-house-saved-historic-1.50141571"><strong>Neighbors save 1920s house in Wantagh from demolition</strong></a>
       </div>
                        				       <div class="tout">
          <a class="imgLink" href="https://www.newsday.com/news/health/coronavirus/covid-19-hauppauge-doug-jansson-1.50142050">
                        				  			<picture class="lazy">
																						 <source srcset="https://cdn.newsday.com/polopoly_fs/1.22642050.1556723435!/httpImage/image.png_gen/derivatives/landscape_384/image.png" data-srcset="https://cdn.newsday.com/polopoly_fs/1.50142180.1612472293!/httpImage/image.jpg_gen/derivatives/landscape_384/image.jpg" media="(min-width: 374px)">
	 																								    		    	    <img src="https://cdn.newsday.com/polopoly_fs/1.22642050.1556723435!/httpImage/image.png_gen/derivatives/landscape_375/image.png" data-src="https://cdn.newsday.com/polopoly_fs/1.50142180.1612472293!/httpImage/image.jpg_gen/derivatives/landscape_375/image.jpg" alt="Doug Jansson, leadpastor of Living Word Church in"  />
	  	</picture>
	<noscript><img src="https://cdn.newsday.com/polopoly_fs/1.50142180.1612472293!/httpImage/image.jpg_gen/derivatives/landscape_375/image.jpg" alt="Doug Jansson, leadpastor of Living Word Church in"  /></noscript>
                                  								              <span class="watch-vid"><i class="fa fa-play"></i><time>1:02</time></span>
                    </a>
          												<label class="sec">WATCH NOW</label>
			          <a href="https://www.newsday.com/news/health/coronavirus/covid-19-hauppauge-doug-jansson-1.50142050"><strong>His family needed a miracle and a dying pastor got one</strong></a>
       </div>
                        				       <div class="tout">
          <a class="imgLink" href="https://www.newsday.com/long-island/transportation/lirr-overtime-1.50142575">
                        				  			<picture class="lazy">
																						 <source srcset="https://cdn.newsday.com/polopoly_fs/1.22642050.1556723435!/httpImage/image.png_gen/derivatives/landscape_384/image.png" data-srcset="https://cdn.newsday.com/polopoly_fs/1.50142684.1612470310!/httpImage/image.jpg_gen/derivatives/landscape_384/image.jpg" media="(min-width: 374px)">
	 																								    		    	    <img src="https://cdn.newsday.com/polopoly_fs/1.22642050.1556723435!/httpImage/image.png_gen/derivatives/landscape_375/image.png" data-src="https://cdn.newsday.com/polopoly_fs/1.50142684.1612470310!/httpImage/image.jpg_gen/derivatives/landscape_375/image.jpg" alt="Acting United States Attorney for the Southern District"  />
	  	</picture>
	<noscript><img src="https://cdn.newsday.com/polopoly_fs/1.50142684.1612470310!/httpImage/image.jpg_gen/derivatives/landscape_375/image.jpg" alt="Acting United States Attorney for the Southern District"  /></noscript>
                              </a>
          																						<label class="sec">Breaking News</label>
		            <a href="https://www.newsday.com/long-island/transportation/lirr-overtime-1.50142575"><strong>Six current or former MTA workers indicted on fraud, conspiracy charges</strong></a>
       </div>
                        				       <div class="tout">
          <a class="imgLink" href="https://www.newsday.com/long-island/politics/schnirman-nassau-1.50142526">
                        				  			<picture class="lazy">
																						 <source srcset="https://cdn.newsday.com/polopoly_fs/1.22642050.1556723435!/httpImage/image.png_gen/derivatives/landscape_384/image.png" data-srcset="https://cdn.newsday.com/polopoly_fs/1.50142527.1612465028!/httpImage/image.jpg_gen/derivatives/landscape_384/image.jpg" media="(min-width: 374px)">
	 																								    		    	    <img src="https://cdn.newsday.com/polopoly_fs/1.22642050.1556723435!/httpImage/image.png_gen/derivatives/landscape_375/image.png" data-src="https://cdn.newsday.com/polopoly_fs/1.50142527.1612465028!/httpImage/image.jpg_gen/derivatives/landscape_375/image.jpg" alt="Nassau County Comptroller Jack Schnirman, pictured on Dec."  />
	  	</picture>
	<noscript><img src="https://cdn.newsday.com/polopoly_fs/1.50142527.1612465028!/httpImage/image.jpg_gen/derivatives/landscape_375/image.jpg" alt="Nassau County Comptroller Jack Schnirman, pictured on Dec."  /></noscript>
                              </a>
          																						<label class="sec">Newsday Exclusive</label>
		            <a href="https://www.newsday.com/long-island/politics/schnirman-nassau-1.50142526"><strong>Schnirman won't seek reelection as Nassau comptroller</strong></a>
       </div>
                                                                                                                                                                                                                                                                   </section>
	 </main>
		      <div class="footer-search">
    <strong>Didn’t find what you were looking for?</strong>
    <form id="searchBar" name="search-form" method="post" action="">
      <fieldset>
        <input type="search" class="text" placeholder="search newsday.com" autocomplete="off" autocorrect="off" maxlength="512" />
        <button value="Search" class="ltBtn" type="submit"><i class="fa fa-search"></i></button>
      </fieldset>
    </form>
  </div>
          <div class="fullBanner ad bottom">
       <div class="adBanner"></div>
     </div>
   	<footer id="footer">
	<!-- html for footer -->
		   <div id="toaster-wrap" class="subOffer fixed-bottom">

</div>
<section class="container">
<nav class="col-4">
<h3>Quick Links</h3>
<a href="https://projects.newsday.com/long-island/about-us/">About Us</a>
<a href="https://www.newsday.com/subscribe">Subscribe</a>
<a href="https://paper.newsday.com">Today’s paper</a>
<a href="https://www.newsday.com/newsletters">Email newsletters</a>
<a href="https://www.newsday.com/newsday-live">Newsday Live</a>
<a href="https://www.newsdaycharities.org/">Newsday Charities</a>
<a href="http://newsday.com/careers">Careers</a>
<a href="https://www.newsday.com/manageaccount">Manage my account</a>
<a href="https://mediakit.newsday.com/">Media Kit</a>
<a href="https://mediakit.newsday.com/brand360/">Brand 360</a>
<a href="https://www.newsday.com/services/newsday-apps-1.1319154" >Mobile & TV apps</a>
<a href="https://www.newsday.com/services/contest">Contests</a>
</nav>

<nav class="col-4">
<h3>Partners</h3>
<a href="https://www.newsday.com/classifieds/cars">Newsday Cars</a>
<a href="https://www.newsday.com/classifieds/real-estate">Newsday Homes</a>
<a href="https://www.newsday.com/classifieds/jobs">Newsday Jobs</a>
<a href="http://local.newsday.com/search/en-US/">Newsday Connect</a>
<a href="http://www.hometownshopperli.com/">Hometown Shopper</a>
</nav>

<nav class="col-4">
<h3>News</h3>
<a href="https://www.newsday.com/long-island">Long Island</a>
<a href="https://www.newsday.com/sports">Sports</a>
<a href="https://www.newsday.com/opinion">Opinion</a>
<a href="https://www.newsday.com/long-island/politics">Politics</a>
<a href="https://www.newsday.com/news/nation">News</a>
<a href="https://www.newsday.com/business">Business</a>
<a href="https://www.newsday.com/towns">Towns</a>
<a href="https://www.newsday.com/sports/high-school">High school sports</a>
</nav>

<nav class="col-4">
<h3>More</h3>
<a href="https://www.newsday.com/funbook">Funbook</a>
<a href="https://www.legacy.com/obituaries/newsday/">Obituaries</a>
<a href="https://www.newsday.com/crossword">Crosswords</a>
<a href="https://www.newsday.com/lifestyle">Things to Do</a>
<a href="https://www.newsday.com/entertainment">Entertainment</a>
<a href="https://www.newsday.com/lifestyle/restaurants">Restaurants</a>
<a href="https://www.newsday.com/lifestyle/family">Family</a>
<a href="https://www.newsday.com/travel">Travel</a>
</nav>


<p>
<a href="https://www.newsday.com/privacy">Privacy Policy</a> | 
<a href="https://www.newsday.com/terms">Terms of service</a> |
<a href="https://www.newsday.com/homedeliveryterms">Subscription terms</a> |
<a href="https://www.newsday.com/services/affiliated-sites-linked-sites-and-advertisements-1.4715345">Your ad choices</a> |
<a href="javascript:;" class="ot-sdk-show-settings"> Cookie Settings</a> |
<a href="https://www.newsday.com/services/newsday-llc-privacy-policy-1.2515999#cal">California Privacy Rights</a> |
<a href="https://projects.newsday.com/long-island/about-us/">About Us</a> |
<a href="https://www.newsday.com/contact">Contact Newsday</a> |
<a href="http://www.newsdayreprints.com/">Reprints & permissions</a> |
<a href="https://www.newsday.com/advertise">Advertise with Newsday</a> |
<a href="https://www.newsday.com/sitemap" >Sitemap</a> |
<a href="https://www.newsday.com/help">Help</a>
</p>
<p class="copyright"></p>
<div class="soc">
<a href="https://www.newsday.com/facebook" class="fa fa-facebook" aria-hidden="true" aria-label="Visit Newsday on Facebook"></a>
<a href="https://www.newsday.com/twitter" class="fa fa-twitter" aria-hidden="true" aria-label="Visit Newsday on Twitter"></a>
<a href="https://www.instagram.com/newsday" class="fa fa-instagram" aria-hidden="true" aria-label="Visit Newsday on Instagram"></a>
</div>
</section>
		</footer>
																	<script>
	var adzone = "/5819/nwsd.desktop/long-island/suffolk";
	var sectionType = "smartFront";
	var pageType = "article";
	var hasTopBCVid = "false";
	var kw = "long island,local,newsday,source";
	var iab = "384";
	</script>
	<script src="https://polyfill.io/v3/polyfill.min.js?features=default,Array.prototype.findIndex,IntersectionObserver,fetch,NodeList.prototype.forEach"></script>
	<script src="https://cdnjs.cloudflare.com/ajax/libs/loadCSS/2.1.0/cssrelpreload.min.js"></script>
	<script src="https://cdnjs.cloudflare.com/ajax/libs/jquery/3.5.1/jquery.min.js" integrity="sha512-bLT0Qm9VnAYZDflyKcBaQ2gg0hSYNQrJ8RilYldYQ1FxQYoCLtUjuuRuZo+fjqhx/qtq/1itJ0C2ejDxltZVFg==" crossorigin="anonymous"></script>
 	<script src="https://cdnjs.cloudflare.com/ajax/libs/slippry/1.4.0/slippry.min.js"></script>
 	<script src="https://ak.sail-horizon.com/spm/spm.v1.min.js"></script>
<script>Sailthru.init({ customerId: 'd9fba709002300974859adea5259da0f' });</script> 				<script defer src="/shell/js/article.min.js?v=n2101.1"></script>
						                                	  	<script type="application/ld+json">
    {
    "@context": "https://schema.org",
    "@type": "NewsArticle",
    "mainEntityOfPage": "https://www.newsday.com/long-island/suffolk/100th-birthday-huntington-link-parade-1.50142835",
    "headline": "Twenty-car parade honors ex-teacher on her 100th birthday",
    "datePublished": "2021-02-04T16:20:14-05:00",
    "dateModified": "2021-02-04T16:20:14-05:00",
    "dateline": "",
    "description": "In celebrating her 100th birthday Thursday, Alice Link announced some plans. &quot;I&rsquo;m aiming for 118,&quot; Link said outside her Huntington home just before a line of vehicles festooned with ribbons, balloons",
    "author": {
    "@type": "Person",
    "name": "Deborah S. Morris"
    },
    "publisher": {
    "@type": "Organization",
    "name": "Newsday",
    "logo": {
    "@type": "ImageObject",
    "url": "https://www.newsday.com/img/amp/newsday-amp-pub-logo.png",
    "width": 600,
    "height": 60
    }
    },
    "image": {
    "@type": "ImageObject",
    "url": "https://www.newsday.com/img/blog-share-nd.jpg",
    "width": 640,
    "height": 360
    }
	    }
</script>
<script type="application/ld+json">
	{
	"@context": "http://schema.org",
	"@type": "BreadcrumbList",
	"itemListElement": [
				 {"@type": "ListItem", "position": 1, "item": { "@id": "https://www.newsday.com/", "name": "Newsday" }}
					, {"@type": "ListItem", "position": 2, "item": { "@id": "https://www.newsday.com/long-island", "name": "Long Island" }}
					, {"@type": "ListItem", "position": 3, "item": { "@id": "https://www.newsday.com/long-island/suffolk", "name": "Suffolk" }}
				]}
</script>
 	<script type='text/javascript'>  (function(){    var logUrl = '/logger/p.gif?a=1.50142835&amp;d=/2.810/2.846/2.848';    var referrer = document.referrer;    if (referrer && referrer.length > 0) {      logUrl += '&referrer=' + referrer;    }    document.write('<img src="' + logUrl + '" />');  })();</script><script type="text/javascript">
function statisticLogger() {
	if (window.jQuery) {
		jQuery.ajax({
			url: '/logger/p.gif?a=1.50142835&d=/2.810/2.846/2.848&type=MIXEDTYPE&ct=430_432,430,0',
			type: 'POST'
		});
	} else {
		setTimeout(function() { statisticLogger() }, 100);
	}
}
statisticLogger();
</script>
					<div id="pageData" data-videoviews="1" data-hotjar="true" data-contenttype="article" data-region="Long Island" data-omni='{"pagename":"Twenty-car parade honors ex-teacher from Huntington on her 100th birthday - Newsday:Long Island:Suffolk ","server":"newsday","sitesection":"long island","sitesubsection":"suffolk","sitesubsection2":"suffolk","sitesubsection3":"suffolk","sitesubsection4":"suffolk","contenttitle":"Twenty-car parade honors ex-teacher from Huntington on her 100th birthday","contentitemid":"1.50142835","contentsource":"newsday","hier":"Newsday:Long Island:Suffolk","categories":"long island,local,newsday,source","omnicode":"reg","section":"suffolk","author":"Deborah S. Morris","pubdate":"1612473612961","contentview":"web","contenttype":"article","setblocked":"metered"}'></div>
</body>
</html>
