<!DOCTYPE html>
		 		 																			    	<html lang="en">

	<head>
				  											    								<meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
<meta http-equiv="X-UA-Compatible" content="IE=edge" />
	<meta name="viewport" content="width=100%,initial-scale=1.0,maximum-scale=2.0" />
   				<link rel="canonical" href="https://www.newsday.com/news/weather/long-island-weather-wednesday-1.29626785" />
					    	 	 	 <link rel="amphtml" href="https://www.newsday.com/amp/news/weather/long-island-weather-wednesday-1.29626785">
													    <link rel="alternate" href="android-app://com.pagesuite.newsday/https://www.newsday.com/json/news/weather/long-island-weather-wednesday-1.29626785" />
    <link rel="alternate" href="ios-app://com.pagesuite.newsday/https://www.newsday.com/json/news/weather/long-island-weather-wednesday-1.29626785" />
		<link rel="alternate" href="android-app://com.newsday.sports/https://www.newsday.com/json/news/weather/long-island-weather-wednesday-1.29626785" />
	<title>Long Island weather: Mostly sunny Wednesday, highs in upper 50s | Newsday</title>
<meta name="description" content="Overnight, the temperatures drop to the mid-30s. But wait until Friday, when warmer weather returns." />
<meta name="msvalidate.01" content="AC41EB10D1EC6B5358F0ECA0E861CCAA" />
<link rel="shortcut icon" href="/img/newsday/favicon.ico" type="image/x-icon" />
<link rel="apple-touch-icon" href="/img/newsday/apple-touch-icon.png" />
<link rel="apple-touch-icon" sizes="57x57" href="/img/newsday/apple-touch-icon-57x57.png" />
<link rel="apple-touch-icon" sizes="72x72" href="/img/newsday/apple-touch-icon-72x72.png" />
<link rel="apple-touch-icon" sizes="76x76" href="/img/newsday/apple-touch-icon-76x76.png" />
<link rel="apple-touch-icon" sizes="114x114" href="/img/newsday/apple-touch-icon-114x114.png" />
<link rel="apple-touch-icon" sizes="120x120" href="/img/newsday/apple-touch-icon-120x120.png" />
<link rel="apple-touch-icon" sizes="144x144" href="/img/newsday/apple-touch-icon-144x144.png" />
<link rel="apple-touch-icon" sizes="152x152" href="/img/newsday/apple-touch-icon-152x152.png" />
<link rel="apple-touch-icon" href="/img/newsday/apple-touch-icon-precomposed.png" />
<meta name="google-site-verification" content="WS-IPs_DqbPtrQ9XhKPi_32a-1spE4tjsjhWUqwVVns" />
<meta name="application-name" content="Newsday"/>
<meta name="msapplication-TileColor" content="#1B3664"/>
<meta name="msapplication-TileImage" content="/img/newsday/nd-win8-icon.png"/>	
<link href="https://plus.google.com/111657400568598461034" rel="publisher" />
<meta name="p:domain_verify" content="b22f651177478af415d53d6eb00b8167"/>
<meta property="fb:pages" content="19175874448" />
           	<meta property="ia:markup_url" content="https://www.newsday.com/facebook/news/weather/long-island-weather-wednesday-1.29626785">
   	<meta property="article:content_tier" content="metered"/>
          <link rel="image_src" href="https://www.newsday.com/img/blog-share-nd.jpg" /> 
<meta name="news_keywords" content="local,newsday,nation and world,suffolk,source,weather,nassau">
<meta property="og:title" content="Forecast: Mostly sunny today, highs in upper 50s"/>
<meta property="og:url" content="https://www.newsday.com/news/weather/long-island-weather-wednesday-1.29626785"/>
<meta property="og:image" content="https://www.newsday.com/img/blog-share-nd.jpg"/>
<meta property="og:site_name" content="Newsday"/>
<meta property="og:description" content="Overnight, the temperatures drop to the mid-30s. But wait until Friday, when warmer weather returns."/>
   <meta property="og:type" content="article"/>
 <meta property="fb:app_id" content="147686468041"/>
<meta name="twitter:card" content="summary_large_image"/>
<meta name="twitter:site" content="@Newsday"/>
<meta name="twitter:title" content="Forecast: Mostly sunny today, highs in upper 50s"/>
<meta name="twitter:description" content="Overnight, the temperatures drop to the mid-30s. But wait until Friday, when warmer weather returns."/>
<meta name="twitter:image" content="https://www.newsday.com/img/blog-share-nd.jpg"/>
  <meta name="twitter:creator" content=""/>
<meta name="twitter:app:id:iphone" content="358571317"/>
<meta name="twitter:app:id:ipad" content="358571317"/>
<meta name="twitter:app:id:googleplay" content="com.pagesuite.newsday"/>
<link rel="alternate" type="application/rss+xml" title="Newsday Top Stories" href="https://www.newsday.com/xml/1.1252099"/>
 <meta name="sailthru.date" content="Wed, 10 Apr 2019 07:03:20 -0400" />
 <meta name="sailthru.title" content="Forecast: Mostly sunny today, highs in upper 50s" />
 <meta name="sailthru.tags" content="local,newsday,nation and world,suffolk,source,weather,nassau" />
 <meta name="sailthru.author" content="Newsday Staff" />
<meta name="isDesktop" content="true">
				<style>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</style>
	<noscript>
		<link type="text/css" rel="stylesheet" href="/shell/css/nd-article-secondary.min.css?v=n193-15"></noscript>
          <style>
/* Temp hide events on search */
.search-filter fieldset div.nd {display:none;}
/* AMNY thumbs up icon missing FA class */

.mta .fa-thumbs-o-up {
    font-family: FontAwesome;
    font-size: 64px;
    text-rendering: auto;
    -webkit-font-smoothing: antialiased;
    -moz-osx-font-smoothing: grayscale;
}

/*AMNY map secrets issue------- */
aside.front #mapContainer .locFinder form, aside.front #mapContainer .findme, #mcon {display:none;}

/* Feed Me Front Fix - ND-10467 - MC */
@media (max-width: 980px) and (min-width: 700px) {
  #reviews .review {width:50%;}
}
@media (min-width: 700px) {
  #reviews .review {min-height: 238px;margin-top: 0;}
}
@media (min-width: 1280px) {
#content .top-header {
    margin: 0 0 0 0;
    padding: 22px;
}
#reviews .review {min-height: inherit;}
#content .top-header .popular {
    margin-left: 48px;
}
}
#content #top-feature {margin:0;}
#content .popular {margin:0 0 0 -22px;}


/* ND ----- lifestyle search bar fix ----- AC  */
#featured.xliSearch form.search .text {padding-left: 60px;border-width: 1px;}
#featured.xliSearch fieldset .fa-search {border: 0;}

/* traffic alert color fix ----- AC */
#primary .alert p {color: #fff;}
.transitAlerts section div {width:auto;}

/* make ticket - bottom margin for smart front list ----- AC */
ul.storyList {margin-bottom: 30px;}

/* make ticket - bottom margin for smart front list ----- AC */

/* ND-10064 - Smart Front Video padding fix ----- AC */
main div[class*=s2nPlayer] {padding:0;}
main .storyList .img .watch {margin-bottom:6px;}
main .storyList>.featured {border-top: #de203f 4px solid;border-left:none;}

/* Temp for frankenteined fronts */
#topCarousel .main .lead {font-size:22px;}
#topCarousel:not(.dbfront) {height:462px}
.lead .hl {padding-left:12px;}
#topCarousel.xli span.webLink br, #topCarousel .rel {display: none;}
#topCarousel.xli span.webLink {font-size: 10px;}
section.list h2 {padding: 12px;margin: 0;}
#topCarousel .paper .btn {padding: 4px 2px;line-height: 1em;font-size: 10px;padding: 8px 0;background: #015895;color: #FFF;text-transform: uppercase;}
[data-role="content"] h1 {padding: 12px 22px;}

/* removes -22px padding on add banners to prevent ad from being partially hidden and not getting views - AC */
@media (min-width: 768px)  {
.ad.fullBanner {margin:0;}
}

/* FIX FOR MISSING MAG ICON IN SEARCH - AC */
.search .text{border-width:1px 0;background-color:#fff;border-radius:2px 0 0 2px;font:400 16px Lato,Helvetica,Arial,sans-serif;text-transform:uppercase;padding:15px 20px;color:#666}.search i{position:absolute;top:50%;transform:translateY(-50%)}.search .searchBtn .mag-glass{display:inline-block;content:"";width:35px;height:35px;right:5px}.search .searchBtn .mag-glass:before{content:"";position:absolute;left:0;right:0;top:10px;margin:0 auto;border-radius:50%;height:16px;width:16px;border:3px solid #ccc}#subNav .search .searchBtn .mag-glass:before{border-color:#fff}.search .searchBtn .mag-glass:after{content:"";height:4px;width:9px;background:#ccc;position:absolute;top:24px;left:21px;-webkit-transform:rotate(45deg);-moz-transform:rotate(45deg);-ms-transform:rotate(45deg);-o-transform:rotate(45deg)}#subNav .search .searchBtn .mag-glass:after{background:#fff}#subNav .search .searchBtn{right:0;top:20px;background:0 0;transition:right .2s ease-in-out}.search .searchBtn{position:absolute;top:50%;transform:translateY(-50%);cursor:pointer;right:1px;border:0;background-color:#fff;padding:0;width:35px;height:35px}@media (min-width:1024px){#subNav .search .searchBtn{right:80px}}


/* Kavanaugh video sidebox - AC */
.bFrame .hero .sideBox {margin: 0;padding: 0;bottom: 0;width: 40%;z-index:4;}
.bFrame .topImg iframe {max-height:300px;}
@media (max-width: 680px)  {
.bFrame .hero .sideBox {width: 100%;	padding: 0 12px 12px;}
}

/* ND-10611 ---- community top styles when there is a photo gallery there*/
.storyList #topm img {max-width: 100%;}
.storyList #topm .btn strong {padding: 0;}



</style>
   				<script src="//www.newsday.com/js/dtm/1dc0fa2faea3f4578a58ecc7eb8158e461206005/satelliteLib-182b60dfa538c9276e0c21e6f782fa260742e43a.js?v=n193-15"></script>	</head>
			
				<body id="nation" class="newsday ">
																																								<header id="masthead" role="banner" v="n193-15">
						<div class="container">
							<div class="headL">
								<a href="#prefs" class="actToggle mBtn"><span></span><em>Menu</em></a>
								<a href="/eedition" class="actToggle sBtn ss"><em>Today's paper</em></a>
							</div>
							<a href="https://www.newsday.com" class="logo">
								<img alt="Newsday" src="https://www.newsday.com/img/newsday/newsdayLogo.svg" />
							</a>
							<div class="headR">
								<div class="logStatus">
																											<div class="pAlert">
										<a id="pAlertBtn" href="#" aria-label="Get breaking news alerts from Newsday">
											<i class="fa fa-bell-o" aria-hidden="true"></i>
										</a>
										<div class="alertList">
											<div class="initialView">
												<div class="optOut">
													<p><strong>Get breaking news alerts from Newsday</strong></p>
													<p class="msg">Turn on notifications?</p>
													<a href="#" class="btn alertYes">Yes</a>
													<a href="#" class="btn gBtn alertNo">Not now</a>
												</div>
												<div class="optIn" style="display:none;">
													<p class="msg">Desktop notifications are on</p>
												</div>
												<div class="blockAlert" style="display:none;">
													<strong><i class="fa fa-exclamation-triangle" aria-hidden="true"></i>Not Enabled</strong>
													<p>You might be using private browsing or have notifications blocked. Please enable notifications or using normal browsing mode.</p>
												</div>
											</div>
										</div>
									</div>
																		<a class="not-loggedin logInbtn" href="/login"><em>Log in</em></a>
									<a class="loggedin" href="#" class=""><span></span><em>ACCOUNT</em></a>
																		<a href="/subscribe" class="tBtn subacct active"><em>Subscribe</em></a>
																	</div>
							</div>
						</div>
					</header>

															<div id="subNav">
						<div class="container">
							<div class="searchBox">
								<a href="/search">SEARCH <i class="mag-glass"></i></a>
															</div>
							<!-- html for top nav -->
														<div id="nav"><ul>
<li><a class="lisl" href="/long-island" title="Long Island">Long Island</a></li>
<li><a class="sports" href="/sports" title="Sports">Sports</a></li>
<li><a class="ent" href="/entertainment" title="Entertainment">Entertainment</a></li>
<li><a class="nation" href="/news/nation" title="News">News</a></li>
<li><a class="life" href="/restaurants" title="Feed Me">Feed Me</a></li>
<li><a class="opinion" href="/opinion" title="Opinion">Opinion</a></li>
<li><a class="biz" href="/business" title="Business">Business</a></li>
<li><a class="obit" href="https://www.legacy.com/obituaries/newsday/" title="Obituaries">Obituaries</a></li>
<li id="all"><a class="all mBtn" href="#">All</a></li>
</ul>
</div>
														<!-- /html for top nav -->
						</div>
					</div>
										<div id="sections" class="pane">
						<button aria-label="Close" class="x"></button>
						<a class="todays btn gBtn" href="/eedition">TODAY'S PAPER</a>
						<!-- weather -->
														    <section class="weather">
       <a href="/weather" data-link="/news/nation/islip-1.3991265">
         <span class="weatherIcon">
         <i class="wicon66"></i>
         <em>44&deg;</em>
         </span>
       <time datetime="2019-04-10">4/10/2019</time>
       <strong>Good Morning</strong>
       <b></b>
       </a>
    </section>
												<!-- /.weather -->
						<!-- closings -->
																								<!-- /.closings -->
						<!-- search -->
						<div class="searchBox">
							<a href="/search">SEARCH <i class="mag-glass"></i></a>
						</div>
												<!-- /.search -->
						<!-- html for nav -->
												<nav id="navMenu">
<ul>
<li><span><a href="https://www.newsday.com/onlineaccess" title="Subscribe">Subscribe</a></span></li>
<li><span><a href="https://www.newsday.com" title="Home">Home</a></span></li>
<li>
<span><a href="https://www.newsday.com/long-island" title="Long Island">Long Island</a> <i class="plus"></i></span>
<div>
<a class="" href="https://www.newsday.com/long-island/nassau">Nassau</a>
<a class="" href="https://www.newsday.com/long-island/suffolk">Suffolk</a>
<a class="" href="https://www.newsday.com/long-island/education">Education</a>
<a class="" href="https://www.newsday.com/long-island/crime">Crime</a>
<a class="" href="https://www.newsday.com/long-island/politics">Politics</a>
<a class="" href="https://www.newsday.com/long-island/towns">Towns</a>
<a class="" href="https://www.newsday.com/long-island/investigations">Investigations</a>
<a class="" href="https://www.newsday.com/long-island/data">Data and maps</a>
<a class="" href="https://www.newsday.com/traffic">Commuting</a>
<a class="" href="https://www.newsday.com/long-island/long-island-life-1.27307843">LI Life</a>
<a class="" href="https://www.newsday.com/long-island/history">History</a>
<a class="" href="https://www.legacy.com/obituaries/newsday/">Obituaries</a>
</div>
</li>
<li>
<span><a href="https://www.newsday.com/sports" title="Sports">Sports</a><i class="plus"></i></span>
<div>
<a href="https://www.newsday.com/sports/baseball/yankees" class="icons"><span class="yankees"></span>Yankees</a>
<a href="https://www.newsday.com/sports/baseball/mets" class="icons"><span class="mets"></span>Mets</a>
<a href="https://www.newsday.com/sports/hockey/islanders" class="icons"><span class="islanders"></span>Islanders</a>
<a href="https://www.newsday.com/sports/hockey/rangers" class="icons"><span class="rangers"></span>Rangers</a>
<a href="https://www.newsday.com/sports/football/jets" class="icons"><span class="jets"></span>Jets</a>
<a href="https://www.newsday.com/sports/football/giants" class="icons"><span class="giants"></span>Giants</a>
<a href="https://www.newsday.com/sports/basketball/knicks" class="icons"><span class="knicks"></span>Knicks</a>
<a href="https://www.newsday.com/sports/basketball/nets" class="icons"><span class="nets"></span>Nets</a>
<a href="https://www.newsday.com/sports/high-school">High school</a>
<a href="https://www.newsday.com/sports/college">College</a>
<a href="https://www.newsday.com/sports/columnists">Columns</a>
<a href="https://www.newsday.com/sports/video">Videos</a>
<a href="https://www.newsday.com/scores">Scores</a>
<a href="https://www.newsday.com/sports/baseball">Baseball</a>
<a href="https://www.newsday.com/sports/basketball">Basketball</a>
<a href="https://www.newsday.com/sports/boxing">Boxing</a>
<a href="https://www.newsday.com/sports/football">Football</a>
<a href="https://www.newsday.com/sports/golf">Golf</a>
<a href="https://www.newsday.com/sports/hockey">Hockey</a>
<a href="https://www.newsday.com/sports/horseracing">Horse Racing</a>
<a href="https://www.newsday.com/sports/media">Media</a>
<a href="https://www.newsday.com/sports/mixed-martial-arts">MMA</a>
<a href="https://www.newsday.com/sports/motor-racing">Motor Racing</a>
<a href="https://www.newsday.com/sports/olympics">Olympics</a>
<a href="https://www.newsday.com/sports/soccer">Soccer</a>
</div>
</li>
<li>
<span><a href="https://www.newsday.com/entertainment" title="Entertainment">Entertainment</a><i class="plus"></i></span>
<div>
<a class="" href="https://www.newsday.com/entertainment/movies">Movies</a>
<a class="" href="https://www.newsday.com/entertainment/tv">TV</a>
<a class="" href="https://www.newsday.com/entertainment/celebrities">Celebrities</a>
<a class="" href="https://www.newsday.com/entertainment/music">Music</a>
<a class="" href="https://www.newsday.com/entertainment/books">Books</a>
<a class="" href="https://www.newsday.com/entertainment/theater">Theater</a>
<a class="" href="https://www.newsday.com/entertainment/tv/reality-tv">Reality TV</a>
<a class="" href="https://www.newsday.com/entertainment/nassau-coliseum">Nassau Coliseum</a>
<a class="" href="https://www.newsday.com/crosswords">Crosswords</a>
<a class="" href="https://www.newsday.com/entertainment/extras/puzzles-games-1.1674628">Puzzles</a>
<a class="" href="https://www.newsday.com/entertainment/extras/comics-1.1702095">Comics</a>
</div>
</li>
<li><span><a href='//www.newsday.com/lifestyle/restaurants'>Feed Me</a></span></li>
<li>
<span><a href="https://www.newsday.com/lifestyle" title="Lifestyle">Things to Do</a><i class="plus"></i></span>
<div>
<a href='//www.newsday.com/lifestyle/restaurants'>Restaurants</a>
<a href='//www.newsday.com/lifestyle/family'>Family</a>
<a href='//www.newsday.com/lifestyle/pets'>Pets</a>
<a href='//www.newsday.com/travel'>Travel</a>
<a href='//www.newsday.com/lifestyle/restaurants/food-and-drink'>Food and Drink</a>
<a href='https://projects.newsday.com/feature-grid/lifestyle/restaurants/top-long-island-restaurants-2016-eat-now/'>Top 100 Restaurants</a>
<a href='//www.newsday.com/lifestyle/fashion-and-shopping'>Fashion and Shopping</a>
<a href='//www.newsday.com/lifestyle/home-and-garden'>Home and Garden</a>
<a href='//www.newsday.com/travel/long-island-getaways'>LI Getaways</a>
<a href='//www.newsday.com/lifestyle/recreation'>Recreation</a>
<a href='//www.newsday.com/lifestyle/retirement'>Retirement</a>
<a href='//www.newsday.com/lifestyle/advice/advice-1.2509012'>Advice</a>
<a href='//www.newsday.com/lifestyle/long-island-events'>Events</a>
<a href='https://www.newsday.com/lifestyle/holidays/spring'>Spring</a>
</div>
</li>
<li><span><a href="https://www.newsday.com/news/nation" title="News">News</a><i class="plus"></i></span>
<div>
<a class="" href="https://www.newsday.com/news/nation">Nation and World</a>
<a class="" href="https://www.newsday.com/news/new-york">NYC</a>
<a class="" href="https://www.newsday.com/news/region-state">State and Region</a>
<a class="" href="https://www.newsday.com/news/health">Health</a>
<a class="" href="https://www.newsday.com/business/technology">Technology</a>
<a class="" href="https://www.newsday.com/news/lottery">Lottery</a>
</div>
</li>
<li>
<span><a href="https://www.newsday.com/opinion" title="Opinion">Opinion</a><i class="plus"></i></span>
<div>
<a class="" href="//projects.newsday.com/cartoons/opinion/matt-davies-political-cartoons/">Matt Davies</a>
<a class="" href="https://www.newsday.com/opinion/columnists">Columnists</a>
<a class="" href="https://www.newsday.com/opinion/letters/letters-to-the-editor-1.2516391">Letters to the editor</a>
<a class="" href="https://www.newsday.com/opinion/submit-your-letter-1.2516352">Submit your letter</a>
</div>
</li>
<li>
<span><a href="https://www.newsday.com/business" title="Business">Business</a><i class="plus"></i></span>
<div>
<a class="" href="https://www.newsday.com/classifieds/real-estate">Real Estate</a>
<a class="" href="https://www.newsday.com/business/technology">Technology</a>
<a class="" href="https://www.newsday.com/classifieds/cars">Cars</a>
<a class="" href="https://www.newsday.com/business/columnists">Columns</a>
<a class="" href="https://www.newsday.com/business/mutual-funds-1.5276471">Mutual funds</a>
<a class="" href="https://www.newsday.com/business/market-summary-1.5274800">Markets</a>
<a class="" href="https://www.newsday.com/business/stock-quotes-1.5276093">Stocks</a>
</div>
</li>
<li><span><a href="https://www.newsday.com/classifieds/cars">Cars<i class="angle-right"></i></a></span></li>
<li><span><a href="https://www.newsday.com/classifieds/real-estate">Real Estate<i class="angle-right"></i></a></span></li>
<li><span><a href="https://www.newsday.com/classifieds/jobs">Jobs<i class="angle-right"></i></a></span></li>
<li><span><a href="https://www.legacy.com/obituaries/newsday/">Obituaries<i class="angle-right"></i></a></span></li>
<li><span><a href="http://edition.pagesuite-professional.co.uk/Newsday/SpecialSections.aspx">Special Sections<i class="angle-right"></i></a></span></li>
<li><span><a href="https://www.newsday.com/classifieds">Classifieds<i class="angle-right"></i></a></span></li>
<li><span><a href="https://www.newsday.com/crosswords">Crosswords<i class="angle-right"></i></a></span></li>
<li><span><a href="https://www.newsday.com/weather">Weather<i class="angle-right"></i></a></span></li>
<li><span><a href="https://www.newsday.com/traffic">Traffic<i class="angle-right"></i></a></span></li>
<li><span><a href="https://www.newsday.com/long-island/data">Data<i class="angle-right"></i></a></span></li>
<li><span><a href="https://www.newsday.com/entertainment/extras/horoscopes-1.1674854">Horoscopes<i class="angle-right"></i></a></span></li>
<!-- </div> -->
<!-- </li> -->


</ul>
</nav>
												<!-- /html for nav -->
					</div><!-- /#sections -->
					<div id="picks" class="pane">
						<button aria-label="Close" class="x"></button>
														    <section class="weather">
       <a href="/weather" data-link="/news/nation/islip-1.3991265">
         <span class="weatherIcon">
         <i class="wicon66"></i>
         <em>44&deg;</em>
         </span>
       <time datetime="2019-04-10">4/10/2019</time>
       <strong>Good Morning</strong>
       <b></b>
       </a>
    </section>
												<aside id="account">
							<div class="not-loggedin" id="menu-not-logged-in">
								<a class="log logInbtn" href="/login">LOG IN</a>
								<section>
									<a class="btn drk" href="/subscribe">SUBSCRIBE</a>
									<a class="btn gBtn gray" href="/newsletters">NEWSLETTERS</a>
								</section>
							</div>
							<div class="loggedin" id="menu-logged-in">
								<a class="log logout" href="#">LOG OUT</a>
								<section>
									<a class="btn gBtn gray stk chpass" href="/resetpassword"><strong>CHANGE</strong> PASSWORD</a>
									<a href="#" class="btn gBtn stk gray manage"><strong>MANAGE MY</strong> ACCOUNT</a>
									<form id="nwsltrForm" action="https://link.newsday.com/manage/55i/optout" method="post">
										<input type="hidden" name="email" value="" />
										<a href="" class="btn gBtn gray newsletters stk"><strong>MANAGE</strong> NEWSLETTERS </a>
									</form>
								</section>
							</div>
						</aside>
											</div><!-- /#picks -->
					  		   											    		                                                                    		<main class="container">
    <article>
      <div class="sticky">
    <div class="top fullBanner ad">
      <div class="adBanner"></div>
    </div>
    <header>
		  											<strong class="breadcrumb"><a href="/news">News</a><a href="/news/weather">Weather</a></strong>
        			      <h1>Long Island weather: Mostly sunny Wednesday, highs in upper 50s</h1>
          <p>Overnight, the temperatures drop to the mid-30s. But wait until Friday, when warmer weather returns.</p>
        </header>
  </div>
    <div class="gut">
    <section class="contentWell">
    				<div class="byline">
  <div>
     <strong>By Newsday Staff</strong>     
  			   		   <time itemprop="datePublished" datetime="2019-04-10T07:03:20-05:00">Updated April 10, 2019 7:03 AM</time>
		  </div>
</div>
		        <div class="sshare">
	<a class="printBtn" onclick="window.print();"> Print</a>
	<input type="checkbox" id="checkbox_toggle">
	<label for="checkbox_toggle">
		<a class="tog">Share <i class="fa fa-share-alt"></i></a>
	</label>
	<div class="simpleShare" id="simpleShareTop">
		<a class="fb" rel="noopener" href=""><i class="fa fa-facebook" aria-hidden="true"></i><span class="font0">fb</span>Share</a>
		<a class="tw" rel="noopener" href="" data-mention="Newsday" data-bitly="https://nwsdy.li/2UJxOpA"><i class="fa fa-twitter" aria-hidden="true"></i> Tweet</a>
		<a class="env" href="" data-rel="external"><i class="fa fa-envelope" aria-hidden="true"></i> Email</a>
	</div>
</div>
	<div id="contentAccess">
  						    		    		    				<p>Wednesday starts with more clouds and fog on Long Island before clearing up with highs in the upper 50s, forecasters said.</p>
												        				  <p>After the morning, the day should be mostly sunny and breezy, with northwest winds of 10 to 20 mph, News 12 Long Island meteorologist Rich Hoffman said. It's the second morning in a row with areas of dense fog.</p>
				    													  <p>The day's&nbsp;highs are slightly above normal, according to the National Weather Service.</p>
									  								<div id="rlm_1_weather">
	<noscript>	<link type="text/css" rel="stylesheet" href="/shell/css/nd-weather-module.min.css?v=n193-15"></noscript>
	<aside class="mediaCell wmodule loading">
		<div class="loadit"><div class="loader"><strong>Loading...</strong></div></div>
	    		        <section class="today">
    <div class="cover">
		<img src="/shell/img/weather/wbg66.jpg"/>
	</div>
    <div class="greeting">
      <em>Good Morning</em>
      Currently few clouds today
    </div>
    <div class="current">
                          <h2>ISLIP, NY</h2>
            <section>
        <i class="big wicon66"></i>
        <strong>44&deg;</strong>
          <span>Few Clouds</span>
                        		      		      		      		                                                                                                                                                                                                                                          <em>58&deg;/37&deg;</em>
        </section>
    </div>
      </section>
	    <a class="btn wbtn" href="/weather"><strong>SEE</strong> FULL FORECAST <i class="fa fa-angle-right"></i></a>
	</aside>
</div>
			                      							          		        				  <p>Overnight, the temperatures drop to the mid-30s. Patchy frost is possible in the pine barrens area into Thursday, Hoffman said.&nbsp;</p>
				    					        	<div class="teadsAd"></div>
        		        				  <p>Thursday should be mostly sunny with highs in the low 50s, a few degrees below normal, the weather service said. Lows should be in the low 40s, near normal.</p>
				    							        				  <p>Warmer weather moves in on a mostly cloudy Friday, which gets up to near 60, cooler on the South Shore and East End, Hoffman said. There is a chance of thunderstorms at night, with lows in the upper 40s.</p>
				    									    <p>The weekend should be cloudy with continuing rain. Saturday starts with showers before highs get up to the 60s, except at the beaches, which will still be in the 50s, Hoffman said.&nbsp;Sunday's highs drop back down to the upper 50s and rain returns in the evening. Rain could be heavy into Monday.</p>
			      		<aside>
      					            	<div class="newsletterSignup " data-confirm="">
	   	   	  	    <label for="userContact">Get the Breaking News newsletter!</label>
	  	  <p>Get the latest breaking news as it happens.</p>	  <form id="subscribeForm" action="" method="POST">
		<div class="formBorder">
		  <input class="form-control" type="text" id="userContact" name="userContact" value="" placeholder="Email address" required="required">
		  <input type="hidden" name="sub" value="ND_edit_breaking_news_masterlist" />
		  <input type="hidden" name="requestType" value="new_subscription" />
		  <input type="hidden" name="responseType" value="json" />
		  <input type="hidden" name="version" value="2" />
		  <input type="hidden" name="search_token" value="3cbfc6a1930bfef03338a5e99c13978120b2be44" />
		  <input type="hidden" name="confirmationEmail" value="ND_circ_NewsletterConfirmation_BreakingNewsAlerts_0717" />
		  <input type="hidden" name="email" value="" />		  <input type="hidden" name="grc-response" value="">		  <input type="hidden" name="user-response" value="" />
		  <input type="hidden" name="nsource" value="A">		</div>
		  <a class="btn disable" href="#">Sign up</a>
	  </form>
	  <div class="signupSuccess"></div>
	  <p class="disclaimer">By clicking Sign up, you agree to our <a href="/privacy" target="blank">privacy policy</a>.</p>
	  	   <div class="not-loggedin" style="display:none;">
	     <p></p>
	   </div>
	  	</div>
      		</aside>
      		        							        				  <p>&quot;Overall, not a terrible weekend,&quot; Hoffman said.</p>
				    				                                                                        
				<div class="byline bot">
	  	  <div>
	     <strong>By Newsday Staff</strong> 	    	  		  </div>
	  	</div>
			</div>
		        <div class="sshare simpleShare big" id="simpleShareBig">
	<a class="fb" rel="noopener" href="/"><i class="fa fa-facebook" aria-hidden="true"></i> Share on Facebook</a>
	<a class="tw" rel="noopener" href="/" data-mention="@Newsday" data-bitly="https://nwsdy.li/2UJxOpA"><i class="fa fa-twitter" aria-hidden="true"></i> Share on Twitter</a>
</div>

                            <div class="more" id="moreStories">
            <h3>More on this topic</h3>
            <div>
            							                	                                    								<a href="http://www.newsday.com/weather"><strong>Check the 7-day forecast for LI</strong>See how the weather's looking for your area for the days ahead.<i aria-hidden="true" class="fa fa-angle-right"></i></a>
				                        </div>
            </div>
            				<div id="comments" class="trail">
  <h3>Comments</h3>
  <p class="disclaimer">We're revamping our Comments section. <a href="/commentsnote">Learn more and share your input</a>.</p>
</div>
	    </section>
    <!-- side bar -->
                      <section class="side">
<div class="ad cubeAd">
    <div class="adBanner"></div>
    </div>
	  		               	      	  	        	      	<aside id="recommendedStories" class="headlines">
      		<h3>Most Popular</h3>
      		<p></p>
      		<ul>
	        	        								 				<li><a href="https://www.newsday.com/news/new-york/fdny-afghanistan-attack-locust-valley-1.29591327">Officials: LIer, FDNY member killed in Afghanistan</a></li>                            	      	  	        	        								 				<li><a href="https://www.newsday.com/long-island/nassau/nassau-rifle-pistol-range-closed-1.29610616">Official: Rifle range closure an 'active investigation'</a></li>                            	      	  	        	        								 				<li><a href="https://www.newsday.com/long-island/crime/long-beach-killing-daughter-1.29607649">Judge: Murder charges stand in dumbbell pipe killing</a></li>                            	      	  	        	        								 				<li><a href="https://www.newsday.com/long-island/crime/leandra-s-law-smithtown-1.29618100">Cop: LI woman high on drugs with child in car</a></li>                            	      	  	        	        								 				<li><a href="https://www.newsday.com/long-island/suffolk/earthquake-long-island-1.29600113">USGS: Magnitude 3.0 earthquake off LI</a></li>                            	      	  	        	                        	      	  	        	                        	      	  	        	                        	      	  	        	                        	      	  	        	                        	      	  	        	                        	      	  	        	                        	      	  	        	                        	      	  	        	                        	      	  	        	                        	      	  	        	                        	      	  	        	                        	      	  	        	                        	      	  	        	                        	      	  	        	                        	      	      	</ul>
  		</aside>
  			 
<div class="ad cubeAd">
  <div class="adBanner"></div>
</div>
	  		               	      	  	        	      	<aside class="tops" id="topStories-side">
      		<h3>Top stories</h3>
      		<p></p>
      		<ol>
	        	        				    												<li>
	          		<a class="imgLink" href="https://www.newsday.com/news/new-york/fdny-afghanistan-attack-locust-valley-1.29591327">
	            						              		<noscript>
	<img class="ph" src="https://cdn.newsday.com/polopoly_fs/1.29598242.1554895439!/httpImage/image.jpg_gen/derivatives/preview_115/image.jpg" alt="Firefighters set the flag to half-staff in front" width="115" height="86" />
	</noscript>
	<img class="ph" data-src="https://cdn.newsday.com/polopoly_fs/1.29598242.1554895439!/httpImage/image.jpg_gen/derivatives/preview_115/image.jpg" src="/img/loaders/landscape.png" alt="Firefighters set the flag to half-staff in front" width="115" height="86" />
	            	</a>
		            <a href="https://www.newsday.com/news/new-york/fdny-afghanistan-attack-locust-valley-1.29591327">
		              <strong>Officials: LIer, FDNY member killed in Afghanistan</strong>
		            </a>
		        </li>
                  	        	      	  	        	        				    												<li>
	          		<a class="imgLink" href="https://www.newsday.com/long-island/crime/long-beach-killing-daughter-1.29607649">
	            						              		<noscript>
	<img class="ph" src="https://cdn.newsday.com/polopoly_fs/1.23278861.1554868209!/httpImage/image.jpg_gen/derivatives/preview_115/image.jpg" alt="Ralph Keppler and Francesca Kiel." width="115" height="86" />
	</noscript>
	<img class="ph" data-src="https://cdn.newsday.com/polopoly_fs/1.23278861.1554868209!/httpImage/image.jpg_gen/derivatives/preview_115/image.jpg" src="/img/loaders/landscape.png" alt="Ralph Keppler and Francesca Kiel." width="115" height="86" />
	            	</a>
		            <a href="https://www.newsday.com/long-island/crime/long-beach-killing-daughter-1.29607649">
		              <strong>Judge: Murder charges stand in dumbbell pipe killing</strong>
		            </a>
		        </li>
                  	        	      	  	        	        				    												<li>
	          		<a class="imgLink" href="https://www.newsday.com/lifestyle/restaurants/onsen-sushi-woodbury-1.29605516">
	            						              		<noscript>
	<img class="ph" src="https://cdn.newsday.com/polopoly_fs/1.29605517.1554849379!/httpImage/image.jpg_gen/derivatives/preview_115/image.jpg" alt="The chirashi at Onsen Sushi in Woodbury is" width="115" height="86" />
	</noscript>
	<img class="ph" data-src="https://cdn.newsday.com/polopoly_fs/1.29605517.1554849379!/httpImage/image.jpg_gen/derivatives/preview_115/image.jpg" src="/img/loaders/landscape.png" alt="The chirashi at Onsen Sushi in Woodbury is" width="115" height="86" />
	            	</a>
		            <a href="https://www.newsday.com/lifestyle/restaurants/onsen-sushi-woodbury-1.29605516">
		              <strong>LI sushi bar opens second location</strong>
		            </a>
		        </li>
                  	        	      	  	        	        				    												<li>
	          		<a class="imgLink" href="https://www.newsday.com/sports/hockey/islanders/islanders-fans-playoff-nassau-coliseum-1.29602422">
	            						              		<noscript>
	<img class="ph" src="https://cdn.newsday.com/polopoly_fs/1.29602647.1554847696!/httpImage/image.jpg_gen/derivatives/preview_115/image.jpg" alt="Alex Klein inside his Islanders-decorated school bus, parked" width="115" height="86" />
	</noscript>
	<img class="ph" data-src="https://cdn.newsday.com/polopoly_fs/1.29602647.1554847696!/httpImage/image.jpg_gen/derivatives/preview_115/image.jpg" src="/img/loaders/landscape.png" alt="Alex Klein inside his Islanders-decorated school bus, parked" width="115" height="86" />
	            	</a>
		            <a href="https://www.newsday.com/sports/hockey/islanders/islanders-fans-playoff-nassau-coliseum-1.29602422">
		              <strong>Islanders fans ready to 'blow off' the Coliseum roof</strong>
		            </a>
		        </li>
                  	        	      	  	        	        				    												<li>
	          		<a class="imgLink" href="https://www.newsday.com/sports/hockey/islanders/islanders-playoff-beards-jordan-eberle-ryan-pulock-devon-teows-1.29608280">
	            						              		<noscript>
	<img class="ph" src="https://cdn.newsday.com/polopoly_fs/1.29608690.1554847563!/httpImage/image.jpg_gen/derivatives/preview_115/image.jpg" alt="Jordan Eberle of the Islanders speaks with the" width="115" height="86" />
	</noscript>
	<img class="ph" data-src="https://cdn.newsday.com/polopoly_fs/1.29608690.1554847563!/httpImage/image.jpg_gen/derivatives/preview_115/image.jpg" src="/img/loaders/landscape.png" alt="Jordan Eberle of the Islanders speaks with the" width="115" height="86" />
	            	</a>
		            <a href="https://www.newsday.com/sports/hockey/islanders/islanders-playoff-beards-jordan-eberle-ryan-pulock-devon-teows-1.29608280">
		              <strong>Islanders cultivating their playoff beards</strong>
		            </a>
		        </li>
                  	        	      	  	        	        				   												<li>
	          		<a class="imgLink" href="https://www.newsday.com/lifestyle/li-apartments-will-dna-test-for-dog-waste-1.29597313">
	            		            	<i class="icon sm fa fa-play" aria-hidden="true"></i>
	            						              		<noscript>
	<img class="ph" src="https://cdn.newsday.com/polopoly_fs/1.29607410.1554845119!/httpImage/image.jpg_gen/derivatives/preview_115/image.jpg" alt="Dog waste left on the grounds of The" width="115" height="86" />
	</noscript>
	<img class="ph" data-src="https://cdn.newsday.com/polopoly_fs/1.29607410.1554845119!/httpImage/image.jpg_gen/derivatives/preview_115/image.jpg" src="/img/loaders/landscape.png" alt="Dog waste left on the grounds of The" width="115" height="86" />
	            	</a>
		            <a href="https://www.newsday.com/lifestyle/li-apartments-will-dna-test-for-dog-waste-1.29597313">
		              <strong>LI apartments will DNA test for dog waste</strong>
		            </a>
		        </li>
                  	        	      	  	        	              	        	      	  	        	              	        	      	  	        	              	        	      	  	        	              	        	      	  	        	              	        	      	  	        	              	        	      	  	        	              	        	      	  	        	              	        	      	  	        	              	        	      	  	        	              	        	      	  	        	              	        	      	        	      	  	        	              	        	      	  	        	              	        	      	  	        	              	        	      	  	        	              	        	      	  	        	              	        	      	        	      	  	        	              	        	      	  	        	              	        	      	  	        	              	        	      	  	        	              	        	      	  	        	              	        	      	  	        	              	        	      	  	        	              	        	      	  	        	              	        	      	  	        	              	        	      	      	</ol>
  		</aside>
      		 
<div class="ad cubeAd">
  <div class="adBanner"></div>
</div>
</section>
	  </div><!-- /.gut -->
</article>
	  		         				      	      	  	        	      	<section class="storyGallery" id="bottomTopStories">
      		<h3>More news</h3>
	        	        				    												<div class="tout">
	          		<a class="imgLink" href="https://www.newsday.com/long-island/nassau/nassau-rifle-pistol-range-closed-1.29610616">
	            						              		<noscript>
	<img class="ph" src="https://cdn.newsday.com/polopoly_fs/1.29611729.1554855900!/httpImage/image.jpg_gen/derivatives/landscape_384/image.jpg" alt="Nassau's only public shooting range at Mitchel Field" width="384" height="216" />
	</noscript>
	<img class="ph" data-src="https://cdn.newsday.com/polopoly_fs/1.29611729.1554855900!/httpImage/image.jpg_gen/derivatives/landscape_384/image.jpg" src="/img/loaders/landscape.png" alt="Nassau's only public shooting range at Mitchel Field" width="384" height="216" />
					</a>
					<a href="https://www.newsday.com/long-island/nassau/nassau-rifle-pistol-range-closed-1.29610616"><strong>Official: Rifle range closure an 'active investigation'</strong></a>
		        </div>
                            	      	  	        	        				    												<div class="tout">
	          		<a class="imgLink" href="https://www.newsday.com/long-island/education/new-transfer-deal-suny-old-westbury-suny-downstate-1.29614517">
	            						              		<noscript>
	<img class="ph" src="https://cdn.newsday.com/polopoly_fs/1.29614518.1554896613!/httpImage/image.jpg_gen/derivatives/landscape_384/image.jpg" alt="A view of Student Union building at SUNY" width="384" height="216" />
	</noscript>
	<img class="ph" data-src="https://cdn.newsday.com/polopoly_fs/1.29614518.1554896613!/httpImage/image.jpg_gen/derivatives/landscape_384/image.jpg" src="/img/loaders/landscape.png" alt="A view of Student Union building at SUNY" width="384" height="216" />
					</a>
					<a href="https://www.newsday.com/long-island/education/new-transfer-deal-suny-old-westbury-suny-downstate-1.29614517"><strong>Transferring into SUNY Downstate made easier</strong></a>
		        </div>
                            	      	  	        	        				    												<div class="tout">
	          		<a class="imgLink" href="https://www.newsday.com/classifieds/real-estate/locust-valley-home-sales-1.29339807">
	            						              		<noscript>
	<img class="ph" src="https://cdn.newsday.com/polopoly_fs/1.29339810.1554389688!/httpImage/image.jpg_gen/derivatives/landscape_384/image.jpg" alt="The three-bedroom, one-bathroom home features a wood-beamed ceiling" width="384" height="216" />
	</noscript>
	<img class="ph" data-src="https://cdn.newsday.com/polopoly_fs/1.29339810.1554389688!/httpImage/image.jpg_gen/derivatives/landscape_384/image.jpg" src="/img/loaders/landscape.png" alt="The three-bedroom, one-bathroom home features a wood-beamed ceiling" width="384" height="216" />
					</a>
					<a href="https://www.newsday.com/classifieds/real-estate/locust-valley-home-sales-1.29339807"><strong>$479,000 LI home features period details</strong></a>
		        </div>
                            	      	        	      	  	        	        				    												<div class="tout">
	          		<a class="imgLink" href="https://www.newsday.com/news/new-york/fdny-afghanistan-attack-locust-valley-1.29591327">
	            						              		<noscript>
	<img class="ph" src="https://cdn.newsday.com/polopoly_fs/1.29598242.1554895439!/httpImage/image.jpg_gen/derivatives/landscape_384/image.jpg" alt="Firefighters set the flag to half-staff in front" width="384" height="216" />
	</noscript>
	<img class="ph" data-src="https://cdn.newsday.com/polopoly_fs/1.29598242.1554895439!/httpImage/image.jpg_gen/derivatives/landscape_384/image.jpg" src="/img/loaders/landscape.png" alt="Firefighters set the flag to half-staff in front" width="384" height="216" />
					</a>
					<a href="https://www.newsday.com/news/new-york/fdny-afghanistan-attack-locust-valley-1.29591327"><strong>Officials: LIer, FDNY member killed in Afghanistan</strong></a>
		        </div>
                            	      	  	        	        				    												<div class="tout">
	          		<a class="imgLink" href="https://www.newsday.com/sports/hockey/islanders/islanders-fans-playoff-nassau-coliseum-1.29602422">
	            						              		<noscript>
	<img class="ph" src="https://cdn.newsday.com/polopoly_fs/1.29602647.1554847696!/httpImage/image.jpg_gen/derivatives/landscape_384/image.jpg" alt="Alex Klein inside his Islanders-decorated school bus, parked" width="384" height="216" />
	</noscript>
	<img class="ph" data-src="https://cdn.newsday.com/polopoly_fs/1.29602647.1554847696!/httpImage/image.jpg_gen/derivatives/landscape_384/image.jpg" src="/img/loaders/landscape.png" alt="Alex Klein inside his Islanders-decorated school bus, parked" width="384" height="216" />
					</a>
					<a href="https://www.newsday.com/sports/hockey/islanders/islanders-fans-playoff-nassau-coliseum-1.29602422"><strong>Islanders fans ready to 'blow off' the Coliseum roof</strong></a>
		        </div>
                            	      	  	        	        				    												<div class="tout">
	          		<a class="imgLink" href="https://www.newsday.com/lifestyle/restaurants/onsen-sushi-woodbury-1.29605516">
	            						              		<noscript>
	<img class="ph" src="https://cdn.newsday.com/polopoly_fs/1.29605517.1554849379!/httpImage/image.jpg_gen/derivatives/landscape_384/image.jpg" alt="The chirashi at Onsen Sushi in Woodbury is" width="384" height="216" />
	</noscript>
	<img class="ph" data-src="https://cdn.newsday.com/polopoly_fs/1.29605517.1554849379!/httpImage/image.jpg_gen/derivatives/landscape_384/image.jpg" src="/img/loaders/landscape.png" alt="The chirashi at Onsen Sushi in Woodbury is" width="384" height="216" />
					</a>
					<a href="https://www.newsday.com/lifestyle/restaurants/onsen-sushi-woodbury-1.29605516"><strong>LI sushi bar opens second location</strong></a>
		        </div>
                            	      	        	      	  	        	                        	      	  	        	                        	      	  	        	                        	      	  	        	                        	      	  	        	                        	      	  	        	                        	      	  	        	                        	      	  	        	                        	      	  	        	                        	      	  	        	                        	      	  	        	                        	      	  	        	                        	      	  	        	                        	      	  	        	                        	      	  	        	                        	      	  	        	                        	      	  	        	                        	      	  	        	                        	      	  	        	                        	      	  	        	                        	      	  	        	                        	      	  	        	                        	      	  	        	                        	      	  	        	                        	      	  	        	                        	      	  		</section>
  			 
</main>
		     	<footer id="footer">
	<!-- html for footer -->
		   <section class="container">
<nav class="col-4">
<h3>Quick Links</h3>
<a href="https://www.newsday.com/subscribe">Subscribe</a>
<a href="https://paper.newsday.com">Today’s paper</a>
<a href="https://www.newsday.com/newsletters">Email newsletters</a>
<a href="https://www.newsdaycharities.org/">Newsday Charities</a>
<a href="http://newsday.com/careers">Careers</a>
<a href="https://www.newsday.com/funbook">Funbook</a>
<a href="https://www.legacy.com/obituaries/newsday/">Obituaries</a>
<a href="https://www.newsday.com/crossword">Crosswords</a>
<a href="https://www.newsday.com/?mmn=1">Manage my account</a>
<a href="https://mediakit.newsday.com/">Media Kit</a>
<a href="https://www.newsday.com/sitemap" >Sitemap</a>
</nav>

<nav class="col-4">
<h3>Partners</h3>
<a href="http://www.news12.com">News 12</a>
<a href="http://www.amny.com">am New York</a>
<a href="https://www.newsday.com/classifieds/cars">Newsday Cars</a>
<a href="https://www.newsday.com/classifieds/real-estate">Newsday Homes</a>
<a href="https://www.newsday.com/classifieds/jobs">Newsday Jobs</a>
<a href="http://local.newsday.com/search/en-US/">Newsday Connect</a>
<a href="http://www.hometownshopperli.com/">Hometown Shopper</a>
<a href="http://www.news12varsity.com/">News12 Varsity</a>
</nav>

<nav class="col-4">
<h3>News</h3>
<a href="https://www.newsday.com/long-island">Long Island</a>
<a href="https://www.newsday.com/sports">Sports</a>
<a href="https://www.newsday.com/opinion">Opinion</a>
<a href="https://www.newsday.com/long-island/politics">Politics</a>
<a href="https://www.newsday.com/news/nation">News</a>
<a href="https://www.newsday.com/business">Business</a>
<a href="https://www.newsday.com/towns">Towns</a>
<a href="https://www.newsday.com/sports/high-school">High school sports</a>
</nav>

<nav class="col-4">
<h3>More</h3>
<a href="https://www.newsday.com/lifestyle">Things to Do</a>
<a href="https://www.newsday.com/entertainment">Entertainment</a>
<a href="https://www.newsday.com/lifestyle/restaurants">Restaurants</a>
<a href="https://www.newsday.com/lifestyle/family">Family</a>
<a href="https://www.newsday.com/travel">Travel</a>
</nav>


<p>
<a href="https://www.newsday.com/privacy">Privacy Policy</a> | 
<a href="https://www.newsday.com/terms">Terms of service</a> |
<a href="https://www.newsday.com/homedeliveryterms">Subscription terms</a> |
<a href="https://www.newsday.com/services/affiliated-sites-linked-sites-and-advertisements-1.4715345">Your ad choices</a> |
<a href="https://www.newsday.com/xml/newsday-latest-stories-1.21987683">RSS</a> |
<a href="https://www.newsday.com/contact">Contact Newsday</a> |
<a href="http://www.newsdayreprints.com/">Reprints & permissions</a> |
<a href="https://www.newsday.com/advertise">Advertise with Newsday</a> |
<a href="https://www.newsday.com/help">Help</a>
</p>
<p>Copyright © <script>var currentYear = new Date().getFullYear();document.write(currentYear);</script> Newsday. All rights reserved.</p>
<div class="soc">
<a href="https://www.newsday.com/facebook" class="fa fa-facebook" aria-hidden="true" aria-label="Visit Newsday on Facebook"></a>
<a href="https://www.newsday.com/twitter" class="fa fa-twitter" aria-hidden="true" aria-label="Visit Newsday on Twitter"></a>
<a href="https://www.instagram.com/newsday" class="fa fa-instagram" aria-hidden="true" aria-label="Visit Newsday on Instagram"></a>

</div>
</section>
		</footer>
											<script>var adzone = "/5819/nwsd.desktop/news/home";var frontType = "2";var pageType = "article";var bannerType = "variable_tag";var expandedCube = "0";</script>
<script type="text/javascript">
// 86acbd31cd7c09cf30acb66d2fbedc91daa48b86:1547048802.96
!function(n,t,c,e,u){function r(n){try{f=n(u)}catch(n){return h=n,void i(p,n)}i(s,f)}function i(n,t){for(var c=0;c<n.length;c++)d(n[c],t);
}function o(n,t){return n&&(f?d(n,f):s.push(n)),t&&(h?d(t,h):p.push(t)),l}function a(n){return o(!1,n)}function d(t,c){
n.setTimeout(function(){t(c)},0)}var f,h,s=[],p=[],l={then:o,catch:a,_setup:r};n[e]=l;var v=t.createElement("script");
v.src=c,v.async=!0,v.id="_uasdk",v.rel=e,t.head.appendChild(v)}(window,document,'https://web-sdk.urbanairship.com/notify/v1/ua-sdk.min.js',
  'UA', {
    websitePushId: 'web.com.newsday',
    appKey: 'Hn--T1tcQKu_ztlJAte93w',
    token: 'MTpIbi0tVDF0Y1FLdV96dGxKQXRlOTN3Omd1cTYzc0JuTGdhZDlfS0NlVk9aSGd5QVl5WnhabU9jdVN1aVhwYXJteHM',
    vapidPublicKey: 'BJf1wki5I3zIQNF9fwn1-YNtfghTRwd6FNTCGItFpeXfmM_L-e-EyBKa5vc9GP7rQQl35qxeXElbz3h9VXOeFvk='
  });
</script>
	<script src="https://polyfill.io/v3/polyfill.min.js?features=default,Array.prototype.findIndex,IntersectionObserver,fetch,NodeList.prototype.forEach"></script>
	<script src="https://cdnjs.cloudflare.com/ajax/libs/jquery/3.2.1/jquery.min.js"></script>
 	<script src="https://cdnjs.cloudflare.com/ajax/libs/slippry/1.4.0/slippry.min.js"></script>
 	<script src="https://ak.sail-horizon.com/spm/spm.v1.min.js"></script>
<script>Sailthru.init({ customerId: 'd9fba709002300974859adea5259da0f' });</script> 				<script defer src="/shell/js/article.min.js?v=n193-15"></script>
	
					                                	<script type="application/ld+json">
    {
    "@context": "https://schema.org",
    "@type": "Article",
    "mainEntityOfPage": "https://www.newsday.com/news/weather/long-island-weather-wednesday-1.29626785",
    "headline": "Forecast: Mostly sunny today, highs in upper 50s",
    "datePublished": "2019-04-10T05:30:36-05:00",
    "dateModified": "2019-04-10T07:03:20-05:00",
    "description": "Overnight, the temperatures drop to the mid-30s. But wait until Friday, when warmer weather returns.",
    "author": {
    "@type": "Person",
    "name": "Newsday Staff"
    },
    "publisher": {
    "@type": "Organization",
    "name": "Newsday",
    "logo": {
    "@type": "ImageObject",
    "url": "https://www.newsday.com/img/amp/newsday-amp-pub-logo.png",
    "width": 600,
    "height": 60
    }
    },
    "image": {
    "@type": "ImageObject",
    "url": "https://www.newsday.com/img/blog-share-nd.jpg",
    "width": 640,
    "height": 360
    }
	    }
</script>
<script type="application/ld+json">
	{
	"@context": "http://schema.org",
	"@type": "BreadcrumbList",
	"itemListElement": [
				 {"@type": "ListItem", "position": 1, "item": { "@id": "https://www.newsday.com/", "name": "Newsday" }}
					, {"@type": "ListItem", "position": 2, "item": { "@id": "https://www.newsday.com/news", "name": "News" }}
					, {"@type": "ListItem", "position": 3, "item": { "@id": "https://www.newsday.com/news/weather", "name": "Weather" }}
				]}
</script>
 	<script type='text/javascript'>  (function(){    var logUrl = '/logger/p.gif?a=1.29626785&amp;d=/2.810/2.858/2.866';    var referrer = document.referrer;    if (referrer && referrer.length > 0) {      logUrl += '&referrer=' + referrer;    }    document.write('<img src="' + logUrl + '" />');  })();</script><script type="text/javascript">
function statisticLogger() {
	if (window.jQuery) {
		jQuery.ajax({
			url: '/logger/p.gif?a=1.29626785&d=/2.810/2.858/2.866&type=MIXEDTYPE&ct=430_432,430,0',
			type: 'POST'
		});
	} else {
		setTimeout(function() { statisticLogger() }, 100);
	}
}
statisticLogger();
</script>
																										<div>
<input type="hidden" id="pageSection" value="Newsday:News:Weather" />
<input type="hidden" id="userSource" value="" />
</div>
<div id="pageData" data-contenttype="article" data-region="Long Island" data-omni='{"pagename":"Long Island weather: Mostly sunny Wednesday, highs in upper 50s - Newsday:News:Weather","server":"Newsday","sitesection":"News","sitesubsection":"Weather","sitesubsection2":"Weather","sitesubsection3":"Weather","sitesubsection4":"Weather","contenttitle":"Long Island weather: Mostly sunny Wednesday, highs in upper 50s","contentitemid":"1.29626785","contentsource":"newsday","hier":"Newsday:News:Weather","categories":"local,newsday,nation and world,suffolk,source,weather,nassau","omnicode":"reg","browser":"unknown","section":"Weather","author":"Newsday Staff","pubdate":"1554894200189","contentview":"web","contenttype":"article","setblocked":"metered","pcount":"8","mrelated":"none,other"}'></div>
 <script type="text/javascript">_satellite.pageBottom();</script>
</body>
</html>
