<!DOCTYPE html>
			    	<html lang="en">

	<head>
										<meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
<meta http-equiv="X-UA-Compatible"  content="IE=edge" />
<meta name="viewport" content="width=100%,initial-scale=1.0,maximum-scale=2.0" />
   	 	 			<link rel="canonical" href="https://www.newsday.com/sports/football/jets/frank-gore-nfl-future-retirement-jets-1.50110015" />
					    	 	 	 <link rel="amphtml" href="https://www.newsday.com/amp/sports/football/jets/frank-gore-nfl-future-retirement-jets-1.50110015">
					 <meta name="apple-itunes-app" content="app-id=358571317, affiliate-data=, app-argument=https://itunes.apple.com/us/app/newsday/id358571317?mt=8">
											    <link rel="alternate" href="android-app://com.pagesuite.newsday/https://www.newsday.com/json/sports/football/jets/frank-gore-nfl-future-retirement-jets-1.50110015" />
    <link rel="alternate" href="ios-app://com.pagesuite.newsday/https://www.newsday.com/json/sports/football/jets/frank-gore-nfl-future-retirement-jets-1.50110015" />
<title>Frank Gore undecided on his NFL future after season with Jets | Newsday</title>
<meta name="description" content="Frank Gore hasn&rsquo;t made a decision about whether he will play a 17th NFL season, but he might return if the right opportunity presents itself. &quot;I still have fun playing the game of football,&quot; Gore said" />
<meta name="msvalidate.01" content="AC41EB10D1EC6B5358F0ECA0E861CCAA" />
<meta name="theme-color" content="#0077c8" />
<link rel="shortcut icon" href="/img/newsday/favicon.ico" type="image/x-icon" />
<link rel="apple-touch-icon" href="/img/newsday/apple-touch-icon.png" />
<link rel="apple-touch-icon" sizes="57x57" href="/img/newsday/apple-touch-icon-57x57.png" />
<link rel="apple-touch-icon" sizes="72x72" href="/img/newsday/apple-touch-icon-72x72.png" />
<link rel="apple-touch-icon" sizes="76x76" href="/img/newsday/apple-touch-icon-76x76.png" />
<link rel="apple-touch-icon" sizes="114x114" href="/img/newsday/apple-touch-icon-114x114.png" />
<link rel="apple-touch-icon" sizes="120x120" href="/img/newsday/apple-touch-icon-120x120.png" />
<link rel="apple-touch-icon" sizes="144x144" href="/img/newsday/apple-touch-icon-144x144.png" />
<link rel="apple-touch-icon" sizes="152x152" href="/img/newsday/apple-touch-icon-152x152.png" />
<link rel="apple-touch-icon" href="/img/newsday/apple-touch-icon-precomposed.png" />
<meta name="google-site-verification" content="WS-IPs_DqbPtrQ9XhKPi_32a-1spE4tjsjhWUqwVVns" />
<meta name="application-name" content="Newsday"/>
<meta name="msapplication-TileColor" content="#1B3664"/>
<meta name="msapplication-TileImage" content="/img/newsday/nd-win8-icon.png"/>
<link href="https://plus.google.com/111657400568598461034" rel="publisher" />
<meta name="p:domain_verify" content="b22f651177478af415d53d6eb00b8167"/>
<meta property="fb:pages" content="19175874448" />
 		        	<meta property="ia:markup_url" content="https://www.newsday.com/facebook/sports/football/jets/frank-gore-nfl-future-retirement-jets-1.50110015">
   	<meta property="article:content_tier" content="metered"/>
      <meta property="article:opinion" content="false"/>
      <link rel="image_src" href="https://cdn.newsday.com/polopoly_fs/1.50110016.1609872002!/httpImage/image.jpg_gen/derivatives/landscape_1280/image.jpg" />
<meta name="news_keywords" content="newsday,afc east,new york jets,american football conference,source,sports,nfl">
<meta property="og:title" content="Frank Gore undecided on his NFL future after season with Jets"/>
<meta property="og:url" content="https://www.newsday.com/sports/football/jets/frank-gore-nfl-future-retirement-jets-1.50110015"/>
<meta property="og:image" content="https://cdn.newsday.com/polopoly_fs/1.50110016.1609872002!/httpImage/image.jpg_gen/derivatives/landscape_1280/image.jpg"/>
<meta property="og:site_name" content="Newsday"/>
<meta property="og:description" content="Frank Gore hasn&rsquo;t made a decision about whether he will play a 17th NFL season, but he might return if the right opportunity presents itself. &quot;I still have fun playing the game of football,&quot; Gore said"/>
   <meta property="og:type" content="article"/>
 <meta property="fb:app_id" content="147686468041"/>
<meta name="twitter:card" content="summary_large_image"/>
<meta name="twitter:site" content="@Newsday"/>
<meta name="twitter:title" content="Frank Gore undecided on his NFL future after season with Jets"/>
<meta name="twitter:description" content="Frank Gore hasn&rsquo;t made a decision about whether he will play a 17th NFL season, but he might return if the right opportunity presents itself. &quot;I still have fun playing the game of football,&quot; Gore said"/>
<meta name="twitter:image" content="https://cdn.newsday.com/polopoly_fs/1.50110016.1609872002!/httpImage/image.jpg_gen/derivatives/landscape_1280/image.jpg"/>
  <meta name="twitter:creator" content=""/>
<meta name="twitter:app:id:iphone" content="358571317"/>
<meta name="twitter:app:id:ipad" content="358571317"/>
<meta name="twitter:app:id:googleplay" content="com.pagesuite.newsday"/>
 <link rel="alternate" type="application/rss+xml" title="Newsday Top Stories" href="https://www.newsday.com/xml/1.1252014"/>
 <meta name="sailthru.date" content="Tue, 05 Jan 2021 13:40:01 -0500" />
 <meta name="sailthru.title" content="Frank Gore undecided on his NFL future after season with Jets" />
 <meta name="sailthru.tags" content="newsday,afc east,new york jets,american football conference,source,sports,nfl" />
 <meta name="sailthru.author" content="Al Iannazzone" />
<meta name="isDesktop" content="true">
				<script>
  //make nd_css available early, just like gAds
  window.nd_css = {queue: []};
</script>
<script src="https://cdn.p-n.io/pushly-sdk.min.js?domain_key=Cg42p96hLQLxIfwvT2auEs3ugoWYzaGqjUYN" async></script>
<script>
  var PushlySDK = window.PushlySDK || [];
  function pushly() { PushlySDK.push(arguments) }
  pushly('load', {
    domainKey: 'Cg42p96hLQLxIfwvT2auEs3ugoWYzaGqjUYN',
    sw: '/push-worker.js',
  });
</script>
<!-- preconnect to frequently used dependency domains -->
<link rel="preconnect" href="https://securepubads.g.doubleclick.net" />
<link rel="preconnect" href="https://c.amazon-adsystem.com" />
<link rel="preconnect" href="https://newsday.demdex.net" />
<link rel="preconnect" href="https://loader-cdn.azureedge.net" />
<link rel="preconnect" href="https://edge.api.brightcove.com" />
<link rel="preconnect" href="https://projects.newsday.com" />
<link rel="preconnect" href="https://cdn.cookielaw.org" />
<link rel="preconnect" href="https://cookie-cdn.cookiepro.com" />

<style>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</style>
					<link href="/shell/css/nd-article-secondary.min.css?v=n2012.1" rel="preload" type="text/css" as='style' onload='window.nd_css.queue.push(this);'/>
	
<noscript>
				<link href="/shell/css/nd-article-secondary.min.css?v=n2012.1" rel="stylesheet" type="text/css" />
	</noscript>
          <style>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</style>

<script>
var dnc_vid_id;
var dnc_player;

window.addEventListener("DOMContentLoaded", function(){ 
	console.log("Tweaking DOM");
	dnc_player = document.querySelector("[data-video-id='6181858609001']");
        if (!!dnc_player) {
 	  dnc_player.dataset.config = JSON.stringify({muted: true, autoplay: true, playsinline: true});

 	  dnc_video_override();
        }
});

var dnc_video_override = function(){
	if(typeof videojs !== "undefined"){
		dnc_player = document.querySelector("[data-video-id='6181858609001']");
		dnc_vid_id = dnc_player.id;
		
		var dnc_player_js = videojs.getPlayer(dnc_vid_id);

		if(!dnc_player_js){
			setTimeout(function(){
				dnc_video_override();
			}, 250);
		} else{
			console.log("Binding to play");
			dnc_player_js.on("play", function(e){
				console.log("Playback began. Disabling mouseover");
				$(dnc_player).off();
			});
		}
	} else{
		setTimeout(function(){
			dnc_video_override();
		}, 250);
	}
}


</script>
   							<script defer src="/shell/js/ads.min.js?v=n2012.1"></script>
			<script src="//www.newsday.com/js/launch-prod/launch-ENe1484b2b97da4cf1bd7f7a777f05562c.min.js?v=n2012.1" async></script>
			</head>
							<body id="sports" class="newsday  ">
																																				<header id="masthead" role="banner" v="n2012.1">
					<div class="container">
						<div class="headL">
							<a href="#prefs" class="actToggle mBtn"><span></span><em>Menu</em></a>
							<a href="/eedition" class="actToggle sBtn ss"><em>Today's paper</em></a>
						</div>
						<a href="https://www.newsday.com" class="logo">
							<img alt="Newsday" src="https://www.newsday.com/img/newsday/newsdayLogo.svg" />
						</a>
						<div class="headR">
							<div class="logStatus">
																<div class="deals" data-rdy="true" style="display:none;">
									<a href="#" class="deal-link"><img src="https://assets.projects.newsday.com/projects-uploads/uploads/2020/04/subscriber-deals-220.png" alt="subscriber deals"></a>
								</div>
								<a href="#" class="not-loggedin logInbtn MG2login" id="MG2login" data-mg2-action="activation"><strong><em>Log in</em></strong></a>
								<a href="#" class="loggedin MG2MyAccount"><span></span><em>ACCOUNT</em></a>
								<a href="/subscribe" class="tBtn subacct MG2Subscribe" id="MG2Subscribe" style="display: none;"><strong><em>Subscribe</em></strong></a>
							</div>
						</div>
					</div>
				</header>
												<div id="subNav">
					<div class="container">
						<div class="searchBox" data-step="9" data-intro="We've upgraded our search engine to help you find exactly what you are looking for.">
							<a href="/search">SEARCH <i class="mag-glass"></i></a>
													</div>
						<!-- html for top nav -->
												<div id="nav"><ul>
<li><a class="lisl" href="/long-island" title="Long Island">Long Island</a></li>
<li><a class="sports" href="/sports" title="Sports">Sports</a></li>
<li><a class="life" href="/lifestyle" title="Things to Do">Things to Do</a></li>
<li><a class="nation" href="/news/nation" title="News">News</a></li>
<li><a class="eatdrink" href="/lifestyle/restaurants" title="Feed Me">Feed Me</a></li>
<li><a class="opinion" href="/opinion" title="Opinion">Opinion</a></li>
<li><a class="biz" href="/business" title="Business">Business</a></li>
<li><a class="obit" href="https://www.legacy.com/obituaries/newsday/" title="Obituaries">Obituaries</a></li>
<li><a class="ndlive" href="https://www.newsday.com/newsday-live" title="Events">Events</a></li>
<!--<li id="all"><a class="all mBtn" href="#">All</a></li>-->
</ul>
</div>
												<!-- /html for top nav -->
					</div>
				</div>
								<div id="sections" class="pane">
					<button aria-label="Close" class="x"></button>
					<a class="todays btn gBtn" href="/eedition">TODAY'S PAPER</a>
					<!-- weather -->
						      <section class="weather">
       <a href="/weather">
         <span class="weatherIcon">
         <i class="wicon28"></i>
         <em>41&deg;</em>
         </span>
         <span class="weather-abso">
         <time datetime="2021-01-05">1/5/2021</time>
         <strong>Good Afternoon</strong>
         <b class="loggedin active"></b>
         </span>
       </a>
    </section>
					<!-- closings -->
																				<!-- /.closings -->
					<!-- search -->
					<div class="searchBox">
						<a href="/search">SEARCH <i class="mag-glass"></i></a>
					</div>
										<!-- /.search -->
					<!-- html for nav -->
										<nav id="navMenu">
<ul>
<li><span><a href="https://www.newsday.com" title="Home">Home</a></span></li>
<li>
<span><a href="https://www.newsday.com/long-island" title="Long Island">Long Island</a> <i class="plus"></i></span>
<div>
<a class="" href="https://www.newsday.com/long-island/nassau">Nassau</a>
<a class="" href="https://www.newsday.com/long-island/suffolk">Suffolk</a>
<a class="" href="https://www.newsday.com/long-island/education">Education</a>
<a class="" href="https://www.newsday.com/long-island/crime">Crime</a>
<a class="" href="https://www.newsday.com/long-island/politics">Politics</a>
<a class="" href="https://www.newsday.com/long-island/towns">Towns</a>
<a class="" href="https://www.newsday.com/long-island/investigations">Investigations</a>
<a class="" href="https://www.newsday.com/long-island/data">Data and maps</a>
<a class="" href="https://www.newsday.com/traffic">Commuting</a>
<a class="" href="https://www.newsday.com/long-island/long-island-life-1.27307843">LI Life</a>
<a class="" href="https://www.newsday.com/long-island/history">History</a>
<a class="" href="https://www.legacy.com/obituaries/newsday/">Obituaries</a>
</div>
</li>
<li>
<span><a href="https://www.newsday.com/sports" title="Sports">Sports</a><i class="plus"></i></span>
<div>
<a href="https://www.newsday.com/sports/baseball/yankees" class="icons"><span class="yankees"></span>Yankees</a>
<a href="https://www.newsday.com/sports/baseball/mets" class="icons"><span class="mets"></span>Mets</a>
<a href="https://www.newsday.com/sports/hockey/islanders" class="icons"><span class="islanders"></span>Islanders</a>
<a href="https://www.newsday.com/sports/hockey/rangers" class="icons"><span class="rangers"></span>Rangers</a>
<a href="https://www.newsday.com/sports/football/jets" class="icons"><span class="jets"></span>Jets</a>
<a href="https://www.newsday.com/sports/football/giants" class="icons"><span class="giants"></span>Giants</a>
<a href="https://www.newsday.com/sports/basketball/knicks" class="icons"><span class="knicks"></span>Knicks</a>
<a href="https://www.newsday.com/sports/basketball/nets" class="icons"><span class="nets"></span>Nets</a>
<a href="https://www.newsday.com/sports/high-school">High school</a>
<a href="https://www.newsday.com/sports/college">College</a>
<a href="https://www.newsday.com/sports/columnists">Columns</a>
<a href="https://www.newsday.com/sports/video">Videos</a>
<a href="https://newsday.sports.gracenote.com/gamematchups">Scores</a>
<a href="https://www.newsday.com/sports/baseball">Baseball</a>
<a href="https://www.newsday.com/sports/basketball">Basketball</a>
<a href="https://www.newsday.com/sports/boxing">Boxing</a>
<a href="https://www.newsday.com/sports/football">Football</a>
<a href="https://www.newsday.com/sports/golf">Golf</a>
<a href="https://www.newsday.com/sports/hockey">Hockey</a>
<a href="https://www.newsday.com/sports/horseracing">Horse Racing</a>
<a href="https://www.newsday.com/sports/media">Media</a>
<a href="https://www.newsday.com/sports/mixed-martial-arts">MMA</a>
<a href="https://www.newsday.com/sports/motor-racing">Motor Racing</a>
<a href="https://www.newsday.com/sports/olympics">Olympics</a>
<a href="https://www.newsday.com/sports/soccer">Soccer</a>
</div>
</li>
<li>
<span><a href="https://www.newsday.com/entertainment" title="Entertainment">Entertainment</a><i class="plus"></i></span>
<div>
<a class="" href="https://www.newsday.com/entertainment/movies">Movies</a>
<a class="" href="https://www.newsday.com/entertainment/tv">TV</a>
<a class="" href="https://www.newsday.com/entertainment/celebrities">Celebrities</a>
<a class="" href="https://www.newsday.com/entertainment/music">Music</a>
<a class="" href="https://www.newsday.com/entertainment/books">Books</a>
<a class="" href="https://www.newsday.com/entertainment/theater">Theater</a>
<a class="" href="https://www.newsday.com/entertainment/tv/reality-tv">Reality TV</a>
<a class="" href="https://www.newsday.com/entertainment/nassau-coliseum">Nassau Coliseum</a>
<a class="" href="https://www.newsday.com/crosswords">Crosswords</a>
</div>
</li>
<li><span><a href='//www.newsday.com/lifestyle/restaurants'>Feed Me</a></span></li>
<li>
<span><a href="https://www.newsday.com/lifestyle" title="Lifestyle">Things to Do</a><i class="plus"></i></span>
<div>
<a href='//www.newsday.com/lifestyle/restaurants'>Restaurants</a>
<a href='//www.newsday.com/lifestyle/family'>Family</a>
<a href='//www.newsday.com/lifestyle/pets'>Pets</a>
<a href='//www.newsday.com/travel'>Travel</a>
<a href='//www.newsday.com/lifestyle/restaurants/food-and-drink'>Food and Drink</a>
<a href='https://projects.newsday.com/feature-grid/lifestyle/restaurants/top-long-island-restaurants-2016-eat-now/'>Top 100 Restaurants</a>
<a href='//www.newsday.com/lifestyle/fashion-and-shopping'>Fashion and Shopping</a>
<a href='//www.newsday.com/lifestyle/home-and-garden'>Home and Garden</a>
<a href='//www.newsday.com/travel/long-island-getaways'>LI Getaways</a>
<a href='//www.newsday.com/lifestyle/recreation'>Recreation</a>
<a href='//www.newsday.com/lifestyle/retirement'>Retirement</a>
<a href='//www.newsday.com/lifestyle/advice/advice-1.2509012'>Advice</a>
<a href='//www.newsday.com/lifestyle/long-island-events'>Events</a>
<a href='https://www.newsday.com/lifestyle/holidays/winter-holidays'>Winter fun</a>
</div>
</li>
<li><span><a href="https://www.newsday.com/news/nation" title="News">News</a><i class="plus"></i></span>
<div>
<a class="" href="https://www.newsday.com/news/nation">Nation and World</a>
<a class="" href="https://www.newsday.com/news/new-york">NYC</a>
<a class="" href="https://www.newsday.com/news/region-state">State and Region</a>
<a class="" href="https://www.newsday.com/news/health">Health</a>
<a class="" href="https://www.newsday.com/business/technology">Technology</a>
<a class="" href="https://www.newsday.com/news/lottery">Lottery</a>
</div>
</li>
<li>
<span><a href="https://www.newsday.com/opinion" title="Opinion">Opinion</a><i class="plus"></i></span>
<div>
<a class="" href="//projects.newsday.com/cartoons/opinion/matt-davies-political-cartoons/">Matt Davies</a>
<a class="" href="https://www.newsday.com/opinion/columnists/mark-chiusano/life-under-coronavirus-long-islanders-helpers-newsday-podcast-1.43342092">Podcast: Life Under Coronavirus</a> 
<a class="" href="https://www.newsday.com/opinion/columnists">Columnists</a>
<a class="" href="https://www.newsday.com/opinion/letters/letters-to-the-editor-1.2516391">Letters to the editor</a>
<a class="" href="https://www.newsday.com/opinion/submit-your-letter-1.2516352">Submit your letter</a>
</div>
</li>
<li>
<span><a href="https://www.newsday.com/business" title="Business">Business</a><i class="plus"></i></span>
<div>
<a class="" href="https://www.newsday.com/classifieds/real-estate">Real Estate</a>
<a class="" href="https://www.newsday.com/business/technology">Technology</a>
<a class="" href="https://www.newsday.com/classifieds/cars">Cars</a>
<a class="" href="https://www.newsday.com/business/columnists">Columns</a>
<a class="" href="https://www.newsday.com/business/mutual-funds-1.5276471">Mutual funds</a>
<a class="" href="https://www.newsday.com/business/market-summary-1.5274800">Markets</a>
<a class="" href="https://www.newsday.com/business/stock-quotes-1.5276093">Stocks</a>
</div>
</li>
<li><span><a href="https://www.newsday.com/classifieds/cars">Cars<i class="angle-right"></i></a></span></li>
<li><span><a href="https://www.newsday.com/classifieds/real-estate">Real Estate<i class="angle-right"></i></a></span></li>
<li><span><a href="https://www.newsday.com/classifieds/jobs">Jobs<i class="angle-right"></i></a></span></li>
<li><span><a href="https://www.legacy.com/obituaries/newsday/">Obituaries<i class="angle-right"></i></a></span></li>
<li><span><a href="https://www.newsday.com/newsday-live">Events<i class="angle-right"></i></a></span></li>
<li><span><a href="http://edition.pagesuite-professional.co.uk/Newsday/SpecialSections.aspx">Special Sections<i class="angle-right"></i></a></span></li>
<li><span><a href="https://www.newsday.com/classifieds">Classifieds<i class="angle-right"></i></a></span></li>
<li><span><a href="https://www.newsday.com/crosswords">Crosswords<i class="angle-right"></i></a></span></li>
<li><span><a href="https://www.newsday.com/weather">Weather<i class="angle-right"></i></a></span></li>
<li><span><a href="https://www.newsday.com/long-island/data">Data<i class="angle-right"></i></a></span></li>
<li><span><a href="https://www.newsday.com/entertainment/extras/horoscopes-1.1674854">Horoscopes<i class="angle-right"></i></a></span></li>
<li><span><a href="https://www.newsday.com/services/contact-newsday-1.1303755">Contact Newsday<i class="angle-right"></i></a></span></li>
<!-- </div> -->
<!-- </li> -->


</ul>
</nav>
										<!-- /html for nav -->
				</div><!-- /#sections -->
				<div id="picks" class="pane">
					<button aria-label="Close" class="x"></button>
						      <section class="weather">
       <a href="/weather">
         <span class="weatherIcon">
         <i class="wicon28"></i>
         <em>41&deg;</em>
         </span>
         <span class="weather-abso">
         <time datetime="2021-01-05">1/5/2021</time>
         <strong>Good Afternoon</strong>
         <b class="loggedin active"></b>
         </span>
       </a>
    </section>
					<aside id="account">
						<div class="not-loggedin" id="menu-not-logged-in">
							<a href="#" class="log not-loggedin logInbtn MG2login" id="MG2login" data-mg2-action="activation"><strong>LOG IN</strong></a>
							<section>
								<a href="/subscribe" class="btn drk tBtn subacct MG2Subscribe" id="MG2Subscribe"><strong>SUBSCRIBE</strong></a>
								<a class="btn gBtn gray" href="/newsletters">NEWSLETTERS</a>
							</section>
						</div>
						<div class="loggedin" id="menu-logged-in">
							<a class="log logout MG2logout" href="#" id="MG2logout"><strong>LOG OUT</strong></a>
							<section>
								<div class="deals">
									<a href="" class="deals-full"><span>SUBSCRIBER</span>
										<strong>DEALS</strong> <em>VIEW</em> <i></i>
									</a>
								</div>
								<a href="/manageaccount" class="btn gBtn stk gray manage MMyAccount" style="display:none"><strong>MANAGE MY</strong> ACCOUNT</a>
								<form id="nwsltrForm" action="https://link.newsday.com/join/55i/newsdaysignup" method="post">
									<input type="hidden" name="email" value="" />
									<a href="/newsletters" class="btn gBtn gray newsletters stk"><strong>MANAGE</strong> NEWSLETTERS</a>
								</form>
								<a href="#" class="btn gBtn stk gray manage MG2activation" style="display:none" id="MG2activation" data-mg2-action="activation"><strong>ACTIVATE MY</strong> ACCOUNT</a>
							</section>
						</div>
					</aside>
				</div>
								  		                                                                    																					<main class="container">
    <article>
      <div class="sticky">
    <div class="top fullBanner ad">
      <div class="adBanner"></div>
    </div>
    <header>
		  															<strong class="breadcrumb"><a href="/sports">Sports</a><a href="/sports/football">Football</a><a href="/sports/football/jets">Jets</a></strong>
	 	        			      <h1>Frank Gore undecided on his NFL future after season with Jets</h1>
    </header>
  </div>
    <div class="gut">
    <section class="contentWell">
    					    <div id="topm" class="mediaCell">
				  			<picture class="lazy">
																						 <source srcset="https://cdn.newsday.com/polopoly_fs/1.22642050.1556723435!/httpImage/image.png_gen/derivatives/landscape_768/image.png" data-srcset="https://cdn.newsday.com/polopoly_fs/1.50110016.1609872002!/httpImage/image.jpg_gen/derivatives/landscape_768/image.jpg" media="(min-width: 455px)">
	 																								    		    	    <img src="https://cdn.newsday.com/polopoly_fs/1.22642050.1556723435!/httpImage/image.png_gen/derivatives/landscape_456/image.png" data-src="https://cdn.newsday.com/polopoly_fs/1.50110016.1609872002!/httpImage/image.jpg_gen/derivatives/landscape_456/image.jpg" alt="Frank Gore #21 of the Jets looks on"  />
	  	</picture>
	<noscript><img src="https://cdn.newsday.com/polopoly_fs/1.50110016.1609872002!/httpImage/image.jpg_gen/derivatives/landscape_456/image.jpg" alt="Frank Gore #21 of the Jets looks on"  /></noscript>
      <p class="caption">
	  Frank Gore #21 of the&nbsp;Jets looks on prior to a game against the Los Angeles Rams at SoFi Stadium on December 20, 2020 in Inglewood, California.&nbsp;       Credit: Getty Images/Sean M. Haffey     </p>
  </div>
			<div class="byline">
  <div>
                 <strong>By Al Iannazzone</strong>
                 	<a href="mailto:al.iannazzone@newsday.com?subject=newsday.com">al.iannazzone@newsday.com</a>    
  			   		   <time datetime="2021-01-05T13:40:01-05:00">Updated January 5, 2021 1:40 PM</time>
		  </div>
</div>
		<div class="sshare">
	<a class="printBtn" onclick="window.print();"> Print</a>
	<input type="checkbox" id="checkbox_toggle">
	<label for="checkbox_toggle">
		<a class="tog">Share <i class="fa fa-share-alt"></i></a>
	</label>
	<div class="simpleShare" id="simpleShareTop">
		<a class="fb" rel="noopener" href=""><i class="fa fa-facebook" aria-hidden="true"></i><span class="font0">fb</span>Share</a>
		<a class="tw" rel="noopener" href="" data-mention="Newsday"><i class="fa fa-twitter" aria-hidden="true"></i> Tweet</a>
		<a class="env" href="" data-rel="external"><i class="fa fa-envelope" aria-hidden="true"></i> Email</a>
	</div>
</div>
	<div id="contentAccess">
							    		    		    					<p>Frank Gore hasn’t made a decision about whether he will play a 17th NFL season, but he might return if the right opportunity presents itself.</p>
																																					      				  <p>"I still have fun playing the game of football," Gore said during a Tuesday morning Zoom call.</p>
						  																														      				  <p>The 37-year-old Gore, who led the Jets in rushing this year, said he would go home to Miami, "chill out" with his kids and see what happens. He said if a team wants him and it’s a good situation for him, he would consider playing again.</p>
						  																														      				  <p>"Basically, who wants me and If I want to play," Gore said. "If a team that really wants me, a team who got a young guy who I can mentor to help out to be a better pro, a team that got a chance who can win, things like that."</p>
						  																																					      				  <p>Gore played that role for the Jets. All of the players and coaches praised Gore for being a such a professional and inspiring for how he approached each day.</p>
						  																														      				  <p>He ended the year on injured reserve after suffered a bruised lung in Week 16. Gore said when he came to the sideline he was bleeding from his mouth but felt fine. He rushed for 653 yards, giving him exactly 16,000 for his career. Only Emmitt Smith and Walter Payton have more.</p>
						  																																  <p>Gore considers himself "blessed" to achieve that because he said, "I’m not supposed to be here right now." He was a third-round pick in 2005 after suffering two torn ACLs in college. The projection was he wouldn’t last long in the NFL. Gore proved many wrong.</p>
						  				  	<aside>
					            	<div class="newsletterSignup signupDiv " data-confirm="">
          	  	    <label for="userContact">Subscribe to Sports Now newsletter</label>
	  	  	  <form id="subscribeForm" action="" method="POST">
		<div class="formBorder">
		  <input class="form-control" type="text" id="userContact" name="userContact" value="" placeholder="Email address" required="required">
		  <input type="hidden" name="sub" value="ND_edit_sports_now_masterlist" />
		  <input type="hidden" name="requestType" value="new_subscription" />
		  <input type="hidden" name="responseType" value="json" />
		  <input type="hidden" name="version" value="2" />
		  <input type="hidden" name="search_token" value="dc30ecbbff5bbed5dd0e6b97bb0aa1c72f016ab1" />
		  <input type="hidden" name="confirmationEmail" value="ND_circ_NewsletterConfirmation_SportsNow_0717" />
		  <input type="hidden" name="email" value="" />		  <input type="hidden" name="nsource" value="A">		</div>
		  <a class="btn disable" href="#">Sign up</a>
	  </form>
	  <div class="signupSuccess"></div>
	  <p class="disclaimer">By clicking Sign up, you agree to our <a href="/privacy" target="blank">privacy policy</a>.</p>
	  	</div>
					</aside>
							  		  																																			      				  <p>Brought in by Adam Gase, Gore said he "felt" for his friend losing his job. This was the third place the two worked together — first in San Francisco and then in Miami. Gore said he hopes Gase is back coaching somewhere.</p>
						  																														      				  <p>Despite the Jets’ 2-14 record, Gore said things could change quickly if general manager Joe Douglas drafts well, acquires more veteran players with a winning background to help the young players and surrounds Sam Darnold with more talent.</p>
						  																														      				  <p>If Douglas and the next coach decide that Darnold isn’t the player to lead this team going forward he won’t be back. But Gore, who had high praise for Darnold’s toughness and the way he fought through and back from a shoulder injury, believes Darnold just needs better weapons.</p>
						  																																					      				  <p>Gore pointed to the other quarterbacks from Darnold’s 2018 draft class and the receivers they have. Cleveland’s Baker Mayfield has Odell Beckham Jr. and Jarvis Landry, and Buffalo’s Josh Allen has Stefon Diggs.</p>
						  																														      				  <p>"He’s very talented, tough and he loves the game," Gore said. "You get some a little help like that, you’ll see. If they keep him. You’ll see."</p>
						  																														      				  <p>Gore also endorsed his former 49ers coach Jim Harbaugh. Gore wouldn’t be surprised if Harbaugh leaves Michigan and returns to the NFL at some point. He has been linked to the Jets. Gore said he would turn them around.</p>
						  																														      				  <p>"He’ll make this team very competitive," Gore said. "He’ll get a great staff with him. He knows how to get the guys' minds to switch to go to war for him, like do whatever it takes, try their best to win. That’s what he can do. That’s my man. Harbaugh’s my man."</p>
						  																									                                                                      
				<div class="byline bot">
	  	  <div>
                       <strong>By Al Iannazzone</strong>
              	    	    	<a href="mailto:al.iannazzone@newsday.com?subject=newsday.com">al.iannazzone@newsday.com</a>	    	  		  </div>
	  	</div>
			</div>
		<div class="sshare simpleShare big" id="simpleShareBig">
	<a class="fb" rel="noopener" href="/"><i class="fa fa-facebook" aria-hidden="true"></i> Share on Facebook</a>
	<a class="tw" rel="noopener" href="/" data-mention="@Newsday"><i class="fa fa-twitter" aria-hidden="true"></i> Share on Twitter</a>
</div>

        			    </section>
    <!-- side bar -->
                      <section class="side">
<div class="ad cubeAd">
    <div class="adBanner"></div>
    </div>
	  	     	    	    	  	        	      	<aside id="recommendedStories" class="headlines">
      		<h3>Most popular</h3>
      		<p></p>
      		<ul>
	        																					<li>
														  							<a href="https://www.newsday.com/sports/football/nfl-mock-draft-2021-1.50108882">NFL mock draft 1.0: The first 18 picks</a>
						</li>					            	    	  	        																					<li>
																  							<a href="https://www.newsday.com/sports/football/2000-yard-rushers-in-nfl-history-1.26546786">The 2,000-yard club</a>
						</li>					            	    	  	        																					<li>
																  							<a href="https://www.newsday.com/sports/college/college-football/jack-coan-notre-dame-transfer-quarterback-wisconsin-1.50109532">LI's Jack Coan announces transfer to Notre Dame</a>
						</li>					            	    	  	        																					<li>
																  							<a href="https://www.newsday.com/sports/football/jets/adam-gase-fired-jets-coach-christopher-johnson-1.50108633">Gase dismissed as Jets coach after two poor seasons</a>
						</li>					            	    	  	        																					<li>
																  							<a href="https://www.newsday.com/sports/football/giants/giants-cowboys-washington-nfc-east-1.50108429">Despite win, Giants' playoff dreams end with Washington victory</a>
						</li>					            	    	  	        					            	    	  	        					            	    	  	        					            	    	  	        					            	    	  	        					            	    	  	        					            	    	  	        					            	    	  	        					            	    	  	        					            	    	  	        					            	    	  	        					            	    	  	        					            	    	  	        					            	    	  	        					            	    	  	        					            	    	      	</ul>
  		</aside>
  			 <div class="ad cubeAd">
  <div class="adBanner"></div>
</div>
	  	     	                <aside class="tops" id="topStories-side">
    <h3>Latest Jets headlines</h3>
    <p></p>
    <ol>
              				      <li>
          <a class="imgLink" href="https://www.newsday.com/sports/columnists/bob-glauber/jets-coaching-search-joe-douglas-christopher-johnson-adam-gase-1.50109364">
                        				  			<picture class="lazy">
																							    				    	    <img src="https://cdn.newsday.com/polopoly_fs/1.22642050.1556723435!/httpImage/image.png_gen/derivatives/preview_115/image.png" data-src="https://cdn.newsday.com/polopoly_fs/1.50056045.1609829743!/httpImage/image.jpg_gen/derivatives/preview_115/image.jpg" alt="Jets general manager Joe Douglas speaks to the" width="115" height="86" />
	  	</picture>
	<noscript><img src="https://cdn.newsday.com/polopoly_fs/1.50056045.1609829743!/httpImage/image.jpg_gen/derivatives/preview_115/image.jpg" alt="Jets general manager Joe Douglas speaks to the" width="115" height="86" /></noscript>
                              </a>
          							            <a href="https://www.newsday.com/sports/columnists/bob-glauber/jets-coaching-search-joe-douglas-christopher-johnson-adam-gase-1.50109364">
            <strong>Glauber: Why Douglas is right guy to lead Jets' coaching search</strong>
          </a>
      </li>
                      				      <li>
          <a class="imgLink" href="https://www.newsday.com/sports/football/jets/christopher-johnson-adam-gase-joe-douglas-1.50109348">
                        				  			<picture class="lazy">
																							    				    	    <img src="https://cdn.newsday.com/polopoly_fs/1.22642050.1556723435!/httpImage/image.png_gen/derivatives/preview_115/image.png" data-src="https://cdn.newsday.com/polopoly_fs/1.25266211.1609828617!/httpImage/image.jpg_gen/derivatives/preview_115/image.jpg" alt="Jets Chairman and CEO Christopher Johnson speaks to" width="115" height="86" />
	  	</picture>
	<noscript><img src="https://cdn.newsday.com/polopoly_fs/1.25266211.1609828617!/httpImage/image.jpg_gen/derivatives/preview_115/image.jpg" alt="Jets Chairman and CEO Christopher Johnson speaks to" width="115" height="86" /></noscript>
                              </a>
          									            <a href="https://www.newsday.com/sports/football/jets/christopher-johnson-adam-gase-joe-douglas-1.50109348">
            <strong>Tired of losing, Jets CEO Johnson wants more well-rounded coach</strong>
          </a>
      </li>
                      				      <li>
          <a class="imgLink" href="https://www.newsday.com/sports/football/jets/jets-locker-room-culture-adam-gase-1.50109404">
                        				  			<picture class="lazy">
																							    				    	    <img src="https://cdn.newsday.com/polopoly_fs/1.22642050.1556723435!/httpImage/image.png_gen/derivatives/preview_115/image.png" data-src="https://cdn.newsday.com/polopoly_fs/1.50109413.1609828478!/httpImage/image.jpg_gen/derivatives/preview_115/image.jpg" alt="Head coach Adam Gase of the Jets looks" width="115" height="86" />
	  	</picture>
	<noscript><img src="https://cdn.newsday.com/polopoly_fs/1.50109413.1609828478!/httpImage/image.jpg_gen/derivatives/preview_115/image.jpg" alt="Head coach Adam Gase of the Jets looks" width="115" height="86" /></noscript>
                              </a>
          									            <a href="https://www.newsday.com/sports/football/jets/jets-locker-room-culture-adam-gase-1.50109404">
            <strong>With Gase gone, players say Jets need a better culture</strong>
          </a>
      </li>
                      				      <li>
          <a class="imgLink" href="https://www.newsday.com/sports/football/jets/sam-darnold-jets-1.50109072">
                        				  			<picture class="lazy">
																							    				    	    <img src="https://cdn.newsday.com/polopoly_fs/1.22642050.1556723435!/httpImage/image.png_gen/derivatives/preview_115/image.png" data-src="https://cdn.newsday.com/polopoly_fs/1.50109182.1609828032!/httpImage/image.jpg_gen/derivatives/preview_115/image.jpg" alt="Sam Darnold #14 of the Jets carries the" width="115" height="86" />
	  	</picture>
	<noscript><img src="https://cdn.newsday.com/polopoly_fs/1.50109182.1609828032!/httpImage/image.jpg_gen/derivatives/preview_115/image.jpg" alt="Sam Darnold #14 of the Jets carries the" width="115" height="86" /></noscript>
                              </a>
          									            <a href="https://www.newsday.com/sports/football/jets/sam-darnold-jets-1.50109072">
            <strong>Darnold's game plan is to stand in the pocket for Jets</strong>
          </a>
      </li>
                      				      <li>
          <a class="imgLink" href="https://www.newsday.com/sports/football/jets/adam-gase-fired-jets-coach-christopher-johnson-1.50108633">
                        				  			<picture class="lazy">
																							    				    	    <img src="https://cdn.newsday.com/polopoly_fs/1.22642050.1556723435!/httpImage/image.png_gen/derivatives/preview_115/image.png" data-src="https://cdn.newsday.com/polopoly_fs/1.50108634.1609779411!/httpImage/image.jpg_gen/derivatives/preview_115/image.jpg" alt="Jets head coach Adam Gase looks on during" width="115" height="86" />
	  	</picture>
	<noscript><img src="https://cdn.newsday.com/polopoly_fs/1.50108634.1609779411!/httpImage/image.jpg_gen/derivatives/preview_115/image.jpg" alt="Jets head coach Adam Gase looks on during" width="115" height="86" /></noscript>
                              </a>
          									            <a href="https://www.newsday.com/sports/football/jets/adam-gase-fired-jets-coach-christopher-johnson-1.50108633">
            <strong>Gase dismissed as Jets coach after two poor seasons</strong>
          </a>
      </li>
                      				      <li>
          <a class="imgLink" href="https://www.newsday.com/sports/football/jets/marcus-maye-jets-q-a-1.50108555">
                        				  			<picture class="lazy">
																							    				    	    <img src="https://cdn.newsday.com/polopoly_fs/1.22642050.1556723435!/httpImage/image.png_gen/derivatives/preview_115/image.png" data-src="https://cdn.newsday.com/polopoly_fs/1.50108560.1609745364!/httpImage/image.jpg_gen/derivatives/preview_115/image.jpg" alt="Marcus Maye #20 of the Jets reacts after" width="115" height="86" />
	  	</picture>
	<noscript><img src="https://cdn.newsday.com/polopoly_fs/1.50108560.1609745364!/httpImage/image.jpg_gen/derivatives/preview_115/image.jpg" alt="Marcus Maye #20 of the Jets reacts after" width="115" height="86" /></noscript>
                              </a>
          									            <a href="https://www.newsday.com/sports/football/jets/marcus-maye-jets-q-a-1.50108555">
            <strong>Jets Q&A: Does Marcus Maye want to stay with franchise?</strong>
          </a>
      </li>
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                </ol>
</aside>
	 <div class="ad cubeAd">
  <div class="adBanner"></div>
</div>
</section>
		  </div><!-- /.gut -->
</article>
		  	     	                <section class="storyGallery" id="bottomTopStories">
      <h3>New York Sports</h3>
               				       <div class="tout">
          <a class="imgLink" href="https://www.newsday.com/sports/football/giants/patrick-graham-giants-blake-martinez-james-bradberry-1.50110079">
                        				  			<picture class="lazy">
																						 <source srcset="https://cdn.newsday.com/polopoly_fs/1.22642050.1556723435!/httpImage/image.png_gen/derivatives/landscape_384/image.png" data-srcset="https://cdn.newsday.com/polopoly_fs/1.50110080.1609870365!/httpImage/image.jpg_gen/derivatives/landscape_384/image.jpg" media="(min-width: 374px)">
	 																								    		    	    <img src="https://cdn.newsday.com/polopoly_fs/1.22642050.1556723435!/httpImage/image.png_gen/derivatives/landscape_375/image.png" data-src="https://cdn.newsday.com/polopoly_fs/1.50110080.1609870365!/httpImage/image.jpg_gen/derivatives/landscape_375/image.jpg" alt="Then-Dolphins defensive coordinator Patrick Graham at training camp"  />
	  	</picture>
	<noscript><img src="https://cdn.newsday.com/polopoly_fs/1.50110080.1609870365!/httpImage/image.jpg_gen/derivatives/landscape_375/image.jpg" alt="Then-Dolphins defensive coordinator Patrick Graham at training camp"  /></noscript>
                              </a>
          							            <a href="https://www.newsday.com/sports/football/giants/patrick-graham-giants-blake-martinez-james-bradberry-1.50110079"><strong>With Graham in demand, Giants players give high praise</strong></a>
       </div>
                          				       <div class="tout">
          <a class="imgLink" href="https://www.newsday.com/sports/football/nfl-teams-under-500-in-the-playoffs-1.50079046">
                        				  			<picture class="lazy">
																						 <source srcset="https://cdn.newsday.com/polopoly_fs/1.22642050.1556723435!/httpImage/image.png_gen/derivatives/landscape_384/image.png" data-srcset="https://cdn.newsday.com/polopoly_fs/1.50079051.1609865368!/httpImage/image.jpg_gen/derivatives/landscape_384/image.jpg" media="(min-width: 374px)">
	 																								    		    	    <img src="https://cdn.newsday.com/polopoly_fs/1.22642050.1556723435!/httpImage/image.png_gen/derivatives/landscape_375/image.png" data-src="https://cdn.newsday.com/polopoly_fs/1.50079051.1609865368!/httpImage/image.jpg_gen/derivatives/landscape_375/image.jpg" alt="Marshawn Lynch of the Seattle Seahawks runs for"  />
	  	</picture>
	<noscript><img src="https://cdn.newsday.com/polopoly_fs/1.50079051.1609865368!/httpImage/image.jpg_gen/derivatives/landscape_375/image.jpg" alt="Marshawn Lynch of the Seattle Seahawks runs for"  /></noscript>
                              </a>
          									            <a href="https://www.newsday.com/sports/football/nfl-teams-under-500-in-the-playoffs-1.50079046"><strong>The NFL teams who reached the postseason with losing records</strong></a>
       </div>
                        				       <div class="tout">
          <a class="imgLink" href="https://www.newsday.com/sports/football/giants/joe-judge-giants-eagles-washington-nfc-east-1.50109316">
                        				  			<picture class="lazy">
																						 <source srcset="https://cdn.newsday.com/polopoly_fs/1.22642050.1556723435!/httpImage/image.png_gen/derivatives/landscape_384/image.png" data-srcset="https://cdn.newsday.com/polopoly_fs/1.50109479.1609830402!/httpImage/image.jpg_gen/derivatives/landscape_384/image.jpg" media="(min-width: 374px)">
	 																								    		    	    <img src="https://cdn.newsday.com/polopoly_fs/1.22642050.1556723435!/httpImage/image.png_gen/derivatives/landscape_375/image.png" data-src="https://cdn.newsday.com/polopoly_fs/1.50109479.1609830402!/httpImage/image.jpg_gen/derivatives/landscape_375/image.jpg" alt="Head coach Joe Judge of the Giants reacts"  />
	  	</picture>
	<noscript><img src="https://cdn.newsday.com/polopoly_fs/1.50109479.1609830402!/httpImage/image.jpg_gen/derivatives/landscape_375/image.jpg" alt="Head coach Joe Judge of the Giants reacts"  /></noscript>
                              </a>
          									            <a href="https://www.newsday.com/sports/football/giants/joe-judge-giants-eagles-washington-nfc-east-1.50109316"><strong>Giants coach Joe Judge rips effort by Eagles</strong></a>
       </div>
                        				       <div class="tout">
          <a class="imgLink" href="https://www.newsday.com/sports/columnists/bob-glauber/jets-coaching-search-joe-douglas-christopher-johnson-adam-gase-1.50109364">
                        				  			<picture class="lazy">
																						 <source srcset="https://cdn.newsday.com/polopoly_fs/1.22642050.1556723435!/httpImage/image.png_gen/derivatives/landscape_384/image.png" data-srcset="https://cdn.newsday.com/polopoly_fs/1.50056045.1609829743!/httpImage/image.jpg_gen/derivatives/landscape_384/image.jpg" media="(min-width: 374px)">
	 																								    		    	    <img src="https://cdn.newsday.com/polopoly_fs/1.22642050.1556723435!/httpImage/image.png_gen/derivatives/landscape_375/image.png" data-src="https://cdn.newsday.com/polopoly_fs/1.50056045.1609829743!/httpImage/image.jpg_gen/derivatives/landscape_375/image.jpg" alt="Jets general manager Joe Douglas speaks to the"  />
	  	</picture>
	<noscript><img src="https://cdn.newsday.com/polopoly_fs/1.50056045.1609829743!/httpImage/image.jpg_gen/derivatives/landscape_375/image.jpg" alt="Jets general manager Joe Douglas speaks to the"  /></noscript>
                              </a>
          									            <a href="https://www.newsday.com/sports/columnists/bob-glauber/jets-coaching-search-joe-douglas-christopher-johnson-adam-gase-1.50109364"><strong>Glauber: Why Douglas is right guy to lead Jets' coaching search</strong></a>
       </div>
                        				       <div class="tout">
          <a class="imgLink" href="https://www.newsday.com/sports/columnists/neil-best/giants-eagles-joe-judge-1.50109001">
                        				  			<picture class="lazy">
																						 <source srcset="https://cdn.newsday.com/polopoly_fs/1.22642050.1556723435!/httpImage/image.png_gen/derivatives/landscape_384/image.png" data-srcset="https://cdn.newsday.com/polopoly_fs/1.50109480.1609829263!/httpImage/image.jpg_gen/derivatives/landscape_384/image.jpg" media="(min-width: 374px)">
	 																								    		    	    <img src="https://cdn.newsday.com/polopoly_fs/1.22642050.1556723435!/httpImage/image.png_gen/derivatives/landscape_375/image.png" data-src="https://cdn.newsday.com/polopoly_fs/1.50109480.1609829263!/httpImage/image.jpg_gen/derivatives/landscape_375/image.jpg" alt="Head coach Joe Judge of the Giants reacts"  />
	  	</picture>
	<noscript><img src="https://cdn.newsday.com/polopoly_fs/1.50109480.1609829263!/httpImage/image.jpg_gen/derivatives/landscape_375/image.jpg" alt="Head coach Joe Judge of the Giants reacts"  /></noscript>
                              </a>
          									            <a href="https://www.newsday.com/sports/columnists/neil-best/giants-eagles-joe-judge-1.50109001"><strong>Best: Judge ratchets up disdain for Eagles after 'disrespect' to game</strong></a>
       </div>
                        				       <div class="tout">
          <a class="imgLink" href="https://www.newsday.com/sports/football/jets/christopher-johnson-adam-gase-joe-douglas-1.50109348">
                        				  			<picture class="lazy">
																						 <source srcset="https://cdn.newsday.com/polopoly_fs/1.22642050.1556723435!/httpImage/image.png_gen/derivatives/landscape_384/image.png" data-srcset="https://cdn.newsday.com/polopoly_fs/1.25266211.1609828617!/httpImage/image.jpg_gen/derivatives/landscape_384/image.jpg" media="(min-width: 374px)">
	 																								    		    	    <img src="https://cdn.newsday.com/polopoly_fs/1.22642050.1556723435!/httpImage/image.png_gen/derivatives/landscape_375/image.png" data-src="https://cdn.newsday.com/polopoly_fs/1.25266211.1609828617!/httpImage/image.jpg_gen/derivatives/landscape_375/image.jpg" alt="Jets Chairman and CEO Christopher Johnson speaks to"  />
	  	</picture>
	<noscript><img src="https://cdn.newsday.com/polopoly_fs/1.25266211.1609828617!/httpImage/image.jpg_gen/derivatives/landscape_375/image.jpg" alt="Jets Chairman and CEO Christopher Johnson speaks to"  /></noscript>
                              </a>
          									            <a href="https://www.newsday.com/sports/football/jets/christopher-johnson-adam-gase-joe-douglas-1.50109348"><strong>Tired of losing, Jets CEO Johnson wants more well-rounded coach</strong></a>
       </div>
                                                                                                                                                                                                                                                                                                                               </section>
	 </main>
		      <div class="footer-search">
    <strong>Didn’t find what you were looking for?</strong>
    <p>Try our new Search</p>
    <form id="searchBar" name="search-form" method="post" action="">
      <fieldset>
        <input type="search" class="text" placeholder="search newsday.com" autocomplete="off" autocorrect="off" maxlength="512" />
        <button value="Search" class="ltBtn" type="submit"><i class="fa fa-search"></i></button>
      </fieldset>
    </form>
  </div>
          <div class="fullBanner ad bottom">
       <div class="adBanner"></div>
     </div>
   	<footer id="footer">
	<!-- html for footer -->
		   <section class="container">
<nav class="col-4">
<h3>Quick Links</h3>
<a href="https://projects.newsday.com/long-island/about-us/">About Us</a>
<a href="https://www.newsday.com/subscribe">Subscribe</a>
<a href="https://paper.newsday.com">Today’s paper</a>
<a href="https://www.newsday.com/newsletters">Email newsletters</a>
<a href="https://www.newsday.com/newsday-live">Newsday Live</a>
<a href="https://www.newsdaycharities.org/">Newsday Charities</a>
<a href="http://newsday.com/careers">Careers</a>
<a href="https://www.newsday.com/manageaccount">Manage my account</a>
<a href="https://mediakit.newsday.com/">Media Kit</a>
<a href="https://mediakit.newsday.com/brand360/">Brand 360</a>
<a href="https://www.newsday.com/services/newsday-apps-1.1319154" >Mobile & TV apps</a>
<a href="https://www.newsday.com/services/contest">Contests</a>
</nav>

<nav class="col-4">
<h3>Partners</h3>
<a href="https://www.newsday.com/classifieds/cars">Newsday Cars</a>
<a href="https://www.newsday.com/classifieds/real-estate">Newsday Homes</a>
<a href="https://www.newsday.com/classifieds/jobs">Newsday Jobs</a>
<a href="http://local.newsday.com/search/en-US/">Newsday Connect</a>
<a href="http://www.hometownshopperli.com/">Hometown Shopper</a>
</nav>

<nav class="col-4">
<h3>News</h3>
<a href="https://www.newsday.com/long-island">Long Island</a>
<a href="https://www.newsday.com/sports">Sports</a>
<a href="https://www.newsday.com/opinion">Opinion</a>
<a href="https://www.newsday.com/long-island/politics">Politics</a>
<a href="https://www.newsday.com/news/nation">News</a>
<a href="https://www.newsday.com/business">Business</a>
<a href="https://www.newsday.com/towns">Towns</a>
<a href="https://www.newsday.com/sports/high-school">High school sports</a>
</nav>

<nav class="col-4">
<h3>More</h3>
<a href="https://www.newsday.com/funbook">Funbook</a>
<a href="https://www.legacy.com/obituaries/newsday/">Obituaries</a>
<a href="https://www.newsday.com/crossword">Crosswords</a>
<a href="https://www.newsday.com/lifestyle">Things to Do</a>
<a href="https://www.newsday.com/entertainment">Entertainment</a>
<a href="https://www.newsday.com/lifestyle/restaurants">Restaurants</a>
<a href="https://www.newsday.com/lifestyle/family">Family</a>
<a href="https://www.newsday.com/travel">Travel</a>
</nav>


<p>
<a href="https://www.newsday.com/privacy">Privacy Policy</a> | 
<a href="https://www.newsday.com/terms">Terms of service</a> |
<a href="https://www.newsday.com/homedeliveryterms">Subscription terms</a> |
<a href="https://www.newsday.com/services/affiliated-sites-linked-sites-and-advertisements-1.4715345">Your ad choices</a> |
<a href="javascript:;" class="ot-sdk-show-settings"> Cookie Settings</a> |
<a href="https://www.newsday.com/services/newsday-llc-privacy-policy-1.2515999#cal">California Privacy Rights</a> |
<a href="https://projects.newsday.com/long-island/about-us/">About Us</a> |
<a href="https://www.newsday.com/contact">Contact Newsday</a> |
<a href="http://www.newsdayreprints.com/">Reprints & permissions</a> |
<a href="https://www.newsday.com/advertise">Advertise with Newsday</a> |
<a href="https://www.newsday.com/sitemap" >Sitemap</a> |
<a href="https://www.newsday.com/help">Help</a>
</p>
<p class="copyright"></p>
<div class="soc">
<a href="https://www.newsday.com/facebook" class="fa fa-facebook" aria-hidden="true" aria-label="Visit Newsday on Facebook"></a>
<a href="https://www.newsday.com/twitter" class="fa fa-twitter" aria-hidden="true" aria-label="Visit Newsday on Twitter"></a>
<a href="https://www.instagram.com/newsday" class="fa fa-instagram" aria-hidden="true" aria-label="Visit Newsday on Instagram"></a>
</div>
</section>
		</footer>
							<script>
	var adzone = "/5819/nwsd.desktop/sports/jets";
	var sectionType = "frontA";
	var pageType = "article";
	var hasTopBCVid = "false";
	var kw = "newsday,afc east,new york jets,american football conference,source,sports,nfl";
	</script>
	<script src="https://polyfill.io/v3/polyfill.min.js?features=default,Array.prototype.findIndex,IntersectionObserver,fetch,NodeList.prototype.forEach"></script>
	<script src="https://cdnjs.cloudflare.com/ajax/libs/loadCSS/2.1.0/cssrelpreload.min.js"></script>
	<script src="https://cdnjs.cloudflare.com/ajax/libs/jquery/3.5.1/jquery.min.js" integrity="sha512-bLT0Qm9VnAYZDflyKcBaQ2gg0hSYNQrJ8RilYldYQ1FxQYoCLtUjuuRuZo+fjqhx/qtq/1itJ0C2ejDxltZVFg==" crossorigin="anonymous"></script>
 	<script src="https://cdnjs.cloudflare.com/ajax/libs/slippry/1.4.0/slippry.min.js"></script>
 	<script src="https://ak.sail-horizon.com/spm/spm.v1.min.js"></script>
<script>Sailthru.init({ customerId: 'd9fba709002300974859adea5259da0f' });</script> 				<script defer src="/shell/js/article.min.js?v=n2012.1"></script>
						                                	  	<script type="application/ld+json">
    {
    "@context": "https://schema.org",
    "@type": "NewsArticle",
    "mainEntityOfPage": "https://www.newsday.com/sports/football/jets/frank-gore-nfl-future-retirement-jets-1.50110015",
    "headline": "Frank Gore undecided on his NFL future after season with Jets",
    "datePublished": "2021-01-05T12:23:08-05:00",
    "dateModified": "2021-01-05T13:40:02-05:00",
    "dateline": "",
    "description": "Frank Gore hasn&rsquo;t made a decision about whether he will play a 17th NFL season, but he might return if the right opportunity presents itself. &quot;I still have fun playing the game of football,&quot; Gore said",
    "author": {
    "@type": "Person",
    "name": "Al Iannazzone"
    },
    "publisher": {
    "@type": "Organization",
    "name": "Newsday",
    "logo": {
    "@type": "ImageObject",
    "url": "https://www.newsday.com/img/amp/newsday-amp-pub-logo.png",
    "width": 600,
    "height": 60
    }
    },
    "image": {
    "@type": "ImageObject",
    "url": "https://cdn.newsday.com/polopoly_fs/1.50110016.1609872002!/httpImage/image.jpg_gen/derivatives/landscape_1280/image.jpg",
    "width": 640,
    "height": 360
    }
	    }
</script>
<script type="application/ld+json">
	{
	"@context": "http://schema.org",
	"@type": "BreadcrumbList",
	"itemListElement": [
				 {"@type": "ListItem", "position": 1, "item": { "@id": "https://www.newsday.com/", "name": "Newsday" }}
					, {"@type": "ListItem", "position": 2, "item": { "@id": "https://www.newsday.com/sports", "name": "Sports" }}
					, {"@type": "ListItem", "position": 3, "item": { "@id": "https://www.newsday.com/sports/football", "name": "Football" }}
					, {"@type": "ListItem", "position": 4, "item": { "@id": "https://www.newsday.com/sports/football/jets", "name": "Jets" }}
				]}
</script>
 	<script type='text/javascript'>  (function(){    var logUrl = '/logger/p.gif?a=1.50110015&amp;d=/2.810/2.893/2.906/2.908';    var referrer = document.referrer;    if (referrer && referrer.length > 0) {      logUrl += '&referrer=' + referrer;    }    document.write('<img src="' + logUrl + '" />');  })();</script><script type="text/javascript">
function statisticLogger() {
	if (window.jQuery) {
		jQuery.ajax({
			url: '/logger/p.gif?a=1.50110015&d=/2.810/2.893/2.906/2.908&type=MIXEDTYPE&ct=430_432,430,0',
			type: 'POST'
		});
	} else {
		setTimeout(function() { statisticLogger() }, 100);
	}
}
statisticLogger();
</script>
					<div id="pageData" data-videoviews="1" data-hotjar="false" data-contenttype="article" data-region="Long Island" data-omni='{"pagename":"Frank Gore undecided on his NFL future after season with Jets - Newsday:Sports:Football:Jets ","server":"newsday","sitesection":"sports","sitesubsection":"football","sitesubsection2":"jets","sitesubsection3":"jets","sitesubsection4":"jets","contenttitle":"Frank Gore undecided on his NFL future after season with Jets","contentitemid":"1.50110015","contentsource":"newsday","hier":"Newsday:Sports:Football:Jets","categories":"newsday,afc east,new york jets,american football conference,source,sports,nfl","omnicode":"reg","section":"jets","author":"Al Iannazzone","pubdate":"1609872001939","contentview":"web","contenttype":"article","setblocked":"metered"}'></div>
<script async type="text/javascript" src="/_Incapsula_Resource?SWJIYLWA=719d34d31c8e3a6e6fffd425f7e032f3&ns=7&cb=1899458212"></script>
</body>
</html>
