<!DOCTYPE html><html><head><meta name="viewport" content="width=device-width"/><meta charSet="utf-8"/><link rel="preconnect" href="https://fonts.googleapis.com"/><link rel="dns-prefetch" href="https://fonts.googleapis.com"/><link rel="preconnect" href="https://htlbid.com"/><link rel="dns-prefetch" href="https://htlbid.com"/><link rel="preconnect" href="https://loader-cdn.azureedge.net"/><link rel="dns-prefetch" href="https://loader-cdn.azureedge.net"/><link rel="preconnect" href="https://cdn.bc0a.com"/><link rel="dns-prefetch" href="https://cdn.bc0a.com"/><link rel="preconnect" href="https://widgets.sports.gracenote.com/"/><link rel="dns-prefetch" href="https://widgets.sports.gracenote.com/"/><title>Davidoff: Write it down; a new Jeter chapter looms - Newsday</title><meta name="robots" content="index,follow"/><meta name="googlebot" content="index,follow"/><meta name="description" content="This love story between the Yankees and Derek Jeter isn&#x27;t over. It&#x27;s simply time to move on to the next chapter."/><meta name="twitter:card" content="summary_large_image"/><meta name="twitter:site" content="@newsday"/><meta name="twitter:creator" content="@newsday"/><meta property="og:title" content="Davidoff: Write it down; a new Jeter chapter looms"/><meta property="og:description" content="This love story between the Yankees and Derek Jeter isn&#x27;t over. It&#x27;s simply time to move on to the next chapter."/><meta property="og:url" content="https://www.newsday.com/news/davidoff-write-it-down-a-new-jeter-chapter-looms-e41680"/><meta property="og:type" content="article"/><meta property="og:image" content="https://cdn.newsday.com/ace/c:Y2I3NzU2ZWMtY2U3MS00:N2NkYmFj/preview/1280"/><meta property="og:site_name" content="Newsday"/><link rel="canonical" href="https://www.newsday.com/news/davidoff-write-it-down-a-new-jeter-chapter-looms-e41680"/><meta name="apple-itunes-app" content="app-id=358571317, affiliate-data=, app-argument=https://itunes.apple.com/us/app/newsday/id358571317?mt=8"/><meta name="msvalidate.01" content="AC41EB10D1EC6B5358F0ECA0E861CCAA"/><meta name="theme-color" content="#0077c8"/><meta name="google-site-verification" content="WS-IPs_DqbPtrQ9XhKPi_32a-1spE4tjsjhWUqwVVns"/><meta name="application-name" content="Newsday"/><meta name="fb:pages" content="19175874448"/><meta name="origin-trial" content="AxNC/9eKMmjjy1dTV1CFOUFT7kXZR87jH426QDYyiSzWBNkMnd8eKsK1/WRyinBMBUJGp8r1lDKn1ERUehny9g0AAACBeyJvcmlnaW4iOiJodHRwczovL3d3dy5uZXdzZGF5LmNvbTo0NDMiLCJmZWF0dXJlIjoiSW50ZXJlc3RDb2hvcnRBUEkiLCJleHBpcnkiOjE2MjYyMjA3OTksImlzU3ViZG9tYWluIjp0cnVlLCJpc1RoaXJkUGFydHkiOnRydWV9"/><meta name="fb:app_id" content="147686468041"/><meta name="twitter:image" content="https://cdn.newsday.com/ace/c:Y2I3NzU2ZWMtY2U3MS00:N2NkYmFj/preview/1280"/><meta name="twitter:app:id:iphone" content="358571317"/><meta name="twitter:app:id:ipad" content="358571317"/><meta name="twitter:app:id:googleplay" content="com.pagesuite.newsday"/><meta name="keywords" content="New York Yankees, MLB, American League, AL East, sports baseball yankees  column, Sports"/><meta name="sailthru.title" content="Davidoff: Write it down; a new Jeter chapter looms"/><meta name="sailthru.date" content="2010-10-23T21:05:00.996Z"/><meta name="sailthru.author" content="KEN DAVIDOFF"/><meta name="onecmsid"/><link rel="amphtml" href="https://www.newsday.com/amp/news/davidoff-write-it-down-a-new-jeter-chapter-looms-e41680"/><link rel="alternate" href="android-app://com.pagesuite.newsday/https://www.newsday.com/json/news/davidoff-write-it-down-a-new-jeter-chapter-looms-e41680"/><link rel="alternate" href="ios-app://com.pagesuite.newsday/https://www.newsday.com/json/news/davidoff-write-it-down-a-new-jeter-chapter-looms-e41680"/><script type="application/ld+json">{"@context":"https://schema.org/","@type":"NewsArticle","mainEntityOfPage":"https://www.newsday.com/news/davidoff-write-it-down-a-new-jeter-chapter-looms-e41680","headline":"Davidoff: Write it down; a new Jeter chapter looms","image":"https://cdn.newsday.com/ace/c:Y2I3NzU2ZWMtY2U3MS00:N2NkYmFj/landscape/1280","datePublished":"2010-10-23T21:05:00.996Z","dateModified":"2010-10-23T21:05:00.996Z","description":"This love story between the Yankees and Derek Jeter isn't over. It's simply time to move on to the next chapter.","articleSection":"News","keywords":["New York Yankees,MLB,American League,AL East,sports baseball yankees  column,Sports"],"author":{"@type":"Person","name":"KEN DAVIDOFF","url":"https://www.newsday.com"},"publisher":{"@type":"Organization","name":"Newsday","logo":{"@type":"ImageObject","url":"https://www.newsday.com/img/newsday/newsday-amp-logo.png"}}}</script><script type="application/ld+json">{"@context":"http://schema.org/","@type":"BreadcrumbList","itemListElement":[{"@type":"ListItem","position":1,"name":"News","item":"https://www.newsday.com/news"}]}</script><meta name="next-head-count" content="48"/><link rel="preconnect" href="https://fonts.gstatic.com" crossorigin /><link rel="preload" href="/_next/static/css/d5ba6ea1f68c1277.css" as="style"/><link rel="stylesheet" href="/_next/static/css/d5ba6ea1f68c1277.css" data-n-g=""/><link rel="preload" href="/_next/static/css/87af389dc1f9cafe.css" as="style"/><link rel="stylesheet" href="/_next/static/css/87af389dc1f9cafe.css" data-n-p=""/><link rel="preload" href="/_next/static/css/eb7d499c56e85ee7.css" as="style"/><link rel="stylesheet" href="/_next/static/css/eb7d499c56e85ee7.css" data-n-p=""/><noscript data-n-css=""></noscript><script defer="" nomodule="" src="/_next/static/chunks/polyfills-5cd94c89d3acac5f.js"></script><script src="/_next/static/chunks/webpack-9f0db76b10536471.js" defer=""></script><script src="/_next/static/chunks/framework-01395af778c6fb71.js" defer=""></script><script src="/_next/static/chunks/main-5259727d11497e4f.js" defer=""></script><script src="/_next/static/chunks/pages/_app-7e3d44ad547b5997.js" defer=""></script><script src="/_next/static/chunks/2852872c-51c4d2a684a409ef.js" defer=""></script><script src="/_next/static/chunks/75fc9c18-fea2000435392bbf.js" defer=""></script><script src="/_next/static/chunks/69-4a597a91bb388aae.js" defer=""></script><script src="/_next/static/chunks/753-93209f4378149df3.js" defer=""></script><script src="/_next/static/chunks/642-513d14c39da72c1b.js" defer=""></script><script src="/_next/static/chunks/656-d7e56e56445d9d31.js" defer=""></script><script src="/_next/static/chunks/pages/%5B...pages%5D-c9a4913442554a6a.js" defer=""></script><script src="/_next/static/newsday-prod-20220505050015/_buildManifest.js" defer=""></script><script src="/_next/static/newsday-prod-20220505050015/_ssgManifest.js" defer=""></script><script src="/_next/static/newsday-prod-20220505050015/_middlewareManifest.js" defer=""></script><style data-href="https://fonts.googleapis.com/css2?family=Lato:wght@400;700;900&family=Work+Sans:wght@600;800&display=swap">@font-face{font-family:'Lato';font-style:normal;font-weight:400;font-display:swap;src:url(https://fonts.gstatic.com/s/lato/v23/S6uyw4BMUTPHvxo.woff) format('woff')}@font-face{font-family:'Lato';font-style:normal;font-weight:700;font-display:swap;src:url(https://fonts.gstatic.com/s/lato/v23/S6u9w4BMUTPHh6UVeww.woff) format('woff')}@font-face{font-family:'Lato';font-style:normal;font-weight:900;font-display:swap;src:url(https://fonts.gstatic.com/s/lato/v23/S6u9w4BMUTPHh50Xeww.woff) format('woff')}@font-face{font-family:'Work Sans';font-style:normal;font-weight:600;font-display:swap;src:url(https://fonts.gstatic.com/s/worksans/v17/QGY_z_wNahGAdqQ43RhVcIgYT2Xz5u32K5fQNis.woff) format('woff')}@font-face{font-family:'Work Sans';font-style:normal;font-weight:800;font-display:swap;src:url(https://fonts.gstatic.com/s/worksans/v17/QGY_z_wNahGAdqQ43RhVcIgYT2Xz5u32K8nQNis.woff) format('woff')}@font-face{font-family:'Lato';font-style:normal;font-weight:400;font-display:swap;src:url(https://fonts.gstatic.com/s/lato/v23/S6uyw4BMUTPHjxAwXiWtFCfQ7A.woff2) format('woff2');unicode-range:U+0100-024F,U+0259,U+1E00-1EFF,U+2020,U+20A0-20AB,U+20AD-20CF,U+2113,U+2C60-2C7F,U+A720-A7FF}@font-face{font-family:'Lato';font-style:normal;font-weight:400;font-display:swap;src:url(https://fonts.gstatic.com/s/lato/v23/S6uyw4BMUTPHjx4wXiWtFCc.woff2) format('woff2');unicode-range:U+0000-00FF,U+0131,U+0152-0153,U+02BB-02BC,U+02C6,U+02DA,U+02DC,U+2000-206F,U+2074,U+20AC,U+2122,U+2191,U+2193,U+2212,U+2215,U+FEFF,U+FFFD}@font-face{font-family:'Lato';font-style:normal;font-weight:700;font-display:swap;src:url(https://fonts.gstatic.com/s/lato/v23/S6u9w4BMUTPHh6UVSwaPGQ3q5d0N7w.woff2) format('woff2');unicode-range:U+0100-024F,U+0259,U+1E00-1EFF,U+2020,U+20A0-20AB,U+20AD-20CF,U+2113,U+2C60-2C7F,U+A720-A7FF}@font-face{font-family:'Lato';font-style:normal;font-weight:700;font-display:swap;src:url(https://fonts.gstatic.com/s/lato/v23/S6u9w4BMUTPHh6UVSwiPGQ3q5d0.woff2) format('woff2');unicode-range:U+0000-00FF,U+0131,U+0152-0153,U+02BB-02BC,U+02C6,U+02DA,U+02DC,U+2000-206F,U+2074,U+20AC,U+2122,U+2191,U+2193,U+2212,U+2215,U+FEFF,U+FFFD}@font-face{font-family:'Lato';font-style:normal;font-weight:900;font-display:swap;src:url(https://fonts.gstatic.com/s/lato/v23/S6u9w4BMUTPHh50XSwaPGQ3q5d0N7w.woff2) format('woff2');unicode-range:U+0100-024F,U+0259,U+1E00-1EFF,U+2020,U+20A0-20AB,U+20AD-20CF,U+2113,U+2C60-2C7F,U+A720-A7FF}@font-face{font-family:'Lato';font-style:normal;font-weight:900;font-display:swap;src:url(https://fonts.gstatic.com/s/lato/v23/S6u9w4BMUTPHh50XSwiPGQ3q5d0.woff2) format('woff2');unicode-range:U+0000-00FF,U+0131,U+0152-0153,U+02BB-02BC,U+02C6,U+02DA,U+02DC,U+2000-206F,U+2074,U+20AC,U+2122,U+2191,U+2193,U+2212,U+2215,U+FEFF,U+FFFD}@font-face{font-family:'Work Sans';font-style:normal;font-weight:600;font-display:swap;src:url(https://fonts.gstatic.com/s/worksans/v17/QGYsz_wNahGAdqQ43Rh_c6DptfpA4cD3.woff2) format('woff2');unicode-range:U+0102-0103,U+0110-0111,U+0128-0129,U+0168-0169,U+01A0-01A1,U+01AF-01B0,U+1EA0-1EF9,U+20AB}@font-face{font-family:'Work Sans';font-style:normal;font-weight:600;font-display:swap;src:url(https://fonts.gstatic.com/s/worksans/v17/QGYsz_wNahGAdqQ43Rh_cqDptfpA4cD3.woff2) format('woff2');unicode-range:U+0100-024F,U+0259,U+1E00-1EFF,U+2020,U+20A0-20AB,U+20AD-20CF,U+2113,U+2C60-2C7F,U+A720-A7FF}@font-face{font-family:'Work Sans';font-style:normal;font-weight:600;font-display:swap;src:url(https://fonts.gstatic.com/s/worksans/v17/QGYsz_wNahGAdqQ43Rh_fKDptfpA4Q.woff2) format('woff2');unicode-range:U+0000-00FF,U+0131,U+0152-0153,U+02BB-02BC,U+02C6,U+02DA,U+02DC,U+2000-206F,U+2074,U+20AC,U+2122,U+2191,U+2193,U+2212,U+2215,U+FEFF,U+FFFD}@font-face{font-family:'Work Sans';font-style:normal;font-weight:800;font-display:swap;src:url(https://fonts.gstatic.com/s/worksans/v17/QGYsz_wNahGAdqQ43Rh_c6DptfpA4cD3.woff2) format('woff2');unicode-range:U+0102-0103,U+0110-0111,U+0128-0129,U+0168-0169,U+01A0-01A1,U+01AF-01B0,U+1EA0-1EF9,U+20AB}@font-face{font-family:'Work Sans';font-style:normal;font-weight:800;font-display:swap;src:url(https://fonts.gstatic.com/s/worksans/v17/QGYsz_wNahGAdqQ43Rh_cqDptfpA4cD3.woff2) format('woff2');unicode-range:U+0100-024F,U+0259,U+1E00-1EFF,U+2020,U+20A0-20AB,U+20AD-20CF,U+2113,U+2C60-2C7F,U+A720-A7FF}@font-face{font-family:'Work Sans';font-style:normal;font-weight:800;font-display:swap;src:url(https://fonts.gstatic.com/s/worksans/v17/QGYsz_wNahGAdqQ43Rh_fKDptfpA4Q.woff2) format('woff2');unicode-range:U+0000-00FF,U+0131,U+0152-0153,U+02BB-02BC,U+02C6,U+02DA,U+02DC,U+2000-206F,U+2074,U+20AC,U+2122,U+2191,U+2193,U+2212,U+2215,U+FEFF,U+FFFD}</style></head><body><div id="__next" data-reactroot=""><link rel="shortcut icon" href="/img/newsday/favicon.ico" type="image/x-icon"/><link rel="apple-touch-icon" sizes="180x180" href="/img/newsday/apple-touch-icon-120x120.png"/><header class="Header_masthead__H8Ys6 " role="banner"><div class="Header_container__7nNih container"><div class="Header_headL__rc56_ "><a href="#site-content" class="Header_skip-play__CoFXL">Skip to content</a><button class="Header_menu-btn__I72i8 mBtn" aria-label="Menu"><span></span><em>Menu</em></button><a class="actToggle Header_sBtn__2Bta7 ss" href="/eedition"><em>Today&#x27;s paper</em></a></div><a class="Header_logo__gECVj" href="/"><img alt="Newsday" src="/img/newsdayLogo.svg" width="140" height="48"/></a><div class="Header_headR___wLkG"><div class="Header_logStatus__75qZk"><a href="#" class="Header_not-loggedin__RiWAs logInbtn MG2login Header_active__lKnmL" data-mg2-action="activation"><em>Log in</em></a><div class="subacct MG2Subscribe Header_active__lKnmL"><a class="Header_tBtn__Uvfkt subacct Header_active__lKnmL" id="MG2Subscribe" href="/subscribe"><em>Subscribe </em><span>$1 FOR 5 MONTHS</span></a></div></div></div></div></header><div class="Header_sub-nav__ML115"><div class="Header_container__7nNih container"><div class="searchBox" data-step="9" data-intro="We&#x27;ve upgraded our search engine to help you find exactly what you are looking for."></div><nav id="nav"><a class="Header_long-island__FEqE_ " href="/long-island">Long Island</a><a class="Header_sports__KAVtN " href="/sports">Sports</a><a class="newsday-tv " href="https://tv.newsday.com">Newsday TV</a><a class="news " href="/news/nation">News</a><a class="feedme " href="/lifestyle/restaurants">FeedMe</a><a class="Header_opinion__AHXmR " href="/opinion">Opinion</a><a class="Header_business__huH8N " href="/business">Business</a><a class="obituaries " href="https://www.legacy.com/obituaries/newsday/">Obituaries</a><a class="newsday-live " href="/newsday-live">Newsday Live</a><a class="Header_search__esM9R " href="/search">Search</a></nav></div></div><div class="SandwichNav_pane__h00mP"><button aria-label="Close" class="SandwichNav_x__k2ZiE btn"></button><section class="Weather_weather__96w_g"></section></div><main class="container"><article class="story full news"><div class="ad_full-banner__7KJ4Q ad_ad__3q0Ak ad_top__OVens"></div><header id="head" class="PageHeader_page-top__AalO8 "><strong class="Breadcrumbs_breadcrumb__N9C7C"><a href="/news">News</a></strong><h1>Davidoff: Write it down; a new Jeter chapter looms</h1></header><div class="primary"><figure class="Image_img__4B696 landscape "><span style="box-sizing:border-box;display:block;overflow:hidden;width:initial;height:initial;background:none;opacity:1;border:0;margin:0;padding:0;position:relative"><span style="box-sizing:border-box;display:block;width:initial;height:initial;background:none;opacity:1;border:0;margin:0;padding:0;padding-top:56.25%"></span><img alt="New York Yankees&#x27; Derek Jeter adjusts his cap during batting..." src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" decoding="async" data-nimg="responsive" style="position:absolute;top:0;left:0;bottom:0;right:0;box-sizing:border-box;padding:0;border:none;margin:auto;display:block;width:0;height:0;min-width:100%;max-width:100%;min-height:100%;max-height:100%"/><noscript><img alt="New York Yankees&#x27; Derek Jeter adjusts his cap during batting..." sizes="100vw" srcSet="/_next/image?url=https%3A%2F%2Fcdn.newsday.com%2Fimage-service%2Fversion%2Fc%3AY2I3NzU2ZWMtY2U3MS00%3AN2NkYmFj%2Falcs-yankees-rangers-baseball.jpg%3Ff%3DLandscape%2B16%253A9%26w%3D770%26q%3D1&amp;w=640&amp;q=60 640w, /_next/image?url=https%3A%2F%2Fcdn.newsday.com%2Fimage-service%2Fversion%2Fc%3AY2I3NzU2ZWMtY2U3MS00%3AN2NkYmFj%2Falcs-yankees-rangers-baseball.jpg%3Ff%3DLandscape%2B16%253A9%26w%3D770%26q%3D1&amp;w=750&amp;q=60 750w, /_next/image?url=https%3A%2F%2Fcdn.newsday.com%2Fimage-service%2Fversion%2Fc%3AY2I3NzU2ZWMtY2U3MS00%3AN2NkYmFj%2Falcs-yankees-rangers-baseball.jpg%3Ff%3DLandscape%2B16%253A9%26w%3D770%26q%3D1&amp;w=828&amp;q=60 828w, /_next/image?url=https%3A%2F%2Fcdn.newsday.com%2Fimage-service%2Fversion%2Fc%3AY2I3NzU2ZWMtY2U3MS00%3AN2NkYmFj%2Falcs-yankees-rangers-baseball.jpg%3Ff%3DLandscape%2B16%253A9%26w%3D770%26q%3D1&amp;w=1080&amp;q=60 1080w, /_next/image?url=https%3A%2F%2Fcdn.newsday.com%2Fimage-service%2Fversion%2Fc%3AY2I3NzU2ZWMtY2U3MS00%3AN2NkYmFj%2Falcs-yankees-rangers-baseball.jpg%3Ff%3DLandscape%2B16%253A9%26w%3D770%26q%3D1&amp;w=1200&amp;q=60 1200w, /_next/image?url=https%3A%2F%2Fcdn.newsday.com%2Fimage-service%2Fversion%2Fc%3AY2I3NzU2ZWMtY2U3MS00%3AN2NkYmFj%2Falcs-yankees-rangers-baseball.jpg%3Ff%3DLandscape%2B16%253A9%26w%3D770%26q%3D1&amp;w=1920&amp;q=60 1920w, /_next/image?url=https%3A%2F%2Fcdn.newsday.com%2Fimage-service%2Fversion%2Fc%3AY2I3NzU2ZWMtY2U3MS00%3AN2NkYmFj%2Falcs-yankees-rangers-baseball.jpg%3Ff%3DLandscape%2B16%253A9%26w%3D770%26q%3D1&amp;w=2048&amp;q=60 2048w, /_next/image?url=https%3A%2F%2Fcdn.newsday.com%2Fimage-service%2Fversion%2Fc%3AY2I3NzU2ZWMtY2U3MS00%3AN2NkYmFj%2Falcs-yankees-rangers-baseball.jpg%3Ff%3DLandscape%2B16%253A9%26w%3D770%26q%3D1&amp;w=3840&amp;q=60 3840w" src="/_next/image?url=https%3A%2F%2Fcdn.newsday.com%2Fimage-service%2Fversion%2Fc%3AY2I3NzU2ZWMtY2U3MS00%3AN2NkYmFj%2Falcs-yankees-rangers-baseball.jpg%3Ff%3DLandscape%2B16%253A9%26w%3D770%26q%3D1&amp;w=3840&amp;q=60" decoding="async" data-nimg="responsive" style="position:absolute;top:0;left:0;bottom:0;right:0;box-sizing:border-box;padding:0;border:none;margin:auto;display:block;width:0;height:0;min-width:100%;max-width:100%;min-height:100%;max-height:100%" loading="lazy"/></noscript></span><figcaption><p><a href="/topics/New_York_Yankees">New York Yankees</a>&#x27; <a href="/topics/Derek_Jeter">Derek Jeter</a> adjusts his cap during batting practice before Game 6 of baseball&#x27;s <a href="/topics/American_League_Championship_Series">American League Championship Series</a> against the <a href="/topics/Texas_Rangers">Texas Rangers</a>. (Oct. 22, 2010) <!-- --> Credit: AP  </p></figcaption></figure><div class="Byline_byline__6oRUO"><strong>By <!-- -->KEN DAVIDOFF</strong><a href="mailto:ken.davidoff@newsday.com?subject=Davidoff: Write it down; a new Jeter chapter looms">ken.davidoff@newsday.com</a><time dateTime="2010-10-23T21:05:00.996Z">October 23, 2010</time></div><div class="share-tools_share-tools__Dp35p"><a class="share-tools_fb__R9Wr5" rel="noopener noreferrer" href="https://www.facebook.com/sharer/sharer.php?u=https://www.newsday.com/news/davidoff-write-it-down-a-new-jeter-chapter-looms-e41680" width="600" height="360" target="_blank"><svg class="icon" aria-label="Share on Facebook"><use href="/img/site-icon-sprites.svg#facebook-f"></use></svg> </a><a class="share-tools_tw__eGGWu" rel="noopener noreferrer" href="https://twitter.com/intent/tweet?text=Davidoff: Write it down; a new Jeter chapter looms&amp;url=https://www.newsday.com/news/davidoff-write-it-down-a-new-jeter-chapter-looms-e41680&amp;via=Newsday" data-mention="@Newsday" width="550" height="440" target="_blank"><svg class="icon twitter" aria-label="Share on Twitter"><use href="/img/site-icon-sprites.svg#twitter"></use></svg> </a><a class="share-tools_env__eRS0O" href="mailto:?subject=Davidoff: Write it down; a new Jeter chapter looms&amp;body=This love story between the Yankees and Derek Jeter isn&#x27;t over. It&#x27;s simply time to move on to the next chapter.,%0D%0Ahttps://www.newsday.com/news/davidoff-write-it-down-a-new-jeter-chapter-looms-e41680" data-rel="external"><svg class="icon" aria-label="Email this story"><use href="/img/site-icon-sprites.svg#envelope"></use></svg> </a><button class="share-tools_print-btn__HpVlH print"><svg class="icon" aria-label="Print page"><use href="/img/site-icon-sprites.svg#print"></use></svg></button></div><div class="contentAccess"><div class="ContinueReading_continue-reading__SAZgU " style="max-height:100%"><p>When reporters asked Derek Jeter to assess his 2010 season minutes after the <a href="/topics/Glasgow_Rangers">Rangers</a> eliminated the Yankees in the <a href="/topics/American_League_Championship_Series">American League Championship Series</a> Friday night, the captain followed form and kept things simple:</p><p>&quot;It&#x27;s over.&#x27;&#x27;</p><p>He&#x27;s right in more ways than he perhaps realized. With Jeter&#x27;s 10-year, $189-million contract having reached its completion - and largely as a success, let&#x27;s stress - a cultural change is coming to the Yankees.</p><div class="ad_full-banner__7KJ4Q ad_ad__3q0Ak ad_midPg__vKnGR"></div><p>Oh, Jeter will be back with the Yankees next season. But his reign as the emperor with no slugging percentage? That&#x27;s over.</p><p>More important than the dollars and years this new deal features will be the elimination of the delicacy with which the Yankees have treated Jeter. Rather than &quot;Derek Jeter, He Who Can Do No Wrong,&quot; he&#x27;ll be a respected veteran who must acknowledge his fading abilities.</p><div class="Newsletter_newsletter-widget__XU6fU"><div><strong for="userContact">Sign up for the NewsdayTV newsletter</strong><p>From breaking news to special features and documentaries, the NewsdayTV team is covering the issues that matter to you.</p></div><div><form class="subscribeForm" action="" method="POST"><input type="email" class="false" name="email" placeholder="Email address" required="" autoComplete="email"/><button class="btn">Sign up</button></form></div><p class="Newsletter_disclaimer__ehQ25">By clicking Sign up, you agree to our<!-- --> <a href="/privacy">privacy policy</a>.</p></div><p>That means dropping him in the lineup if he doesn&#x27;t pick up his offense in 2011. That means eventually moving him out of shortstop, although that&#x27;s a secondary concern right now. He didn&#x27;t hit well enough in 2010 to support a less demanding defensive position, anyway, in what marked the worst season of his major-league career.</p><p>Let&#x27;s not count out Jeter altogether. It&#x27;s a decent bet that he puts up better numbers in 2011 than he did in 2010. But it&#x27;s a terrible wager that he&#x27;ll ever come close again to the 2009 statistics that made him an AL Most Valuable Player candidate.</p><p>He&#x27;s not a liability. Nor is he an immense asset.</p><p>The prediction here is that the Yankees cover Jeter on the dollars side while covering themselves on the years side. How about three years and $60 million? That way, Jeter can get paid like royalty and the Yankees can mitigate the chances of awkward tension with a completely useless version of Jeter.</p><p>Yankees ownership and management have gotten better at avoiding albatross contracts, but they still have a great deal of room for improvement. <a href="/topics/A.J._Burnett">A.J. Burnett</a> seems like a disaster, and <a href="/topics/Jorge_Posada">Jorge Posada</a> likely will spend the bulk of 2011 as a pricey designated hitter. And as much as <a href="/topics/Cliff_Lee">Cliff Lee</a> represents a cure to all that ails them, it would represent significant foolishness to commit, say, a six-year deal to a pitcher who will turn 33 in the first season of that contract.</p><div class="ad_full-banner__7KJ4Q ad_ad__3q0Ak ad_midPg__vKnGR"></div><p>The fans would never turn on Jeter, but they&#x27;d turn on the notion of Jeter getting playing time for the Yankees if he can&#x27;t defeat Father Time. Think of <a href="/topics/Bernie_Williams">Bernie Williams</a>&#x27; 2005 season, his final campaign as the Yankees&#x27; starting centerfielder. Most fans took on a &quot;Love the stinker, hate the stink&quot; approach, as they cheered Williams while pleading with management to find his replacement.</p><p>The Yankees need to take the lead to make sure it never reaches that with Jeter. There&#x27;s pride and then there&#x27;s denial, and you wonder if Jeter appreciates the gulf between the two. His refusal to be reflective explains his greatness - dude never seems to lose confidence - but he&#x27;ll be the last to acknowledge his humanity.</p><p>To reiterate, Jeter needs the Yankees more than the Yankees need Jeter. His whole brand is built on integrity and selflessness. Do you really think he&#x27;d blow that up by taking off because, in his mind, the Yankees wouldn&#x27;t sufficiently kiss his <a href="/topics/World_Series">World Series</a> rings?</p><p>No, this relationship will continue, and it will have a new vibe. One that is healthier for the future success of both the organization and Jeter.</p><p>This love story between the Yankees and Jeter isn&#x27;t over. It&#x27;s simply time to move on to the next chapter.</p><div class="share-tools_share-tools__Dp35p share-method share-tools_big__rPHOS"><a class="share-tools_fb__R9Wr5" rel="noopener noreferrer" href="https://www.facebook.com/sharer/sharer.php?u=https://www.newsday.com/news/davidoff-write-it-down-a-new-jeter-chapter-looms-e41680" width="600" height="360" target="_blank"><svg class="icon" aria-label="Share on Facebook"><use href="/img/site-icon-sprites.svg#facebook-f"></use></svg> <span>Share on Facebook</span></a><a class="share-tools_tw__eGGWu" rel="noopener noreferrer" href="https://twitter.com/intent/tweet?text=Davidoff: Write it down; a new Jeter chapter looms&amp;url=https://www.newsday.com/news/davidoff-write-it-down-a-new-jeter-chapter-looms-e41680&amp;via=Newsday" data-mention="@Newsday" width="550" height="440" target="_blank"><svg class="icon twitter" aria-label="Share on Twitter"><use href="/img/site-icon-sprites.svg#twitter"></use></svg> <span>Share on Twitter</span></a><a class="share-tools_env__eRS0O" href="mailto:?subject=Davidoff: Write it down; a new Jeter chapter looms&amp;body=This love story between the Yankees and Derek Jeter isn&#x27;t over. It&#x27;s simply time to move on to the next chapter.,%0D%0Ahttps://www.newsday.com/news/davidoff-write-it-down-a-new-jeter-chapter-looms-e41680" data-rel="external"><svg class="icon" aria-label="Email this story"><use href="/img/site-icon-sprites.svg#envelope"></use></svg> <span>Email this story</span></a></div></div></div></div><div id="pageData" data-omni="{&quot;setblockedsite&quot;:&quot;metered&quot;}"></div><div class="nativo"></div></article></main><div class="Footer_footer-search__y7pUg"><div class="be-ix-link-block"></div><strong>Didn&#x27;t find what you were looking for?</strong><form name="search-form" method="GET" action=""><fieldset><input type="search" class="text" placeholder="Search newsday.com" autoComplete="off" autoCorrect="off" maxLength="512"/><button value="Search" class="ltBtn" type="submit" aria-label="Search"><svg class="Icon_icon__QfSMz"><use href="/img/site-icon-sprites.svg#search"></use></svg></button></fieldset></form></div><div class="ad_full-banner__7KJ4Q ad_ad__3q0Ak bottom"></div><footer class="Footer_site-footer__O9YZP"><div id="toaster-wrap" class="subOffer fixed-bottom"></div><section id="foot" class="container"><div class="Footer_link-columns__4K4MZ"><nav class="col-4"><h3>Quick Links</h3><a href="https://projects.newsday.com/long-island/about-us/">About Us</a><a href="/subscribe">Subscribe</a><a href="https://paper.newsday.com">Today&#x27;s paper</a><a href="/newsletters">Email newsletters</a><a href="/newsday-live">Newsday Live</a><a href="https://www.newsdaycharities.org/">Newsday Charities</a><a href="/careers">Careers</a><a href="/manageaccount">Manage my account</a><a href="https://mediakit.newsday.com/">Media Kit</a><a href="https://mediakit.newsday.com/brand360/">Brand 360</a><a href="/services/newsday-apps-ios-android-wdhvqyhx">Mobile &amp; TV apps</a><a href="/services/contest">Contests</a><a href="https://newsday.newspapers.com/">Archives</a></nav><nav class="col-4"><h3>Partners</h3><a href="https://productions.newsday.com/">Newsday Productions</a><a href="/classifieds/cars">Newsday Cars</a><a href="/classifieds/real-estate">Newsday Homes</a><a href="/classifieds/jobs">Newsday Jobs</a><a href="https://newsdayconnect.com/">Newsday Connect</a><a href="http://www.hometownshopperli.com/">Hometown Shopper</a></nav><nav class="col-4"><h3>News</h3><a href="/long-island">Long Island</a><a href="/sports">Sports</a><a href="/opinion">Opinion</a><a href="/long-island/politics">Politics</a><a href="/news/nation">News</a><a href="/business">Business</a><a href="/long-island/towns">Towns</a><a href="/sports/high-school">High school sports</a></nav><nav class="col-4"><h3>More</h3><a href="/funbook">Funbook</a><a href="https://www.legacy.com/obituaries/newsday/">Obituaries</a><a href="/entertainment/crossword-puzzle">Crosswords</a><a href="/lifestyle">Things to Do</a><a href="/entertainment">Entertainment</a><a href="/lifestyle/restaurants">Restaurants</a><a href="/lifestyle/family">Family</a><a href="/travel">Travel</a></nav></div><p><a href="/privacy">Privacy Policy</a> <!-- -->|<a href="/terms">Terms of service</a> <!-- -->|<a href="/homedeliveryterms">Subscription terms</a> <!-- -->|<a href="/services/ad-choices-s4co9cpn">Your ad choices</a> <!-- -->|<a class="ot-sdk-show-settings" href="/news/davidoff-write-it-down-a-new-jeter-chapter-looms-e41680#">Cookie Settings</a> <!-- -->|<a href="/services/newsday-llc-privacy-policy-fasg61nc#cal">California Privacy Rights</a> <!-- -->|<a href="https://projects.newsday.com/long-island/about-us/">About Us</a> <!-- -->|<a href="/contact">Contact Newsday</a> <!-- -->|<a href="http://www.newsdayreprints.com/">Reprints &amp; permissions</a> <!-- -->|<a href="/advertise">Advertise with Newsday</a> <!-- -->|<a href="/help">Help</a></p><p class="copyright">Copyright ©<!-- -->2022<!-- --> Newsday. All rights reserved.</p><div class="Footer_soc__yODjP"><a aria-label="Visit Newsday on Facebook" href="/facebook"><svg class="icon"><use href="/img/site-icon-sprites.svg#facebook-f"></use></svg></a><a aria-label="Visit Newsday on Twitter" href="/twitter"><svg class="icon"><use href="/img/site-icon-sprites.svg#twitter"></use></svg></a><a aria-label="Visit Newsday on Instagram" href="https://www.instagram.com/newsday"><svg class="icon"><use href="/img/site-icon-sprites.svg#instagram"></use></svg></a></div></section></footer></div><script id="__NEXT_DATA__" type="application/json">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</script></body></html>