<!DOCTYPE html><html lang="en"><head><meta name="viewport" content="width=device-width"/><meta charSet="utf-8"/><link rel="preconnect" href="https://htlbid.com"/><link rel="dns-prefetch" href="https://htlbid.com"/><link rel="preconnect" href="https://loader-cdn.azureedge.net"/><link rel="dns-prefetch" href="https://loader-cdn.azureedge.net"/><link rel="preconnect" href="https://cdn.bc0a.com"/><link rel="dns-prefetch" href="https://cdn.bc0a.com"/><link rel="preconnect" href="https://widgets.sports.gracenote.com/"/><link rel="dns-prefetch" href="https://widgets.sports.gracenote.com/"/><title>Carey’s Mike Catanese undisputed leader of LI’s offense - Newsday</title><meta name="robots" content="index,follow"/><meta name="twitter:card" content="summary_large_image"/><meta name="twitter:site" content="@newsday"/><meta name="twitter:creator" content="@newsday"/><meta property="og:title" content="Carey’s Mike Catanese undisputed leader of LI’s offense"/><meta property="og:url" content="https://www.newsday.com/sports/high-school/football/carey-s-mike-catanese-undisputed-leader-of-li-s-offense-r90887"/><meta property="og:type" content="article"/><meta property="og:image" content="https://cdn.newsday.com/ace/c:MTlkNTRhNjItNDk4OC00:ZGI4Njhl/landscape/1280"/><meta property="og:site_name" content="Newsday"/><link rel="canonical" href="https://www.newsday.com/sports/high-school/football/carey-s-mike-catanese-undisputed-leader-of-li-s-offense-r90887"/><meta name="apple-itunes-app" content="app-id=358571317, affiliate-data=, app-argument=https://itunes.apple.com/us/app/newsday/id358571317?mt=8"/><meta name="msvalidate.01" content="AC41EB10D1EC6B5358F0ECA0E861CCAA"/><meta name="theme-color" content="#0077c8"/><meta name="google-site-verification" content="WS-IPs_DqbPtrQ9XhKPi_32a-1spE4tjsjhWUqwVVns"/><meta name="application-name" content="Newsday"/><meta name="fb:pages" content="19175874448"/><meta name="origin-trial" content="AxNC/9eKMmjjy1dTV1CFOUFT7kXZR87jH426QDYyiSzWBNkMnd8eKsK1/WRyinBMBUJGp8r1lDKn1ERUehny9g0AAACBeyJvcmlnaW4iOiJodHRwczovL3d3dy5uZXdzZGF5LmNvbTo0NDMiLCJmZWF0dXJlIjoiSW50ZXJlc3RDb2hvcnRBUEkiLCJleHBpcnkiOjE2MjYyMjA3OTksImlzU3ViZG9tYWluIjp0cnVlLCJpc1RoaXJkUGFydHkiOnRydWV9"/><meta name="fb:app_id" content="147686468041"/><meta name="twitter:image" content="https://cdn.newsday.com/ace/c:MTlkNTRhNjItNDk4OC00:ZGI4Njhl/landscape/1280"/><meta name="twitter:app:id:iphone" content="358571317"/><meta name="twitter:app:id:ipad" content="358571317"/><meta name="twitter:app:id:googleplay" content="com.pagesuite.newsday"/><meta name="keywords" content="High School, Carey, High School Football, NEWSDAY, Football, Schools, Sports"/><meta name="sailthru.title" content="Carey’s Mike Catanese undisputed leader of LI’s offense"/><meta name="sailthru.date" content="2016-06-23T02:42:00.917Z"/><meta name="sailthru.author" content="Kenny DeJohn"/><meta name="onecmsid"/><link rel="amphtml" href="https://www.newsday.com/amp/sports/high-school/football/carey-s-mike-catanese-undisputed-leader-of-li-s-offense-r90887"/><link rel="alternate" href="android-app://com.pagesuite.newsday/https://www.newsday.com/json/sports/high-school/football/carey-s-mike-catanese-undisputed-leader-of-li-s-offense-r90887"/><link rel="alternate" href="ios-app://com.pagesuite.newsday/https://www.newsday.com/json/sports/high-school/football/carey-s-mike-catanese-undisputed-leader-of-li-s-offense-r90887"/><link rel="alternate" type="application/rss+xml" title="Most recent from newsday.com" href="https://www.newsday.com/api/rss/recent"/><script type="application/ld+json">{"@context":"https://schema.org/","@type":"NewsArticle","mainEntityOfPage":"https://www.newsday.com/sports/high-school/football/carey-s-mike-catanese-undisputed-leader-of-li-s-offense-r90887","headline":"Carey’s Mike Catanese undisputed leader of LI’s offense","image":"https://cdn.newsday.com/ace/c:MTlkNTRhNjItNDk4OC00:ZGI4Njhl/landscape/1280","datePublished":"2016-06-23T02:42:00.917Z","dateModified":"2016-06-23T02:42:00.917Z","articleSection":"Sports","keywords":["High School,Carey,High School Football,NEWSDAY,Football,Schools,Sports"],"author":{"@type":"Person","name":"Kenny DeJohn","url":"https://www.newsday.com"},"publisher":{"@type":"Organization","name":"Newsday","logo":{"@type":"ImageObject","url":"https://www.newsday.com/img/blog-share-nd.jpg"}}}</script><script type="application/ld+json">{"@context":"http://schema.org/","@type":"BreadcrumbList","itemListElement":[{"@type":"ListItem","position":1,"name":"Sports","item":"https://www.newsday.com/sports"},{"@type":"ListItem","position":2,"name":"High School","item":"https://www.newsday.com/sports/high-school"},{"@type":"ListItem","position":3,"name":"High School Football","item":"https://www.newsday.com/sports/high-school/football"}]}</script><link rel="preload" as="image" imagesrcset="/_next/image?url=https%3A%2F%2Fcdn.newsday.com%2Fimage-service%2Fversion%2Fc%3AMTlkNTRhNjItNDk4OC00%3AZGI4Njhl%2Fsports-cropped.jpg%3Ff%3DLandscape%2B16%253A9%26w%3D770%26q%3D1&amp;w=640&amp;q=60 640w, /_next/image?url=https%3A%2F%2Fcdn.newsday.com%2Fimage-service%2Fversion%2Fc%3AMTlkNTRhNjItNDk4OC00%3AZGI4Njhl%2Fsports-cropped.jpg%3Ff%3DLandscape%2B16%253A9%26w%3D770%26q%3D1&amp;w=750&amp;q=60 750w, /_next/image?url=https%3A%2F%2Fcdn.newsday.com%2Fimage-service%2Fversion%2Fc%3AMTlkNTRhNjItNDk4OC00%3AZGI4Njhl%2Fsports-cropped.jpg%3Ff%3DLandscape%2B16%253A9%26w%3D770%26q%3D1&amp;w=828&amp;q=60 828w, /_next/image?url=https%3A%2F%2Fcdn.newsday.com%2Fimage-service%2Fversion%2Fc%3AMTlkNTRhNjItNDk4OC00%3AZGI4Njhl%2Fsports-cropped.jpg%3Ff%3DLandscape%2B16%253A9%26w%3D770%26q%3D1&amp;w=1080&amp;q=60 1080w, /_next/image?url=https%3A%2F%2Fcdn.newsday.com%2Fimage-service%2Fversion%2Fc%3AMTlkNTRhNjItNDk4OC00%3AZGI4Njhl%2Fsports-cropped.jpg%3Ff%3DLandscape%2B16%253A9%26w%3D770%26q%3D1&amp;w=1200&amp;q=60 1200w, /_next/image?url=https%3A%2F%2Fcdn.newsday.com%2Fimage-service%2Fversion%2Fc%3AMTlkNTRhNjItNDk4OC00%3AZGI4Njhl%2Fsports-cropped.jpg%3Ff%3DLandscape%2B16%253A9%26w%3D770%26q%3D1&amp;w=1920&amp;q=60 1920w, /_next/image?url=https%3A%2F%2Fcdn.newsday.com%2Fimage-service%2Fversion%2Fc%3AMTlkNTRhNjItNDk4OC00%3AZGI4Njhl%2Fsports-cropped.jpg%3Ff%3DLandscape%2B16%253A9%26w%3D770%26q%3D1&amp;w=2048&amp;q=60 2048w, /_next/image?url=https%3A%2F%2Fcdn.newsday.com%2Fimage-service%2Fversion%2Fc%3AMTlkNTRhNjItNDk4OC00%3AZGI4Njhl%2Fsports-cropped.jpg%3Ff%3DLandscape%2B16%253A9%26w%3D770%26q%3D1&amp;w=3840&amp;q=60 3840w" imagesizes="100vw"/><meta name="next-head-count" content="45"/><link rel="preconnect" href="https://fonts.gstatic.com"/><link rel="preload" as="style" data-href="https://fonts.googleapis.com/css2?family=Lato:wght@400;700;900&amp;family=Work+Sans:wght@600;800&amp;display=swap"/><link rel="preload" as="script" href="https://www.newsday.com/js/launch-prod/29e082cdf7d4/d4c7792a643b/launch-ENe1484b2b97da4cf1bd7f7a777f05562c.min.js"/><script src="https://www.newsday.com/js/launch-prod/29e082cdf7d4/d4c7792a643b/launch-ENe1484b2b97da4cf1bd7f7a777f05562c.min.js" async=""></script><link rel="preconnect" href="https://fonts.gstatic.com" crossorigin /><link rel="preload" href="/_next/static/css/3db6cfa778808b50.css" as="style"/><link rel="stylesheet" href="/_next/static/css/3db6cfa778808b50.css" data-n-g=""/><link rel="preload" href="/_next/static/css/a851682128e081cd.css" as="style"/><link rel="stylesheet" href="/_next/static/css/a851682128e081cd.css" data-n-p=""/><link rel="preload" href="/_next/static/css/7d11d2e3f3c2172a.css" as="style"/><link rel="stylesheet" href="/_next/static/css/7d11d2e3f3c2172a.css" data-n-p=""/><noscript data-n-css=""></noscript><script defer="" nomodule="" src="/_next/static/chunks/polyfills-5cd94c89d3acac5f.js"></script><script src="/_next/static/chunks/webpack-1d90a0def7ee4a30.js" defer=""></script><script src="/_next/static/chunks/framework-4fadf02ee0c3c13f.js" defer=""></script><script src="/_next/static/chunks/main-99969ae04933af42.js" defer=""></script><script src="/_next/static/chunks/pages/_app-09bab1a8730f5806.js" defer=""></script><script src="/_next/static/chunks/2852872c-c4285623ae6a0fa4.js" defer=""></script><script src="/_next/static/chunks/75fc9c18-70e04920b0b139c8.js" defer=""></script><script src="/_next/static/chunks/553-83cf2d6b279f7fd1.js" defer=""></script><script src="/_next/static/chunks/743-a1f5c8b0ec62e9a5.js" defer=""></script><script src="/_next/static/chunks/382-04d859efa32ed8da.js" defer=""></script><script src="/_next/static/chunks/502-78d05a81702303a3.js" defer=""></script><script src="/_next/static/chunks/pages/%5B...pages%5D-23b6bfd56d02e232.js" defer=""></script><script src="/_next/static/newsday-prod-20220727145940/_buildManifest.js" defer=""></script><script src="/_next/static/newsday-prod-20220727145940/_ssgManifest.js" defer=""></script><script src="/_next/static/newsday-prod-20220727145940/_middlewareManifest.js" defer=""></script><style data-href="https://fonts.googleapis.com/css2?family=Lato:wght@400;900&family=Work+Sans:wght@700&display=swap">@font-face{font-family:'Lato';font-style:normal;font-weight:400;font-display:swap;src:url(https://fonts.gstatic.com/s/lato/v23/S6uyw4BMUTPHvxo.woff) format('woff')}@font-face{font-family:'Lato';font-style:normal;font-weight:900;font-display:swap;src:url(https://fonts.gstatic.com/s/lato/v23/S6u9w4BMUTPHh50Xeww.woff) format('woff')}@font-face{font-family:'Work Sans';font-style:normal;font-weight:700;font-display:swap;src:url(https://fonts.gstatic.com/s/worksans/v17/QGY_z_wNahGAdqQ43RhVcIgYT2Xz5u32K67QNis.woff) format('woff')}@font-face{font-family:'Lato';font-style:normal;font-weight:400;font-display:swap;src:url(https://fonts.gstatic.com/s/lato/v23/S6uyw4BMUTPHjxAwXiWtFCfQ7A.woff2) format('woff2');unicode-range:U+0100-024F,U+0259,U+1E00-1EFF,U+2020,U+20A0-20AB,U+20AD-20CF,U+2113,U+2C60-2C7F,U+A720-A7FF}@font-face{font-family:'Lato';font-style:normal;font-weight:400;font-display:swap;src:url(https://fonts.gstatic.com/s/lato/v23/S6uyw4BMUTPHjx4wXiWtFCc.woff2) format('woff2');unicode-range:U+0000-00FF,U+0131,U+0152-0153,U+02BB-02BC,U+02C6,U+02DA,U+02DC,U+2000-206F,U+2074,U+20AC,U+2122,U+2191,U+2193,U+2212,U+2215,U+FEFF,U+FFFD}@font-face{font-family:'Lato';font-style:normal;font-weight:900;font-display:swap;src:url(https://fonts.gstatic.com/s/lato/v23/S6u9w4BMUTPHh50XSwaPGQ3q5d0N7w.woff2) format('woff2');unicode-range:U+0100-024F,U+0259,U+1E00-1EFF,U+2020,U+20A0-20AB,U+20AD-20CF,U+2113,U+2C60-2C7F,U+A720-A7FF}@font-face{font-family:'Lato';font-style:normal;font-weight:900;font-display:swap;src:url(https://fonts.gstatic.com/s/lato/v23/S6u9w4BMUTPHh50XSwiPGQ3q5d0.woff2) format('woff2');unicode-range:U+0000-00FF,U+0131,U+0152-0153,U+02BB-02BC,U+02C6,U+02DA,U+02DC,U+2000-206F,U+2074,U+20AC,U+2122,U+2191,U+2193,U+2212,U+2215,U+FEFF,U+FFFD}@font-face{font-family:'Work Sans';font-style:normal;font-weight:700;font-display:swap;src:url(https://fonts.gstatic.com/s/worksans/v17/QGY_z_wNahGAdqQ43RhVcIgYT2Xz5u32K67QBiAJoI3ZKyHaQfhf.woff) format('woff');unicode-range:U+0102-0103,U+0110-0111,U+0128-0129,U+0168-0169,U+01A0-01A1,U+01AF-01B0,U+1EA0-1EF9,U+20AB}@font-face{font-family:'Work Sans';font-style:normal;font-weight:700;font-display:swap;src:url(https://fonts.gstatic.com/s/worksans/v17/QGY_z_wNahGAdqQ43RhVcIgYT2Xz5u32K67QBiEJoI3ZKyHaQfhf.woff) format('woff');unicode-range:U+0100-024F,U+0259,U+1E00-1EFF,U+2020,U+20A0-20AB,U+20AD-20CF,U+2113,U+2C60-2C7F,U+A720-A7FF}@font-face{font-family:'Work Sans';font-style:normal;font-weight:700;font-display:swap;src:url(https://fonts.gstatic.com/s/worksans/v17/QGY_z_wNahGAdqQ43RhVcIgYT2Xz5u32K67QBi8JoI3ZKyHaQQ.woff) format('woff');unicode-range:U+0000-00FF,U+0131,U+0152-0153,U+02BB-02BC,U+02C6,U+02DA,U+02DC,U+2000-206F,U+2074,U+20AC,U+2122,U+2191,U+2193,U+2212,U+2215,U+FEFF,U+FFFD}</style></head><body><div id="__next" data-reactroot=""><link rel="shortcut icon" href="/img/newsday/favicon.ico" type="image/x-icon"/><link rel="apple-touch-icon" sizes="180x180" href="/img/newsday/apple-touch-icon-120x120.png"/><header class="Header_masthead__H8Ys6 " role="banner"><div class="Header_container__7nNih container"><div class="Header_headL__rc56_ "><a href="#site-content" class="Header_skip-play__CoFXL">Skip to content</a><button class="Header_menu-btn__I72i8 mBtn" aria-label="Menu"><span></span><em>Menu</em></button><a class="actToggle Header_sBtn__2Bta7 ss" href="/eedition"><em>Today&#x27;s paper</em></a></div><a class="Header_logo__gECVj" href="/"><img alt="Newsday" src="/img/newsdayLogo.svg" width="140" height="48"/></a><div class="Header_headR___wLkG"><div class="Header_logStatus__75qZk"><a href="#" class="Header_not-loggedin__RiWAs logInbtn MG2login Header_active__lKnmL" data-mg2-action="activation"><em>Log in</em></a><div class="subacct MG2Subscribe Header_active__lKnmL"><a class="Header_tBtn__Uvfkt subacct Header_active__lKnmL" id="MG2Subscribe" href="/subscribe"><em>Subscribe </em><span>$1 FOR 5 MONTHS</span></a></div></div></div></div></header><div class="Header_sub-nav__ML115"><div class="Header_container__7nNih container"><div class="searchBox" data-step="9" data-intro="We&#x27;ve upgraded our search engine to help you find exactly what you are looking for."></div><nav id="nav"><a class="Header_long-island__FEqE_ " href="/long-island">Long Island</a><a class="Header_sports__KAVtN Header_active__lKnmL" href="/sports">Sports</a><a class="newsday-tv " href="https://tv.newsday.com">Newsday TV</a><a class="news " href="/news/nation">News</a><a class="feedme " href="/lifestyle/restaurants">FeedMe</a><a class="Header_opinion__AHXmR " href="/opinion">Opinion</a><a class="Header_business__huH8N " href="/business">Business</a><a class="obituaries " href="https://www.legacy.com/obituaries/newsday/">Obituaries</a><a class="newsday-live " href="/newsday-live">Newsday Live</a><a class="Header_search__esM9R " href="/search">Search</a></nav></div></div><div class="SandwichNav_pane__h00mP"><button aria-label="Close" class="SandwichNav_x__k2ZiE btn"></button><section class="Weather_weather__96w_g"></section></div><link rel="alternate" type="application/rss+xml" title="Most recent from newsday.com" href="/api/rss/recent"/><main class="container"><article class="story  sports high-school high-school-football"><div class="ad_full-banner__7KJ4Q ad_ad__3q0Ak ad_top__OVens"></div><header id="head" class="PageHeader_page-top__AalO8 "><strong class="Breadcrumbs_breadcrumb__N9C7C"><a href="/sports">Sports</a><a href="/sports/high-school">High School</a><a href="/sports/high-school/football">High School Football</a></strong><h1>Carey’s Mike Catanese undisputed leader of LI’s offense</h1></header><div class="primary"><figure class="Image_img__4B696 landscape  eager"><span style="box-sizing:border-box;display:block;overflow:hidden;width:initial;height:initial;background:none;opacity:1;border:0;margin:0;padding:0;position:relative"><span style="box-sizing:border-box;display:block;width:initial;height:initial;background:none;opacity:1;border:0;margin:0;padding:0;padding-top:56.25%"></span><img alt="Quarterback Michael Catanese school from Carey High School playing for..." sizes="100vw" srcSet="/_next/image?url=https%3A%2F%2Fcdn.newsday.com%2Fimage-service%2Fversion%2Fc%3AMTlkNTRhNjItNDk4OC00%3AZGI4Njhl%2Fsports-cropped.jpg%3Ff%3DLandscape%2B16%253A9%26w%3D770%26q%3D1&amp;w=640&amp;q=60 640w, /_next/image?url=https%3A%2F%2Fcdn.newsday.com%2Fimage-service%2Fversion%2Fc%3AMTlkNTRhNjItNDk4OC00%3AZGI4Njhl%2Fsports-cropped.jpg%3Ff%3DLandscape%2B16%253A9%26w%3D770%26q%3D1&amp;w=750&amp;q=60 750w, /_next/image?url=https%3A%2F%2Fcdn.newsday.com%2Fimage-service%2Fversion%2Fc%3AMTlkNTRhNjItNDk4OC00%3AZGI4Njhl%2Fsports-cropped.jpg%3Ff%3DLandscape%2B16%253A9%26w%3D770%26q%3D1&amp;w=828&amp;q=60 828w, /_next/image?url=https%3A%2F%2Fcdn.newsday.com%2Fimage-service%2Fversion%2Fc%3AMTlkNTRhNjItNDk4OC00%3AZGI4Njhl%2Fsports-cropped.jpg%3Ff%3DLandscape%2B16%253A9%26w%3D770%26q%3D1&amp;w=1080&amp;q=60 1080w, /_next/image?url=https%3A%2F%2Fcdn.newsday.com%2Fimage-service%2Fversion%2Fc%3AMTlkNTRhNjItNDk4OC00%3AZGI4Njhl%2Fsports-cropped.jpg%3Ff%3DLandscape%2B16%253A9%26w%3D770%26q%3D1&amp;w=1200&amp;q=60 1200w, /_next/image?url=https%3A%2F%2Fcdn.newsday.com%2Fimage-service%2Fversion%2Fc%3AMTlkNTRhNjItNDk4OC00%3AZGI4Njhl%2Fsports-cropped.jpg%3Ff%3DLandscape%2B16%253A9%26w%3D770%26q%3D1&amp;w=1920&amp;q=60 1920w, /_next/image?url=https%3A%2F%2Fcdn.newsday.com%2Fimage-service%2Fversion%2Fc%3AMTlkNTRhNjItNDk4OC00%3AZGI4Njhl%2Fsports-cropped.jpg%3Ff%3DLandscape%2B16%253A9%26w%3D770%26q%3D1&amp;w=2048&amp;q=60 2048w, /_next/image?url=https%3A%2F%2Fcdn.newsday.com%2Fimage-service%2Fversion%2Fc%3AMTlkNTRhNjItNDk4OC00%3AZGI4Njhl%2Fsports-cropped.jpg%3Ff%3DLandscape%2B16%253A9%26w%3D770%26q%3D1&amp;w=3840&amp;q=60 3840w" src="/_next/image?url=https%3A%2F%2Fcdn.newsday.com%2Fimage-service%2Fversion%2Fc%3AMTlkNTRhNjItNDk4OC00%3AZGI4Njhl%2Fsports-cropped.jpg%3Ff%3DLandscape%2B16%253A9%26w%3D770%26q%3D1&amp;w=3840&amp;q=60" decoding="async" data-nimg="responsive" style="position:absolute;top:0;left:0;bottom:0;right:0;box-sizing:border-box;padding:0;border:none;margin:auto;display:block;width:0;height:0;min-width:100%;max-width:100%;min-height:100%;max-height:100%"/></span><figcaption><p>Quarterback Michael Catanese school from Carey High School playing for the Long Island team during the Empire Challenge High School football practice, which pits the top Long Island seniors against the top New York City seniors at Hofstra, on Monday, June 20, 2016.<!-- --> Credit: Andrew Theodorakis/ Andrew Theodorakis</p></figcaption></figure><div class="Byline_byline__6oRUO"><strong>By <!-- -->Kenny DeJohn</strong><a href="mailto:kenny.dejohn@newsday.com?subject=Carey’s Mike Catanese undisputed leader of LI’s offense">kenny.dejohn@newsday.com</a><time dateTime="2016-06-23T02:42:00.917Z">June 22, 2016</time></div><div class="share-tools_share-tools__Dp35p"><a class="share-tools_fb__R9Wr5" rel="noopener noreferrer" href="https://www.facebook.com/sharer/sharer.php?u=https://www.newsday.com/sports/high-school/football/carey-s-mike-catanese-undisputed-leader-of-li-s-offense-r90887" width="600" height="360" target="_blank"><svg class="Icon_icon__QfSMz"><use href="/img/site-icon-sprites.svg?v=newsday-prod-20220727145940#facebook-f"></use></svg> </a><a class="share-tools_tw__eGGWu" rel="noopener noreferrer" href="https://twitter.com/intent/tweet?text=Carey’s Mike Catanese undisputed leader of LI’s offense&amp;url=https://www.newsday.com/sports/high-school/football/carey-s-mike-catanese-undisputed-leader-of-li-s-offense-r90887&amp;via=Newsday" data-mention="@Newsday" width="550" height="440" target="_blank"><svg class="Icon_icon__QfSMz"><use href="/img/site-icon-sprites.svg?v=newsday-prod-20220727145940#twitter"></use></svg> </a><a class="share-tools_env__eRS0O" href="mailto:?subject=Carey’s Mike Catanese undisputed leader of LI’s offense&amp;body=undefined,%0D%0Ahttps://www.newsday.com/sports/high-school/football/carey-s-mike-catanese-undisputed-leader-of-li-s-offense-r90887" data-rel="external"><svg class="Icon_icon__QfSMz"><use href="/img/site-icon-sprites.svg?v=newsday-prod-20220727145940#envelope"></use></svg> </a><button class="share-tools_print-btn__HpVlH print"><svg class="Icon_icon__QfSMz"><use href="/img/site-icon-sprites.svg?v=newsday-prod-20220727145940#print"></use></svg></button></div><div class="contentAccess"><div class="ContinueReading_continue-reading__SAZgU " style="max-height:100%"><p>Carey’s Mike Catanese was the second quarterback on the Long Island depth chart for Tuesday night’s Empire Challenge, a 39-34 win for New York City. But when it was all said and done, Catanese was the leader of the offense.</p><p>Catanese, a 6-3 passer, came into the game during Long Island’s second series and immediately found his footing, eventually snagging late-game snaps from Newfield’s Ryan Klemm.</p><p>The offense found consistency with Catanese under center, as he went 10-for-19 for 163 yards and a touchdown en route to being named Long Island player of the game.</p><div class=""></div><p>He also rushed seven times for 33 yards and a touchdown.</p><p>“We had great line play and great wide receivers, so I just had to put the ball in a decent spot and the wide receivers went and got it,” he said, deflecting praise to his teammates.</p><div class="Newsletter_newsletter-widget__XU6fU"><div><strong for="userContact">Subscribe to Newsday&#x27;s high school sports newsletter.</strong><p>Newsday&#x27;s weekly newsletter takes you on the field and inside the high school sports scene across Long Island.</p><p class="frequency"></p></div><div><form class="subscribeForm" action="" method="POST"><input type="email" class="false" name="email" placeholder="Email address" required="" autoComplete="email"/><button class="btn">Sign up</button></form></div><p class="Newsletter_disclaimer__ehQ25">By clicking Sign up, you agree to our<!-- --> <a href="/privacy">privacy policy</a>.</p></div><p>One of the game’s biggest highlights came from Catanese on a fourth-and-4 halfway through the first quarter. He took the snap, scrambled in the backfield and got hit by a lineman as he fired a strike to Patchogue-Medford’s Nico Morabito, who hauled it in for a 26-yard gain.</p><p>That conversion led to the game’s first score, a 9-yard sweep from left to right by Huntington’s Infinite Tucker.</p><div class="embedphotolist_embed-photo-list__NaQLV"><a href="/sports/high-school/football/empire-challenge-2016-practice-pictures-h70500"><figure class="Image_img__4B696 landscape  lazy"><span style="box-sizing:border-box;display:block;overflow:hidden;width:initial;height:initial;background:none;opacity:1;border:0;margin:0;padding:0;position:relative"><span style="box-sizing:border-box;display:block;width:initial;height:initial;background:none;opacity:1;border:0;margin:0;padding:0;padding-top:56.25%"></span><img alt="" src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" decoding="async" data-nimg="responsive" style="position:absolute;top:0;left:0;bottom:0;right:0;box-sizing:border-box;padding:0;border:none;margin:auto;display:block;width:0;height:0;min-width:100%;max-width:100%;min-height:100%;max-height:100%"/><noscript><img alt="" sizes="100vw" srcSet="/_next/image?url=https%3A%2F%2Fcdn.newsday.com%2Fimage-service%2Fversion%2Fc%3ANTNhMTMwZGItZjNkYi00%3AY2E5MDBh%2Fsports.jpg%3Ff%3DLandscape%2B16%253A9%26w%3D770%26q%3D1&amp;w=640&amp;q=60 640w, /_next/image?url=https%3A%2F%2Fcdn.newsday.com%2Fimage-service%2Fversion%2Fc%3ANTNhMTMwZGItZjNkYi00%3AY2E5MDBh%2Fsports.jpg%3Ff%3DLandscape%2B16%253A9%26w%3D770%26q%3D1&amp;w=750&amp;q=60 750w, /_next/image?url=https%3A%2F%2Fcdn.newsday.com%2Fimage-service%2Fversion%2Fc%3ANTNhMTMwZGItZjNkYi00%3AY2E5MDBh%2Fsports.jpg%3Ff%3DLandscape%2B16%253A9%26w%3D770%26q%3D1&amp;w=828&amp;q=60 828w, /_next/image?url=https%3A%2F%2Fcdn.newsday.com%2Fimage-service%2Fversion%2Fc%3ANTNhMTMwZGItZjNkYi00%3AY2E5MDBh%2Fsports.jpg%3Ff%3DLandscape%2B16%253A9%26w%3D770%26q%3D1&amp;w=1080&amp;q=60 1080w, /_next/image?url=https%3A%2F%2Fcdn.newsday.com%2Fimage-service%2Fversion%2Fc%3ANTNhMTMwZGItZjNkYi00%3AY2E5MDBh%2Fsports.jpg%3Ff%3DLandscape%2B16%253A9%26w%3D770%26q%3D1&amp;w=1200&amp;q=60 1200w, /_next/image?url=https%3A%2F%2Fcdn.newsday.com%2Fimage-service%2Fversion%2Fc%3ANTNhMTMwZGItZjNkYi00%3AY2E5MDBh%2Fsports.jpg%3Ff%3DLandscape%2B16%253A9%26w%3D770%26q%3D1&amp;w=1920&amp;q=60 1920w, /_next/image?url=https%3A%2F%2Fcdn.newsday.com%2Fimage-service%2Fversion%2Fc%3ANTNhMTMwZGItZjNkYi00%3AY2E5MDBh%2Fsports.jpg%3Ff%3DLandscape%2B16%253A9%26w%3D770%26q%3D1&amp;w=2048&amp;q=60 2048w, /_next/image?url=https%3A%2F%2Fcdn.newsday.com%2Fimage-service%2Fversion%2Fc%3ANTNhMTMwZGItZjNkYi00%3AY2E5MDBh%2Fsports.jpg%3Ff%3DLandscape%2B16%253A9%26w%3D770%26q%3D1&amp;w=3840&amp;q=60 3840w" src="/_next/image?url=https%3A%2F%2Fcdn.newsday.com%2Fimage-service%2Fversion%2Fc%3ANTNhMTMwZGItZjNkYi00%3AY2E5MDBh%2Fsports.jpg%3Ff%3DLandscape%2B16%253A9%26w%3D770%26q%3D1&amp;w=3840&amp;q=60" decoding="async" data-nimg="responsive" style="position:absolute;top:0;left:0;bottom:0;right:0;box-sizing:border-box;padding:0;border:none;margin:auto;display:block;width:0;height:0;min-width:100%;max-width:100%;min-height:100%;max-height:100%" loading="lazy"/></noscript></span></figure><span class="embedphotolist_btn__4sr78 angle"><strong>SEE PHOTOS</strong>Empire Challenge 2016 practice<i class="fa fa-angle-right"></i></span></a></div><p>“With his accuracy on the field and his leadership, he took over the game,” said coach Joe Piccinnini, who is also the coach at Newfield. “We needed that taken care of. He stepped up and got the job done.”</p><p>Despite earning significant playing time in the second half because of his consistent play, Catanese was the second-stringer entering the game. A possible explanation, he said, was that he had to leave practices early the previous week for several awards dinners for baseball and academics.</p><p>While that may have had some influence in the quarterback pecking order, it didn’t stop Piccinnini and offensive coordinator Rob Hoss from putting the ball in Catanese’s hands when it mattered most.</p><div class=""></div><p>“Everybody has a role,” Piccinnini said. “When somebody’s doing better, that person’s going to play. You just go with who’s got the hot hand.”</p><p>Catanese proved himself ready for Cornell football, using the Empire Challenge as a litmus test against some of New York’s best players. He called it a tune up, citing the overwhelming college talent.</p><p>“If you look at the colleges all these players are going to on our team or their team, it’s all Division I or Division II,” he said. “They’re all great football players. It’s the best of the best.”</p><p>And Catanese certainly belonged, making accurate throws in traffic and acting as the offense’s leader from the second he stepped on the field.</p><div class="share-tools_share-tools__Dp35p share-method share-tools_big__rPHOS"><a class="share-tools_fb__R9Wr5" rel="noopener noreferrer" href="https://www.facebook.com/sharer/sharer.php?u=https://www.newsday.com/sports/high-school/football/carey-s-mike-catanese-undisputed-leader-of-li-s-offense-r90887" width="600" height="360" target="_blank"><svg class="Icon_icon__QfSMz"><use href="/img/site-icon-sprites.svg?v=newsday-prod-20220727145940#facebook-f"></use></svg> <span>Share on Facebook</span></a><a class="share-tools_tw__eGGWu" rel="noopener noreferrer" href="https://twitter.com/intent/tweet?text=Carey’s Mike Catanese undisputed leader of LI’s offense&amp;url=https://www.newsday.com/sports/high-school/football/carey-s-mike-catanese-undisputed-leader-of-li-s-offense-r90887&amp;via=Newsday" data-mention="@Newsday" width="550" height="440" target="_blank"><svg class="Icon_icon__QfSMz"><use href="/img/site-icon-sprites.svg?v=newsday-prod-20220727145940#twitter"></use></svg> <span>Share on Twitter</span></a><a class="share-tools_env__eRS0O" href="mailto:?subject=Carey’s Mike Catanese undisputed leader of LI’s offense&amp;body=undefined,%0D%0Ahttps://www.newsday.com/sports/high-school/football/carey-s-mike-catanese-undisputed-leader-of-li-s-offense-r90887" data-rel="external"><svg class="Icon_icon__QfSMz"><use href="/img/site-icon-sprites.svg?v=newsday-prod-20220727145940#envelope"></use></svg> <span>Email this story</span></a></div></div></div></div><div class="secondary"><div class="ad_ad__3q0Ak ad_cube-ad__YFnqM"></div><div class="ad_ad__3q0Ak ad_cube-ad__YFnqM"></div><div id="hs-article-rail" class="topSiteStories"><div class="ModHead_mod-head__qiTdb"><h2>More High Schools</h2></div><div class="headlines"><a class="Headline_headline-item__71tkf no-teaser sports high-school high-school-football time-on" href="/sports/high-school/football/commack-football-weiss-kq981djq"></a><a class="Headline_headline-item__71tkf no-teaser sports high-school time-on" href="/sports/high-school/high-school-sports-fan-behavior-p59i6nnu"></a><a class="Headline_headline-item__71tkf no-teaser sports high-school wrestling time-on" href="/sports/high-school/wrestling/anthony-cipriano-obituary-copiague-gcm1ayqi"></a><a class="Headline_headline-item__71tkf no-teaser sports high-school wrestling time-on" href="/sports/high-school/wrestling/dunia-sibomana-wrestling-long-beach-congo-ynbuhjfp"></a><a class="Headline_headline-item__71tkf no-teaser sports high-school high-school-football time-on" href="/sports/high-school/football/nassau-county-seedings-2022-kqbsb367"></a></div></div><div class="ad_ad__3q0Ak ad_cube-ad__YFnqM"></div></div><div id="pageData" data-omni="{&quot;setblockedsite&quot;:&quot;metered&quot;,&quot;setblocked&quot;:&quot;metered&quot;}"></div><div class="nativo"></div></article></main><style id="nd_custom_section_css">select::-ms-expand { display: none; } .select { display: grid; border-radius: 6px; padding: 8px 12px; grid-template-areas: &quot;select&quot;; align-items: center; position: relative; max-width: 20ch; width: 100%; border: 1px solid #9baab5; cursor: pointer; align-self: center; background: linear-gradient(0deg, rgba(228,234,240,1) 0%, rgba(255,255,255,1) 100%); } .select:focus-within { outline: 0; box-shadow: inset 0 0 0 3px rgba(0,123,255,.5); } .select select, .select select:focus, .select::after { grid-area: select; border:0; background: transparent; font-size: 1.6rem; } .select::after { content: &quot;&quot;; justify-self: end; width: 1em; height: 0.6em; background-color: #666; -webkit-clip-path: polygon(100% 0%, 0 0%, 50% 100%); clip-path: polygon(100% 0%, 0 0%, 50% 100%); } .content-group { display: flex; flex-direction: row; gap: 11px; justify-content: flex-start; align-content: center; } .select-group { display: flex; flex-direction: row; gap: 11px; justify-content: flex-start; align-content: center; flex-wrap: wrap; flex-grow: 1; flex-basis: calc(100% - 120px); } .sponsor { margin-left: auto; align-self: center; flex-basis: 120px; } .sponsor a { font-size: 1rem; text-align: right; display: block; color: #666; } .sponsor img { display: block; margin-top: -14px; max-width: none; }</style><div class="Footer_footer-search__y7pUg"><div class="be-ix-link-block"></div><strong>Didn&#x27;t find what you were looking for?</strong><form name="search-form" method="GET" action=""><fieldset><input type="search" class="text" placeholder="Search newsday.com" autoComplete="off" autoCorrect="off" maxLength="512"/><button value="Search" class="ltBtn" type="submit" aria-label="Search"><svg class="Icon_icon__QfSMz"><use href="/img/site-icon-sprites.svg?v=newsday-prod-20220727145940#search"></use></svg></button></fieldset></form></div><div class="ad_full-banner__7KJ4Q ad_ad__3q0Ak bottom"></div><footer class="Footer_site-footer__O9YZP"><div id="toaster-wrap" class="subOffer fixed-bottom"></div><section id="foot" class="container"><div class="Footer_link-columns__4K4MZ"><nav class="col-4"><h3>Quick Links</h3><a href="https://projects.newsday.com/long-island/about-us/">About Us</a><a href="/subscribe">Subscribe</a><a href="https://paper.newsday.com">Today&#x27;s paper</a><a href="/newsletters">Email newsletters</a><a href="/newsday-live">Newsday Live</a><a href="https://www.newsdaycharities.org/">Newsday Charities</a><a href="/careers">Careers</a><a href="/manageaccount">Manage my account</a><a href="https://mediakit.newsday.com/">Media Kit</a><a href="https://mediakit.newsday.com/brand360/">Brand 360</a><a href="/services/newsday-apps-ios-android-wdhvqyhx">Mobile &amp; TV apps</a><a href="/services/contest">Contests</a><a href="https://newsday.newspapers.com/">Archives</a></nav><nav class="col-4"><h3>Partners</h3><a href="https://productions.newsday.com/">Newsday Productions</a><a href="/classifieds/cars">Newsday Cars</a><a href="/classifieds/real-estate">Newsday Homes</a><a href="/classifieds/jobs">Newsday Jobs</a><a href="https://newsdayconnect.com/">Newsday Connect</a><a href="http://www.hometownshopperli.com/">Hometown Shopper</a></nav><nav class="col-4"><h3>News</h3><a href="/long-island">Long Island</a><a href="/sports">Sports</a><a href="/opinion">Opinion</a><a href="/long-island/politics">Politics</a><a href="/news/nation">News</a><a href="/business">Business</a><a href="/long-island/towns">Towns</a><a href="/sports/high-school">High school sports</a></nav><nav class="col-4"><h3>More</h3><a href="/funbook">Funbook</a><a href="https://www.legacy.com/obituaries/newsday/">Obituaries</a><a href="/entertainment/crossword-puzzle">Crosswords</a><a href="/lifestyle">Things to Do</a><a href="/entertainment">Entertainment</a><a href="/lifestyle/restaurants">Restaurants</a><a href="/lifestyle/family">Family</a><a href="/travel">Travel</a></nav></div><p><a href="/privacy">Privacy Policy</a> <!-- -->|<a href="/terms">Terms of service</a> <!-- -->|<a href="/homedeliveryterms">Subscription terms</a> <!-- -->|<a href="/services/ad-choices-s4co9cpn">Your ad choices</a> <!-- -->|<a class="ot-sdk-show-settings" href="/sports/high-school/football/carey-s-mike-catanese-undisputed-leader-of-li-s-offense-r90887#">Cookie Settings</a> <!-- -->|<a href="/services/newsday-llc-privacy-policy-fasg61nc#cal">California Privacy Rights</a> <!-- -->|<a href="https://projects.newsday.com/long-island/about-us/">About Us</a> <!-- -->|<a href="/contact">Contact Newsday</a> <!-- -->|<a href="http://www.newsdayreprints.com/">Reprints &amp; permissions</a> <!-- -->|<a href="/advertise">Advertise with Newsday</a> <!-- -->|<a href="/help">Help</a></p><p class="copyright">Copyright ©<!-- -->2022<!-- --> Newsday. All rights reserved.</p><div class="Footer_soc__yODjP"><a aria-label="Visit Newsday on Facebook" href="/facebook"><svg class="Icon_icon__QfSMz"><use href="/img/site-icon-sprites.svg?v=newsday-prod-20220727145940#facebook-f"></use></svg></a><a aria-label="Visit Newsday on Twitter" href="/twitter"><svg class="Icon_icon__QfSMz"><use href="/img/site-icon-sprites.svg?v=newsday-prod-20220727145940#twitter"></use></svg></a><a aria-label="Visit Newsday on Instagram" href="https://www.instagram.com/newsday"><svg class="Icon_icon__QfSMz"><use href="/img/site-icon-sprites.svg?v=newsday-prod-20220727145940#instagram"></use></svg></a></div></section></footer></div><script id="__NEXT_DATA__" type="application/json">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</script></body></html>